Large Corrupted Project

Hi, so I use Audacity for editing a Dungeons and Dragons podcast with my friends. While editing this week’s episode, I ran into an issue where it wasn’t letting me edit on a person’s track in the project. Each time I tried cutting something from it or interacting with it in general, it would give me an error that it couldn’t read a file on my hard drive. After this happened for a while, I tried closing out the project and re-opening it. Whenever I went to open the project file, I am met with a “Project is corrupt (unable to work with block files)” error message. I don’t know how to fix this and would love some help. I’ve pasted the log below. I’m using Windows 10 and use Audacity 3.1.3.

    "timestamp": 1663934781,
    "event_id": "a1d03a05b8377b4e988b7a582352632f",
    "platform": "native",
    "release": "audacity@3.1.3",
    "contexts": {
        "os": {
            "type": "os",
            "name": "Windows",
            "version": "10.0.19043"
    "exception": {
        "values": [
                "type": "Error_Opening_Project",
                "value": "Project is corrupt\n(Unable to work with the blockfiles)",
                "mechanism": {
                    "type": "runtime_error",
                    "handled": false,
                    "data": {
                        "sqlite3.query": "DELETE FROM sampleblocks WHERE NOT inset(blockid);",
                        "sqlite3.rc": "11",
                        "sqlite3.context": "ProjectGileIO::GetBlob",
                        "log": "Error: Project is corrupt\n(Unable to work with the blockfiles)\n07:06:20: Loaded 110 string <path> Kb in size\n07:06:20: sqlite3 message: (11) database corruption at line 71416 of [1b256d97b5]\n07:06:20: sqlite3 message: (11) statement aborts at 8: [DELETE FROM sampleblocks WHERE NOT inset(blockid);] database disk image is malformed\n07:06:20: DBConnection SetDBError\n\tErrorCode: 11\n\tLastError: Project is corrupt\n(Unable to work with the blockfiles)\n\tLibraryError: database disk image is malformed\n"

Yes. Unfortunately, this “11” is SQL shorthand for “The SQLITE_CORRUPT result code indicates that the database file has been corrupted.”

Fortunately, in many cases the issue may be corrected. See the first post in this thread for details: