Lame_Enc not being recognised/detected

Hello all,

I am fairly new to Audacity, though I did have a play with it a few years ago. The other day I wanted to take a piece of audio from the MP4 file. After watching a video on YouTube I then went through the process of installing the FFmpeg dll. For some reason, this was much harder than I thought it was gong to be. Audacity just would not recognise it. And I cannot actually remember what I had to do to get it to work.

Then a couple of days ago I was cutting up different parts of a podcast and putting them together into a new MP3 file for uploading to Facebook, in a technology group that I run. When I came to export the MP3 file, of course, I was told that I required the Lame-enc.dll. I then went and got that and successfully installed it.

However, again, Audacity just refuses to recognise it. I have tried both installing it via the EXE file and extracting it from the Zip. I have tried putting it in the Lame for to Audacity directory as well as one of my choosing. And though I can see both of these files, and have clicked on them, Audacity just refuses to acknowledge it.

I then searched the computer to see whether there was another Lame-enc.dll that might be causing a conflict, though I could not really see why this would be. And I found quite a few on there. So I decided not to delete them. As I use TextAloud to both read to me, and, more importantly in this context, to turn text into MP3s, I decided to point Audacity at the Lame dll in that directory. As I know that works perfectly. Again, Audacity just refuses to acknowledge it. I have also been into the config file and deleted the MP3 entry, and then tried relocating the dll within Audacity. Again, with no joy.

I read on here a post from a few days ago where a gentleman could not get the dll to install. Gale pointed him to an alternative program for making the MP3 files from an exported WAV file. This I have downloaded and successfully used for making my project into an MP3 file.

So it is not so much a case of how do I make up an MP3 file per se, as I can now do this thanks to the forum. It is more a point of why this is happening? It just annoys me that I have to have two programs on the system to get one task done when really Audacity should be able to do it in one foul swoop.

Can anyone please point me to a reason why this should be happening? And, whether there is anything I can do about it? It is just going to be one of those things that keeps gnawing at me until I can find a solution. And, as I say, I originally had a similar problem with the FFmpeg dll.

I have tried uninstalling and installing Audacity, a few times.

I am running Audacity 2.1.2 under the Windows 7 professional x64 system.

Thank you for any help that you might be able to give me.


We do not recommend looking at YouTube videos about Audacity. Some of them are misleading or incorrect, and most don’t say what version of Audacity they refer to.

All you should need to do is read the instructions in the Manual:

Audacity does not include pre-installed LAME or FFmpeg due to licensing restrictions. So you do have to install those libraries.

You can export MP3 using FFmpeg instead of LAME if you really want to, by choosing Custom FFmpeg Export. Select MP3 in the Formats list and libmp3lame in the Codecs list (the only choice).

Yes it is possible that other installed versions of FFmpeg or LAME could conflict, because Audacity also searches folders in your system PATH when looking for FFmepg or LAME. Do you have the current Audacity 2.1.2? See Help > About Audacity… . If you have the current version, Audacity should definitely look first for FFmpeg in \FFmpeg for Audacity. The FFmpeg installer we recommend defaults to installing there.

LAME conflicts don’t occur often. You could open Audacity Preferences, try to select and open lame_enc.dll and then attach the log from Help > Show Log… . Please see how to attach files to forum posts.


Hello, Gale,

First of all, thank you for your reply.

Yes, I can understand the recommendation for users not to use Youtube as a learning course. I had noticed on quite a few of the videos that they are using outdated versions, to the now new version.

I do understand why the lame DLL and FFmpeg DLL are not included within Audacity. And I was ready for this when I went to make the MP3. However, I think did not think that it would be as difficult as this to get my machine to accept it. And in no way am I trying to disparage Audacity for not loading them. I just found it strange.

I was completely unaware that you could get FFmpeg to do that. I will give that a go. As if this does cure the problem, as you have suggested, then not having the lame encoder recognised would not be that much of a problem for me; asit really is not using TAC. It is just more of an annoyance and a curiosity to me.

I did actually state in my original message that I am using version 2.1.2 of Audacity and that is being run under Windows 7 Professional. As it was at the bottom of the message then I can only guess that you quite naturally missed it? :smiley:

I will also have a look at opening the Audacity preferences and see if I can attach a log file.

Once again, thank you for your reply.


Sorry I did not notice your Audacity version at the bottom of your quite long post. If possible, please put the Audacity version at the start of your post. :wink:

What is TAC - TAudioConverter?


Yes. That was how I saw it referenced. My fault for not giving it its proper name. I apologise for that.

Well, I just went into Edit - Preferences- Libraries, in Audacity, and it has now picked up Lame 3.97 encoder from the TextAloud folder. I have checked it, and everything seems to be working.

I think that it is now time to backup the system.


We recommend LAME 3.99.3 installed using these instructions: I am not clear if you followed those instructions or some other instructions you saw. If you use that recommended installer, a Registry key is installed that Audacity will look for.

I really would not recommend using the lame_enc.dll supplied by other applications. The other application might lock the DLL.

Not all builds of lame_enc.dll work with Audacity. Some don’t have enough “symbols” built into them. Audacity should reject those with an error message.


Hello, Gale,

Originally I tried the ones gained from the site obtained from the Download button, in the Libraries section of Audacity. I originally tried the EXE file. When that did not work, I tried extracting the ZIP archive. When that did not work, I then tried both methods multiple times. It was then that I looked for conflicting versions. There are quite a few instances on the system. After I back up the system I will try again to get Audacity to recognise 3.99.3.


Hello, Gale,

I just tried again, and this time it accepted 3.99.3.


I’m using Windows 10 home & Audacity 2.3.0

The MP3 library adds fine.
I tried to repeat the process for Lame and I think I may have misdirected the library update on my first attempt.
So I tried again and I got an error saying the file is not found

I reinstalled both Audacity & the Lame libraries and I get the same thing.

The log (attached) says the Lame.exe is not present… but it is :slight_smile:
It’s installed on the exact path that Audacity is checking.

Thanks for your help

Lame error log.txt (16.9 KB)

Is that what you meant to say, or do you mean that you tried to repeat the process for “FFmpeg”?

It looks like FFmpeg is installed in the wrong place.

I’d suggest that you uninstall FFmpeg - if you installed with the “ffmpeg-win-2.2.2.exe”, then you should be able to uninstall from the Windows Control Panel (Add / Remove software).

For FFmpeg, you need to follow the instructions here:
The first set of instructions (using “ffmpeg-win-2.2.2.exe”, and not the “Alternative zip download”) should be all that is needed to install FFmpeg correctly.

That solved it!
Thanks very much !! :slight_smile: