Labels unreadable under track name

Is there a way to have all labels positioned a bit more below their default vertical position ? I notice the track name is always hiding labels at their default vertical position, so one has to move the label track back just in order to read hidden labels.


Perhaps you wish to include a screenshot illustrating the issue.

Hi, sorry for this answer lag. I have attached here a screenshot showing label tracks whose some labels get hidden by the track name. And the problem is not really solved by the horizontal zooming.

Thanks for the screenshot. No, I don’t have a solution for this - perhaps someone else does.

When I first saw your post, I was thinking label tracks didn’t have labels themselves. You can turn these off by unchecking “Show track name as Overlay” in Edit > Preferences > Tracks.

Note that in 3.1 and later, the “grab handle” at the top of audio tracks can contain the track label, and it does not overlay the audio. The current version of Audacity is 3.2.5.

My solution would be to either edit the label track name so that it is much shorter - or even delete it altogether.

Alternatively you could dispense with having the track names show ans overlays (they are off by default in preferences) and then edit the clip name on the audio track with the very long name that you require.


track names.png

Thanks a lot both for your answers.
Actually I really need to see the label track names while handling the audacity project, so switch off the “overlay” option is not an option for me.
As a matter of fact, I had a post in 2021 ( mentionning the same problem with label track. My audacity version is 2.4.2 because I am still on windows 7. Has the overlay transparency option been reintroduced in further audacity versions ?

On my computer with Audacity 2.4.2 I can simply resize the height of the label track a bit taller to see the labels. The track name does not generally cover the labels (except for sometimes the last label before the end of the track name, as you can see with label “06” below).

Maybe there’s a Windows 7 issue, but if that’s the case it won’t be fixed because Windows 7 is obsolete.
Also, there won’t be any fixes from the Audacity developers for Audacity 2.4.2 because it’s obsolete (though I still use it).


Thank you, Steve.

I don’t think it’s a Windows 7 issue, though.

Do you know if later audacity versions have reintroduce the track name transparency option ? If so, I might give a try to some of these later versions on Win7.

I’ve got translucent track name overlays in Audacity 3.2.4, but I don’t think it helps much - I find that it’s worse because the labels don’t try to dodge out of the way of the name overlay.


Do you need to see all of the name? In your screenshots, most of the name is the same and only the last part changes. If you changed
“Chora Tua Tristeza - Gal Costa - tempo 123,4-4”
“123,4-4 Chora Tua Tristeza - Gal Costa”
Then you would be able to see the important part (“123,4-4”) without the name overlay.

Thank you for this relatively good news about this transparency back in 3.2.4., I’ll give it a try on win7.

Actually, due to many audio and label tracks I use to have in many projects, the full track name is important to me and most of the time, even if transparency is far from clearest vision of track contents, It avoids me to move the track back all the time to figure out label content.

As I mentioned in the earlier post in 2021, the best solution for me would be having all labels systematically 1 cm below, i.e. always just below track name level, since it’s already what audacity does when labels are too near from each other. But I can use transparency if the 1cm suggestion is not an option. :wink:

Thank you all for help.

As a matter of fact, Steve, I just found your plugin “toggle-track-names.ny”, and it would be the easiest way to handle this issue for me.

So thanks also for this plugin.

Ah, this thing:
I’d forgotten that I’d written that :smiley:
Glad to hear that it’s still useful (5 years later :slight_smile:)