it starts playing when i add markers

i need to add a lot of markers to a song. im doing that with ctrl and b. every now and then playback starts on its own and i have not pressed space or the play buttin i am just adding markers. if i press space to stop it just adds a space in the marker so i press the stop buttin then i have to delete the last marker and do it again then it will be ok for a bit and then start playing again. this is insain why does it keep playing?
windows 7 with audacity 2.0.6

Try resetting the keyboard shortcuts.
To do that, go to “Edit > Preferences > Keyboard” and click on the “Defaults” button, then press “OK”.

no thats not it. its still doing it every time i get a bit of spped up. it dosnt do it when i add markers slowly. i never had this problem with the old version.

Are you 100% sure that you are not catching the spacebar?
What sort of keyboard do you have?
Are your keyboard or mouse wireless / bluetooth?
Does your computer have any other input devices, such as a track pad, wacom tablet, tracker ball…?
Are you using an ordinary mouse?

Does the location of the waves change just before it starts playing? The screen shift (not the “starting playing”) is a known problem if you type very fast. Bug 452 – Speed typing in a label shifts the screen.


Does the location of the waves change just before it starts playing?

No it just starts playing.

Are you 100% sure that you are not catching the spacebar?


What sort of keyboard do you have?

just an ordinary usb keyboard

Are your keyboard or mouse wireless / bluetooth?


Does your computer have any other input devices, such as a track pad, wacom tablet, tracker ball…?


Are you using an ordinary mouse?

yes. its a trust optical wheel mouse.

Nothing obvious comes to mind. This does not sound like any known bug.
Let’s break this down a bit…
I presume that when you say “markers” you mean “labels” (
Are you adding point labels or region labels?
How exactly (click by click) are you setting the position for the new label?

shit man i found it. i was holding onto the ctrl key too long when i made a label and that was makibg it play wehn i clicked to select the next bit. how did i manage to turn that on and how do i turn it off? i don’t see it in preferences.

Ctrl+click in the waveform to induce a Quick-Play is a barely advertised “feature” of Audacity - so hard to find and tricky to diagnose what you’ve done wrong.

So well done you for finding what you’d done there - and thanks for feeding back what happened.

And sorry, no there is no way to turn that off (would that you could).


It is a feature, but not one that is easy to advertise unless you read the playback sections of the Manual.

I’ve been calling for it to be “advertised” in the Status Bar for some time. The message could come on if you hold CTRL for more than a couple of seconds. Does someone have a better idea?


It is listed in the Mouse preferences (5th item in the list: Audacity Manual). Unfortunately these are not really “preferences” because they can’t (currently) be changed.

Also it is probably not all that obvious to look there, even if you could disable that binding. Most people I guess would look in Playback Preferences.


sorry for the late reply. i missed the reply notification.

my better idea is to not have it, or at least provide a way to tyurn it off.

yes i looked there.

Well I certainly would vote +1 for its removal:

  1. I fail to see the benefit of it over clicking in the Timeline which has long been the “advertised” way in the Manual for achieving a “Quick-Play”. I can never understand apps that have duplicated commands to achieve the same effect. Removing it would not thus reduce functionality

  2. because the implementation of scrubbing (in the alphas for 2.1.0) is also a Ctrl modified gesture on the waveform - in that case Ctrl+click+drag one has to be careful when using Ctrl+click for a Quick-Play to ensure that no dragging with the mouse occurs.

  3. The current implementation of Ctrl+click for a Quick-Play is dangerous in that it can interrupt an on-going recording

  4. If you need to click on the exact point on the waveform, which is the benefit that Gale ascribes to Ctrl+click (hard to do when zoomed in as the waveform moves too fast - and fairly useless when zoomed out due the loss of granularity at those zoom levels) then it is quite easy to click and the presss spacebar - still only two clicks. And ok if Audacity’s already playing then it’s just click followed by a rapid double-tap on the spacebar.


PS It’s also potentially moonphase buggy. In testing this just now with many Ctrl+clicks I managed to get Audacity playback into a big tangle where it moved the cursor backwards unbidden on the wave form playing a short section, then moving the cursor backward again prior to the previous point, playing there - repeating this till it got back to time 0 and then stopped playback altogether. Extremely odd and hard to reproduce - I will do some more testing on this later today. Anybody else seen such behaviour?

Some issues that I have noticed that may be responsible (or in part responsible):

  1. If the mouse moves laterally even a minute amount during the click action, the original selection is lost and a new (possibly invisibly small) selection is created.
  2. If the mouse click is fractionally before the current cursor position, playback may appear to not start, because it only plays up to the cursor. This is easy to do if (1) has occurred.
  3. Restarting playback with Ctrl+Click too rapidly loses the current selection and selects the audio clip under the mouse pointer.

Because of the above, Ctrl+Click playback is extremely erratic when using a touchpad rather than a mouse.

I agree with stevenknowles that the behaviour should be removed (because it is unnecessary and potentially confusing duplication of a long established behaviour), or at the very least an option for the user to disable it.

I can’t for the life of me repeat that odd moonphase behaviour - not for want of trying …

But I do note one other odd thing about the Ctrl+click Quick-Play behaviour that I really don’t think is right, is that you can not only Ctrl+click in the waveform to effect the Quick-Play you can also do so in the empty gray space below the waveform.

It’s also somewhat odd that you can’t Ctrl+click in the Timeline to start a Quick-Play (but I’m less concerned about that).


I’ve not looked at this behaviour much in detail because until very recently I was unaware that it existed, (as I think was the case for most of the other QA folk), but now that I look, the more issues I am finding.

This one is a definite bug:
Ctrl+Click on a track, or anywhere within the track window, after the end of the longest track.
The Play button is depressed (indicating playback) but no playback (there is nothing to play).

Here’s another:
Select the Envelope tool.
Hold down the Ctrl key. The Play button indicates Quick Play is activated.
Click anywhere in the track window - Quick Play does not start.
Same is true for all tools other than the Selection tool.

These bugs are probably not hard to fix, but my preferred fix would be to remove the Ctrl+Click Quick Play altogether (which is also the easiest fix).

The Ctrl+Click behaviors have changed throughout the various versions of Audacity.

Working on the ones I still have copies of:

from 1.3.5 all the way through 2.0.5 you cold effect Quick-Play with a Ctrl+click in the Waveform and the Timeline.

In 2.0.6 this changed so that you can Ctrl+click only in the waveform to effect Quick-Play

Then in the latest 2.1.0 alphas it changed again so you can Ctrl+click in the waveform and the gray space under the waveform - but not in the Timeline.

So its behavior has been somewhat erratic over the years - and those changes of behavior have gone undocumented.

I do have a fair number of the alpha versions so I could narrow down the 2.0.6=>2.1.0 alpha version where the behavior changed, but I really don’t think that’s worth spending time on.


It’s also slower and more effort if you are trying to find a particular spot, so need multiple clicks.

The alternative click to play in the Timeline can be a long stretch for eye and hand if you are trying to follow the right-hand channel of a stereo track.

I’m fine with having a Preference to enable CTRL-click play in the waveform. That way the feature would be advertised, if we are opposed to advertising it in the Status Bar.

I’m opposed to removing the feature until there is a better way than Timeline play to play from a spot in one step.


But surely Gale from the usage you are describing, both click in the Timeline and Ctrl+click in the waveform (et al.) are for you, just a “poor-man’s scrubbing” - functionality that we will address with much greater utility and precision when we get around after 2.1.0 to working on Paul L’s proper scrubbing to make it work properly.

And note that CtrL+click may well form part of how we eventually implement scrubbing as I note that Pauls is already using Ctrl modified gestures.