how to seperate one large track in to seperate tracks?

so i’ve read through all of the other related posts & looked through tutorials and such… but i can’t seem to find the answer to my problem…

i have one large track, where each song crossfades in to the next. it consists of about 15 songs and is around 78 minutes long.

i put label tracks in all the middles of each part where 2 tracks fade together. i did this by clicking where i wished & selected Tracks>Add Label At Selection, hoping of course that when i export & burn to a CD, that i could switch between tracks easier, instead of having just one track.

next i went to export multiple (like tutorials said), and filled in all the settings correctly (like the tutorial), and then clicked export.

this brings me in to a frenzy of having to click OK for about 150 different windows. they all are the same except for the track number. but there aren’t 150(or so) tracks in the file… i don’t understand what i’m doing wrong :frowning:

when i go to iTunes & try to import the file… the file didn’t seem to save at all. and it didn’t show a window in Audacity that it was saving after i clicked OK on all those windows.

ANYONE’S HELP WOULD BE MUCH APPRECIATED! thank you! :slight_smile:

You can avoid the “frenzy of clicking” by turning off the metadata editor - go to Edit > Preferences > Import/Export and uncheck the box that says “Show Metadata Editor prior to export step” - it’s an unfortunate default in Audacity which was done by the developers a whilke back to circumvent a bug they couldn’t fisx at the time.

Now on to the meat of your query. I am somewhat confused, you say that you are using export multiple - but you go on to talk about a single file “when I go to iTunes … the file …” - Export Multiple should produce a set of files, one per labelled track/song not a single file. Are you getting multiple files? Also what format are you exporting from Audacity to import into iTunes.



In case it helps here is my summarized workflow for getting “stuff” from Audacity to iTunes:

Workflow to take Audacity Projects to AAC in iTunes

  1. Record and edit the project in Audacity
  2. Export as a set of WAV files (to facilitate correct ordering later I Label the tracks 01 <track_name_1>, 02 <track_name_2>, etc.)
  3. Import the WAV files into iTunes
  4. Use iTunes to make AAC copies (at your chosen bitrate) in the library of the WAV files
  5. Delete the WAV files from the library.
  6. Edit the metadata tags of the tracks/album
  7. And last but not least - backup my updated iTunes library
  8. Delete the Audacity project file (.aup and folder) to release hard disk space

    some more detail:

For step 1. I record and edit with Audacity set at 44.1kHz and 32-bit floating stereo (this gives me good headroom for any required editing) – I down-sample on export to 44.1Khz 16-bit PCM stereo (the Red Book standard for CDs)

For step 2. – I down-sample on export to 44.1Khz 16-bit PCM stereo (the Red Book standard for CDs). All the files for a particular album or show are placed in a specific named folder for that album/show.

For Step 3. in my iTunes application I have the Import Settings ( Edit > Preferences > General > Import Settings ) set to Import Using AAC and with my preferred bitrate set via Custom. I then add the folder created in step 2 above to the iTunes library with the File > Add Folder to Library. This loads the WAV files into the library.

For Step 4. One of the columns I always have showing in my iTunes library is Bitrate. Clicking on the Bitrate column header will re-order the display by bitrate (you need to have All Genres/Artists/Albums showing).
The WAV files should show up as a set at the top of the list (or bottom) - mine show at a bitrate of 1411 kbps. Alternatively you could activate the Kind column - whereby the imported files will show as WAV and similarly clicking on the Kind column header will produce a suitable ordering for you… Select all the WAV files that you need to convert and then use Advanced > Create AAC version.

Actually to facilitate later location of the converted files I usually edit the common metadata tags for the set of WAVS whilst they are selected - most importantly the album/show name.

For Step 5. The WAV files should still be the only selected tunes at this stage, providing that you have done no further clicking - just take extreme care at this stage (the AACs are created but selection is not forced by iTunes) So then I just Delete the selected files using the Delete key - and send the files to my wastebasket (Note carefully that my iTunes is set to copy files in NOT to reference external files - so the WAVs that are deleted are copies of the original source WAVs that iTunes made in my library in step 3. This is set in Edit > Preferences > Advanced with the “Copy tunes into iTunes folder when adding to library” tickbox.)

For Step 6. In order to edit the metadata for Song Name etc - the album is easy to locate as I have already edited the Album tag in Step 4 above.

Step 7. This is a critical step – as I have no desire to lose the valuable fruits of my labours. I maintain two separate 1TB disks. On each disk I place a complete set of the WAV files I have created in their album/show named folders – with the album folders sorted by genre and placed in “Genre folders”. Each disk also contains two generations of backup of my iTunes libraries - (I actually don’t do this library backup after every update - but I do try to do it at least every couple of weeks so I have a roll-back point)..

Step 8. After the backups are made I can then safely release space on my onboard hard drive by deleting the Audacity project files and the originally exported WAV files which remain there.

Yes it’s a bit of work - but worth the effort IMHO :slight_smile:


Alternative Method

Actually there is an alternative method I sometimes use when transcribing a vinyl album. I usually make a CD of these from the set of WAV files, retaining the original ordering of course. I then load this CD into my PC - if I am lucky the Gracenote CDDB database will “recognize” the CD and supply all the necessary metadata for me (otherwise I edit the metadata tags and submit them to Gracenote). Then I can simply rip the CD into my iTunes library in the same way as I would do with a commercially produced CD.


It might help to post a screenshot of your project.

  1. Resize the project window so you can see the audio track and the label track but no grey space below (just to keep the screenshot manageable).
  2. Go to View > Fit to Window.
  3. Go to Help > Screenshot Tools.
  4. In the “Save Images to:” section, click the “Choose” button and choose a place to save the screenshots
  5. Then in the “Capture part of a project window” section, click the Tracks button.

A file with the name “tracks000.png” (or similar) will be created in the place you chose in the step 4.

Read this message: to see how to post an image in a message.

It should end up looking like this. Note that before I made the screenshot I made the Audacity window small horizontally in order to create a smaller image.
After we see what your project looks like we might have a better idea of what is wrong.

What is your Audacity version, computer, and OS?

When those 150 windows pop up, what do you see in the “Track” field?

– Bill

hey thanks so much guys for being willing to help!!

so i edited my preferences, and unchecked the box that reads “show metadat editor prior to export step”

i aligned all of the labels up again (figuring that i did it wrong the first time) then i tried to export multiple, but when i clicked export on the window… nothing happened… but when i checked “tracks” under “split flies based on:” instead of “labels”, it WILL export it. under ugh. i’m working backwards now.

so also another time i’ve tried to export multiple, it seemed like a success. until i tried to open the files in to iTunes… the songs opened themselves just fine, but they didn’t play back in the way that i labled them. they played back as the non mixed versions. you see, i labeled track 1 at zero. i labeled track 2 halfway between the fade-in of the song following the previouse song. how do i explain this better… my songs overlap eachother, so my songs do not look like a string of songs, they look like a staircase of songs. songs that are connected together, fade into eachother. is this a problem when labeling and exporting?

i feel like this should be simpler…

oh and also. my computer is a Windows XP. Audacity version is 1.3.7

======== <— my songs overlap like this. i couldn’t figure out how to put down the picture.


and also, when i’m labeling the tracks, it lets me name the first 3 tracks, then the 4th through 9 or so tracks don’t leave me a space to type in a name. then the 10th and 11th track is allowed to be named, and the rest of the tracks i can’t name. the ones i can’t name just show a bunch of b’s instead of a blank space to type.

Yes, that’s your problem. You need to select all the tracks then click on Tracks > Mix and Render. This will mix all your songs into one track. NOW you can go through and put in your labels. When you are ready to export you should have one audio track and one label track, as shown in my previous post.
In the Export Multiple dialog under “Split files based on” click “Labels”. Take note of the option “Include audio before first label” and use it if you don’t have a label at the very start of the track.

– Bill

By the way, to stop the forum software from deleting leading spaces, and also use a fixed-width font, so you can post pictures like that, put the text inside a code block. Click the Code button at the top of the editing window then type your picture between the tags. Like this:

    ========       <--- my songs overlap like this.

You’ll need to hit the Preview button and adjust the text until it looks right.

Is this what you were trying to show?

– Bill

hey thanks bill! and yes, that’s how i meant for my text to look.

so i mixed and rendered my song(s), so it’s now one long track.

but of course, i’m having more issues :confused:

when i go to export multiple, change the settings so they’re correct, and click export, it doesn’t do anything but freeze the program :frowning:

A picture of your project at this point would be very helpful.

Try this. Just as a test. Select a portion of your track and select Export Selection. In the save dialog, at the bottom, select “WAV” in the “Format” popup menu. Choose a location and save the file. Does it work? If not, then there is a deeper problem that has nothing to do with Export Multiple. If it does work then we need to see a picture of your project, and exact details of what you are entering in the Export Multiple dialog.

– Bill

okay here it is. sorry if it’s distorted, i had to do it a little differently

You quite possibly do have 150 or so “tracks” in your project - caused by your use of multiple labels at the same point. From your posting I can see at least 3 per position and possibly more as the label track window is not fully expanded.

And you also have repeated label names which will either really confuse Audacity on Export - or cause the same file to be re-written many timers, causing data loss.

So… one label per position and unique label names - then try Export Multiple.

And yes you do have clipping distortion from an oversaturated signal …


hey thanks! i knew that the labeling was causing me some sort of problem, since it wouldn’t let me name some of the tracks.

but i don’t get how to perfectly alighn each label together, one after the other, not skipping or overlapping even the smallest bit of audio. sometimes there’s a yellow line that shows up that tells me where the last label ended, but other times, the yellow line will not show up :frowning: there must be a fool-proof way?

It can be a little confusing as there are two types of label in Audacity:

  1. the type shown in billw58’s response to you where the label covers a duration (and in your posted example) - you can see the bold line extending the length of the labelled section.
  2. labels at specific points (essentially these are markers). For this, Export Multiple treats the section between two labels as a track/song and will create a file for that - which is why your multiple labels at the same point cause problems on export.

Personally, I find it easier to work withe the type 2 single point labels. There is also an Export setting which enables you to ignore any recording before the first label - which may be useful to you if you have some recorded silence, or signal, before the first track/song that you want to export.

I have no idea what happens if you mix both label types or if you use the type-1 labels with ranges but leave gaps between the ranges - I may try an experiment sometime to find out.


Here’s what I do:

  1. Click on the point where you want the track division
  2. Click on Edit > Split
  3. Continue in this manner putting a split point between each track
    Your track is now divided into a bunch of clips, one clip per track
  4. Double-click on the first clip
  5. Click on Tracks > Add Label at Selection
  6. Type in a unique name for the label
  7. Continue in this manner adding a label that spans each clip.

There will be zero overlap between labels and zero gaps between labels.

Look at the screenshot I posted earlier - you can see what this will look like.

– Bill

okay so the problem i have when labeling, after the first few labels, it will stop showing the box to type a name for the label. i undid the label and tried it again, but it kept doing the same thing.

there are only like two songs tho, that won’t let me name the label :question:

I don’t think you’ve told us what version of Audacity you’re using. Versions prior to 1.3.5 (or so) had a bug where if you tried to type a letter into a label, and that key was also used as a shortcut (such a j k z r), the shortcut would be executed instead of typing the letter. That has been fixed. So make sure you’re running version 1.3.9.

Although this doesn’t sound like problem you’re describing, it is worth investigating.

We need another screenshot if we’re going to move forward. Note that once we saw the previous screenshot we saw immediately what the problem was.

– Bill

hey thanks bill! i downloaded the 1.3.9 version and it lets me label all the songs now!

unfortunately… it won’t let me export multiple… Audacity just freezes after i press export :frowning:

here’s what the export multiple window looks like before i press export
export multiple.gif

Sorry, I meant a screenshot of the project window showing the audio track and label track, like you provided last time.

  • Bill

here it is, sorry it’s small :smiley:

note that after i downloaded Audacity 1.3.9, it didn’t give me any more trouble with the labeling.