How to record streaming audio w/o disturbing my sleep

Hi! I have Audacity 2.0.3 and Windows 8.1
I want to record streaming audio from a radio station while I sleep, which means that if my computer is in the room where I sleep I need to be able to record the streaming audio without hearing it. Recording streaming audio per se is no problem-- everything going through my speakers is recorded and I can set the timer to start and stop the recording. However, when I plug earbuds or headphones into the headphone jack and the sound is no longer going through the speakers, Audacity no longer records the streaming audio.

So my question is obvious: is it possible to record streaming audio using Audacity without having it go through the speakers or if it must go through the speakers, is there something I can do (other than be elsewhere in the house, which is not possible or wear earplugs, which is not desirable) so that I don’t hear it even when it is going through the speakers?

If you use WASAPI as the host and use the loopback - see this page in the Audacity Manual:

then you should be able t turn down the output slider in Audacity and Audacity will still record (I do this a lot on my W10 laptop)

Note that you need to set the recording levels on the sound supplying app or website - not using the mic slider in Audacity.


Hi waxcylinder, thanks for responding.

And certainly your response led to a successful conclusion: I’m now capable of recording any audio streaming on my computer and simultaneously sleeping like a baby (i.e. like a baby proverbially sleeps-- soundly and peacefully-- not like a baby really sleeps-- sleep a little, wake up cry a little)!

However, getting to that successful conclusion required some deviations from the path you charted for me!

First of all, I had forgotten that some time ago I’d set my Windows Sound input (and Audacity too) to microphone, not stereo mix, so that’s why I was able to record the streaming audio up until I plugged in the earphones: it was recording through the built-in microphone in my computer. Anything audibly coming through the speakers is recorded by the built-in microphone when the Sound is set on Microphone. (Some time ago I used the microphone setting to record both sides of telephone conversations on Audacity that I conducted over Google Phone. The built-in microphone in the computer recorded the other person’s voice coming to me through the speakers, and of course recorded my side-- as long as I remembered to stay close enough to it!)

But when I was trying to record the streaming audio a few days ago, although everything went fine when I was listening to the program through the speakers, when I wanted to go to sleep and therefore plugged the earphones into the jack, Audacity’s recording flat-lined. It was only today that I understood why: the sound was no longer coming through the speakers and therefore was no longer going into the built-in microphone, so of course it wouldn’t be recorded when all the settings were on Microphone!

So today, my initial step was to set the Windows Sound to Stereo Mix, and to do likewise then in Audacity. However, when I followed your recommendation and relied upon the radio station’s audio streaming volume control (while sliding the Audacity volume control to zero) nothing was recorded! It was only when I had both the radio station’s volume control at a moderate level AND the Audacity volume control at a moderate level that I was able to record the streaming. So that necessitated that I use my original solution to record and sleep at the same time in the same room: plugging the earphones into the headphone jack of the computer. (So, when awake and wanting to listen to streaming and also to record it, I have the choice of either setting: Microphone or Stereo Mix)

Incidentally waxcylinder, one thing that happened during all this really shocked me. When I had Audacity open, and slid its volume control to zero, it also muted all sound on my computer-- I didn’t expect that and when YouTube videos were suddenly silent, at first I had no idea why. It took me a few minutes to realize that, in zeroing out the volume in Audacity, I had unintentionally done that to all sound on my computer!

Anyway, it all worked out perfectly and we have a happy ending!

I thank you again for your response, waxcylinder!