*how to eliminate dither...?

Attached is a noise that doesn’t register any dB level…so I think it can be termed as “dither”.

Noise removal does not eliminate the sound…ctrl + L does silence it…and I can amplify it as well.

Any advice how to eliminate this from the teleseminar I’m editing?

Thanks so much - it’s time sensitive so the sooner any solutions you can suggest, the better.

Use a noise gate http://wiki.audacityteam.org/wiki/Nyquist_Effect_Plug-ins#Noise_Gate
Note that you will need to either export in a high bit format (24 or 32 bit) or temporarily turn off dither in Audacity preferences (Edit > Preferences > quality) or Audacity will put dither noise back on when you export.

ok thanks…do you have suggestions on noise gate?

I tried various…but didn’t eliminate noise.

Looks like you may have dloaded the dither file so you have the exact noise print

Do you want to the dither to disappear permanently (in the silent parts)?
The noise is currently at -60 dB or less.
This indicates that quite a lot of times dithering was applied or the Sound was amplified by about 10 dB.
Absolute silence will probably Sound a Little queer, but the noise gate can be set such that noise below -55 dB can be attenuated by -18 dB.
I see that the file is not processed within Audacity and that the original sample Format is 16 bit.
It sounds rather weird after amplification - like a sucking pump or so…
Turn the dithering off if you want to Export the file again as 16 bit (after the noise gate).
The high-Level sounds are not affected by the noise-gate.
The noise is masked in this regions though.

Ok, thanks for the help so far fella’s…really appreciate it.

Robert, to answer your Q’s =

I want dither gone so it’s silent…the telesem sounds a lot better like this. Dither just sounds like background noise.

So I want to completely eliminate dither and make it silent.

What I need to know are the exact settings within noise gate that you guys are able to get this dither to be silent.

Robert you’re suggesting these settings? =

Level Reduction: -18

Gate Threshold: -55

If so, this didn’t work.

I tried max Level Reduction (-100) and Gate Threshold from -40 to -80 and it reduces the dither a bit but does not eliminate it.

So maybe if anyone who’s downloaded the sample wants to test various settings they have in mind and finds something that does eliminate dither to the point where it’s silent or as close to silent as possible…let me know the settings.

Thanks again guys…


I don’t have the noise gate installed at the Moment.
But from the source-code it is apparent that Levels higher than 96 dB should produce absolute silence.
You can also try the following ( with the whole track selected; effects > Nyquist-prompt):

(defun silencer (sig at-db)
  (mult (snd-oneshot (s-abs sig) (db-to-linear at-db) 
                      (/ *sound-srate*)) sig))
(multichan-expand 'silencer s -60)

everything below -60 dB will be absolutely silenced.
use the noise gate anyway, just to smooth the edges.
Maybe the n-g works not ideally with such a low sample-rate (8000 Hz), especially with the usage of the hp filter.
Ps Steve has comitted a Picture (Settings?)

Isn’t it true if you import and export the same sound standard as Audacity and then turn off dither in Preferences, that it causes little or no sound damage and doesn’t add the dither signal?

Dither may show up if you set the meters to the limit of 16-bit WAV
Edit > Preferences > Interface > Meter Range (-96).

I don’t think I get the postings who claim they can hear dither. That would have to be a very serious sound system turned up to ear-splitting volume.


Level reduction = -100 dB
Gate Threshold = -60 dB
Everything else at the default settings.

That will lower the hiss to absolute silence over a period of 0.25 seconds.
There could be a very slight fizz during the “fade out” because you can’t really fade out 2 LSBs.

The perceived loudness of the dither noise on that sample is quite a lot louder than normal dither because it is using shaped dither that is optimised for 44100 Hz or 48000 Hz sample rate but the recording has a sample rate of 8000 Hz. I’m surprised that the noise is a problem because at 8000 Hz sample rate the sound quality must be crap.

You’re quite good if you can distinguish if it is shaped noise or another type…
If the noise was intended for 48000 Hz, it will be nearly impossible to determine how the noise was distributed.
That’s because all above 4000 Hz is 3 times folded back into the audible Region if no proper anti-aliasing filter was used.
If the anti-aliasing filter was good, then we will end up with a noise spektrom that Shows only a tiny 6th part of the original Spektrum.
With regard to the high Level of the noise, I rather tend to the former case (simple Interpolation).
For my part, I can’t tell which type of dithering has been used (maybe more than one). The noise seems to be rather high, but shifting the frequencies into the Region above 3000 Hz is quite senseless for any dithering as it is in the Region of best Hearing.
However, the question is rather academic.
I hope the louder parts of the Audio Sound satisfying.

Shaped dither is generally created by filtering - the problem is that the filter parameters are optimised for specific sample rates, and no-one expects anyone to be doing serious high quality audio work at 8000 Hz, so the filter poles are all in the wrong places and noise is shifted to the “high end” (toward the Nyquist frequency), but at 8000 Hz that is between 3 and 4 kHz rather than 12 to 20 kHz. If you look at the Plot Spectrum figures you’ll see the characteristic “bump” rising sharply from about 2500 Hz.

This leads to the conclusion that Audacity shouldn’t use noise shaped dithering below - let’s say - 32 kHz.
Besides, a bump in the high frequencies is also to be expected with a equal Distribution when we resample from 44100 Hz:

  • 18050 Hz are mirrored down at Nyquist.
  • 14050 Hz are fold back at DC.
  • 10050 Hz go down again
  • 6050 Hz go up again.
  • and the remaining 2050 Hz are mirrored at the Nyquist frequency to lie eventually between 1950 Hz and 4000 Hz.
    That’s only a logigal assumption, I didn’t test this in praxis.
    (I also believe that even the fast Interpolation in Audacity is good enough to avoid this aliasing).
    I am only surprised that the Level of the noise is nearly 30 dB higher than one might expect from a normal dithering.
    It can’t therefore not come from the application just before Export.
    A former dithering must have been amplified Prior to the 16 bit Export (since the values imported into Audacity are all 16 bit).

Thanks again guys for all the help.

Steve - tried the settings…and got the same result as I did in my testing before posting here. I basically tried the exact settings you suggest…can still hear the dither, volume is reduced though after applying the gate.

Also tried the nyquist prompt Robert - had virtually the same effect as noise gate for sections I tested.

So, if that’s the best we can do then no worries.

I had the project sample rate set at 8000Hz unknowingly…was the sample rate set automatically to match the original wav file? How do you find the sample rate of any given file in audacity? If the project rate automatically matches…then you can just identify there…but if not, let me know.

Thanks again guys

Did you set the Audacity High Quality Conversion settings to Dither = None? (see my previous post for how).

I forgot…actually.

Just did and that did the trick - thanks Steve.

And regarding my previous Q anyone =

I had the project sample rate set at 8000Hz unknowingly…was the sample rate set automatically to match the original wav file? How do you find the sample rate of any given file in audacity? If the project rate automatically matches…then you can just identify there…but if not, let me know.

If there are no tracks in the project already, importing a file will change the project rate if necessary to match the rate of the file.

If there are already tracks in the project, importing a file will not affect the project rate.

Audacity doesn’t have complete media properties information for imported files - that is a feature request. If you want to request that, let us know.

However the sample rate of an imported file can always be seen above the Mute / Solo buttons in the track.

The bit depth information in the same place (16-bit/24-bit/32-bit float) is not the bit depth of the file, but the resolution Audacity imports the file at, according to “Default Sample Format” in the Quality Preferences.


Alright thanks Gale.

One more thing guys if you have any quick tips…the dither seems to still be present when people are speaking in the teleseminar I’m editing.

and then it fades out to silence usually where dither once was. I’m pretty sure it’s dither I’m hearing…wanted to get your input how to eliminate the noise if possible. Going to test various noise gate settings but let me know if you have any quick idea’s/tips.


Could you attach an example for this too?
There’s always the average trick. It improves the Signal to noise Ratio if the Audio is polluted with uncorrelated noise. But I have to test this on a real example. The Attachment above has no Signal in it (only noise).

yep here are two samples attached…(removed)

let me know - thanks

Unfortunately it is not possible to make a high quality recording out of a low quality recording. Those recordings are quite low quality - there’s not a lot that you can do about that. You may find that you get slightly preferable results if you use a little “Noise Removal” instead of the Noise Gate and just put up with there being a bit of hiss remaining.