Hesitation When I Hit "Play" [SOLVED]

I’m trying to edit a WAV file. When I click the Play button or tap the spacebar to start playing, there is a pause of about a second, then when it starts, the first half-second is muted. It is intermittent. It may do that several times in a row, then operate normally for several more times, then come back. If I stop and restart from the same position, it plays normally on the second try every time.

I’ve been using Audacity for many years on multiple systems and have never seen this behavior before. However, this is a new installation on a new system. It started on day 1. I’m at version 2.3.2, on a Lenovo notebook running Windows 10. I turned of audio enhancements and Dolby; no improvement.

Any ideas?

I get this - but only sometimes and only on one of my W10 PCs and not the other. For me the silence is about 2 seconds - you can see the play cursor advancing for 2 secs. with silent playback until the audio starts at about 3 secs=. Press Stop and Play and playback starts immediately :confused:

It’s not just Audacity - I get the same with other audio players - so I’m suspecting that it’s down to soundcard and its drivers (I have different soundcards in the 2 PCs).

That suspicion is amplified by the fact that the afflicted PC creates a “helpful” 2 second fade in when I record fro my on-board mic. My other W10 PC does not do that and nor does my Macbook Pro with Mojave.


Thanks for the suggestion. I ran the audio troubleshooter, and all it came up with was “Audio format not set to default”, which was true. It had originally been set to its default setting, and I had changed it hoping to fix the problem. No luck. But now that the troubleshooter set it back, Audacity seems to be working correctly. I didn’t have much time to test it extensively, but will do so soon to see if it’s consistent.

Tried it some more and it is not fixed. The problem remains. As I said initially, it’s somewhat intermittent, so I guess I was just lucky the last time. I’ll continue to do some poking around. Any suggestions are welcome.

For what it’s worth, this definitely seems to be an issue in Audacity. I say this because I have no other audio issues, and because I’ve identified what makes it intermittent. As long as I keep the mouse activity within the waveform display and don’t try to jump forward, there is no problem. But I can cause the hesitation/lag by:

1 - Use the mouse to do anything in the toolbars. If I select a section within the waveform, no problem. But if I click the cut button, for example, I’ll see the hesitation the next time I try to play.

2 - Jump ahead enough to update the screen, either by clicking the mouse in the scrubber bar or by using the keyboard shortcuts to jump ahead.

Looks to me like an editor issue.

This may be providing a hint to the problem.

Drawing the waveform is a relatively slow process, because Audacity has to calculate the amplitude for every waveform pixel on screen. To make this more efficient, Audacity caches waveform data (creates “snapshots” of the waveform) in RAM, so that it can be drawn quickly. However, when you change the audio (in this case, by cutting a piece out), Audacity no longer has cached “snapshots” to match the actual audio that lies off-screen, so it needs to prepare (calculate) the next screen of waveform before playback scrolling occurs.

Something you could try, which may show if this is the problem, is to disable scrolling on playback. (Fourth checkbox "“Auto-scroll…” on this page in Preferences: Tracks Preferences - Audacity Manual ). You can change this setting back if you don’t like this behaviour, but it would be useful if you could try it an let us know if that prevents the “hesitation” problem.

I can’t provoke the “hesitation” silent playback by using the Cut button (W10 testing on 2.3.2 and 2.3.3 alpha)

When I get it, it’s the first P;lay I press on returning to an Audacity after I’ve been on other apps


I tried this and it did not make a difference. I also cleaned up the SSD (it’s only 1/3 full) and enlarged the swap file to see if any of that would help. It didn’t. This being a new computer, I also verified that it really did have 8 GB of working RAM. It does, and plenty of it is free. I’m running out of things to check.

And the winner (loser, really) is…Realtek!

Although I noticed this only on Audacity, I decided to broaden my web searching anyway and came across this article: https://neosmart.net/wiki/fix-realtek-audio-delay-lag/. I followed the procedure there and the issue vanished.

Waxcylinder, this may explain the other issues you are seeing.

Congratulations DTM. Very pleased you found a solution, and thanks for posting it here.

You’re welcome. Thanks to both of you for helping.

DTM, thanks for doing that research and posting the link - an interesting read. :ugeek: :sunglasses:


I tried this yesterday - and yes the start delay was indeed gone - but I found I was getting choppy/clickety playback in Audacity - so I ended up reverting to the Realtek driver :frowning: