I am using Windows 10. I was using Audacity 2.4.2 and for some reason the programs were installed in the download directory instead of the windows/program files directory. I thought it would be better to put it in the right place in case my download directory gets accidentally deleted. I deleted my Audacity 2.4.2 directory and then reinstall Audacity.

It was at this point that I realize that Audacity is now in 3.0.2 version. At first I received an error message that a .dll file could not be found. I tried to copy back the Audacity directory which I had deleted earlier back to the download directory. But I got the same error message. I can’t remember what I did after this, but I had since uninstall and reinstall several times and somehow managed to go far enough to be able to go open the application. But the Silence Finder under Analyze is now missing.

I checked under Edit-Preference–Enable Effect and all my boxes including Nyquist are ticked. Under Analyze, the only thing that is not greyed out is “Add/Remove Plug-ins”. When I choose that, I noticed that Silence Finder is “Disabled”. I tried to “Enable” it and press “OK” but the Silence Finder still does not show up under “Analyze”. When I go back to “Add/Remove Plug-ins”, I noticed that the Silence Finder is “Disabled” again. I noticed that the path still points to my download directory (ie. …\Downloads\audacity-2.4.2\plug-ins\SilenceMarker.ny). Is that the reason why the program is not working properly? because somehow the program is still looking for audacity-2.4.2 files that no longer exist? How do I get audacity 3.0.2 to work properly and get the Silence Finder back?

I am not a music professional or a frequent user, but I do need to use audacity for the purpose of recording/editing for a virtual choir, as well as to “break down” a bigger audio file to smaller files for teaching purpose. Hope my message make sense. Very sorry for the long message. Thank you.

How do I get audacity 3.0.2 to work properly and get the Silence Finder back?

You missed a question. “How do I roll Audacity back to 2.4.2?”

Scroll down.


In Audacity 3.x Sound Finder and Silence Finder are replace by Label Sounds (which does both jobs):



Thank you kozikowski, but I don’t understand what you mean about missing a question. And I don’t want to go back to 2.4.2. I saw a list when I go to the link. Not sure what I am supposed to do. Very sorry.

Thank you waxcylinder. I understand now that the Silence Finder is now put under “Label Sound”. But “Label Sound” is greyed out under “Analyze”. What do I need to do to “un-grey” it?

You just need to select some audio for it to work on.


Thank you very much waxcylinder. It is working now. Feeling very embarassed now. Thank you very much!! This forum is great!!

That’s OK - it’s only easy when you know how.

Glad we got you sorted.