Help- Trouble loading FFmpeg library

Hi, so I was running through a recording I did earlier and it wasn’t loading correctly. It would play, then cut out and get all mixed up.

I checked the log and that follows.
What happened? I understand some of what the errors say but I’m just not sure how to fix it.
I might have gotten a virus the other day, would that be an issue that could mess up audacity?

16:11:02: Audacity 2.0.5
4:11:03 PM: Trying to load FFmpeg libraries...
4:11:03 PM: Trying to load FFmpeg libraries from system paths. File name is 'avformat-52.dll'.
4:11:03 PM: Looking up PATH environment variable...
4:11:03 PM: PATH = 'C:Program FilesCommon FilesMicrosoft SharedWindows Live;C:Program Files (x86)Common FilesMicrosoft SharedWindows Live;C:Program Files (x86)NVIDIA CorporationPhysXCommon;C:Program FilesBroadcomBroadcom 802.11 Network AdapterDriver;;C:Windowssystem32;C:Windows;C:WindowsSystem32Wbem;C:WindowsSystem32WindowsPowerShellv1.0;C:Program FilesIntelWiFibin;C:Program FilesCommon FilesIntelWirelessCommon;C:Program Files (x86)Windows LiveShared;C:Program FilesIntelWiFibin;C:Program FilesCommon FilesIntelWirelessCommon'
4:11:03 PM: Checking that '' is in PATH...
4:11:03 PM: FFmpeg directory is in PATH.
4:11:03 PM: Checking for monolithic avformat from 'avformat-52.dll'.
4:11:03 PM: Error: Failed to load shared library 'avformat-52.dll' (error 126: the specified module could not be found.)
4:11:03 PM: Loading avutil from 'avutil-50.dll'.
4:11:03 PM: Error: Failed to load shared library 'avutil-50.dll' (error 126: the specified module could not be found.)
4:11:03 PM: Loading avcodec from 'avcodec-52.dll'.
4:11:03 PM: Error: Failed to load shared library 'avcodec-52.dll' (error 126: the specified module could not be found.)
4:11:03 PM: Loading avformat from 'avformat-52.dll'.
4:11:03 PM: Error: Failed to load shared library 'avformat-52.dll' (error 126: the specified module could not be found.)
4:11:03 PM: Error: Failed to load FFmpeg libraries.
4:11:03 PM: Error: Failed to find compatible FFmpeg libraries.

FFmpeg is an optional extra that provides support for importing/exporting a wide range of audio formats (in addition to those that are supported as standard).
FFmpeg is not required for Audacity to run, and FFmpeg is not included in the standard download.

Those messages indicate that Audacity has not found a version of FFmpeg that it is able to use. That may be because you don’t have FFmpeg installed, or that you have it installed, but it is not a compatible version. (I’d guess probably the latter as it says that it has found a FFmpeg directory).

A virus could mess up anything and/or anything.
As you suspect this is a possibility, I’d strongly recommend that you perform a full in-depth virus scan as soon as possible (with an up-to-date reputable anti-virus program).
If you don’t have an up to date antivirus program, you should install one at your earliest convenience (free ones are available, such as Avast, AVG, ZoneAlarm, Avira, and others).

Yeah, I went ahead with an AVG scan not too long ago. I have the free version and it didn’t find anything.

I don’t remember installing any FFmpeg. Where could I get a compatible verision or update the one I (apparently) have?


That sounds like longer ago than “I might have gotten a virus the other day”

This will not solve the problem: “It would play, then cut out and get all mixed up.” but there are instructions for installing FFmpeg in the manual: Audacity Manual
Note that the version of FFmpeg needed for Audacity has recently been updated, so ensure that you also have the current (2.0.6) version of Audacity (available here: Audacity ® | Downloads)

If you still have the problem that you wrote about in your first post, please give more details - I don’t know what you mean and I can’t see your computer :wink:

The issue with the virus happened yesterday and I ran AVG, the full updated one today with nothing found.

When the tracks are playing, the stereo tracks will go out of sync, then it sounds like it tries to readjust it but it just keeps going out of sync from the click that’s playing and starts playing with partial skips in it.
It’ll start like that or with a small bit of audio missing and then it throws it entirely out of sync.

That sounds like your computer (or some part of it) is struggling to keep up.

Describe your set-up and the project that you are working with and we’ll see if we can work out where the bottleneck is and whether we can do anything about it.

I’m running the latest version of Audacity.
Using windows 7.
I’m using a Multimix 8usb to record as an interface.
Right now, there are only three tracks playing and it’ll mess up.

My project rate is at 44100hz.
My audio to buffer is at 100 milliseconds.

that’s all I can really think of.

Update- I tried exporting the song and it seemed to export fine. There were some locating issues with the LAME files shown below.
I ran through the song that I exported and then replayed it in the project file and it ran okay.
But I’m not sure I’ve seen the end of this…

8:45:01 PM: Error: Failed to load shared library 'lame_enc.dll' (error 126: the specified module could not be found.)
8:45:01 PM: load failed

What are the track sample rates? (look in the info box on the left end of each track).

What format did you export as?

Do you have LAME installed? Do you ever export from Audacity as MP3?

Try saving the project, reboot the computer, then open the project. Does it play OK?

The sample rates are 32 bit. All of them. All running at 44100 hz

I exported them as mp3s. I usually do, and on rare occasions WAV, but haven’t in months.

I had LAME installed originally, since it was needed for exporting to MP3. I rebooted my computer after downloading the new audacity, which was the very first thing I did after this started. Then I re-installed LAME.

It was messing up about 40 minutes ago today, then I tried rebooting the computer and reinstalling LAME and it seems to be working okay. Perhaps that did it?
It seems it was causing more issues as I was running other windows such as this one on my computer earlier… which it didn’t have any trouble doing before as I’ve streamed sound clips onto recordings from videos.

But as of now it seems to be working.
I don’t have anything having to do with an FFMpeg library on my computer. I also don’t recall ever downloading it. It’s not in my plugin folder either.

Thanks a lot, steve.

I had the same error start without warning on both of my machines running Audacity 2.0.6.

Looking back, it started after I installed LAME (why did they use that acronym?). I followed the directions here, to go to the same site and get the FFmpeg library plug-in.

Problem went away.

Now to get back to my transcription work. :unamused:

Due to IPR licensing restrictions - Frauenfofer Instsitute owns the rights to MP3 encoding

LAME = LAME Ain’t an Mp3 Encoder :sunglasses: :ugeek:

It is not really an error. If you only import and export standard WAV files for example, you should not need FFmpeg. But the FFmpeg messages are useful if you install FFmpeg and Audacity has problems loading it.