Help! Project can no longer be opened! Error 101. Disaster!

I’m using Google Translater :smiling_face:

Hello! :sob: :sob: :sob:

I have a really catastrophic problem! After updating to version 3.4, my project (over 40 GB) no longer opens at all. And yes, of course I had created a backup beforehand. But that no longer opens either. I can’t really explain it, I suspect that there was some kind of problem during the backup, even though I was still working on the project the evening before. The error message is given as 101, see below.

“timestamp”: 1699125386,
“event_id”: “496b2ca68945434c93515e2215ca421b”,
“platform”: “native”,
“release”: “audacity@3.1.0”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.19045”
“exception”: {
“values”: [
“type”: “File_Error”,
“value”: “Audacity failed to read from a file in .”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “101”,
“sqlite3.context”: “SqliteSampleBlock::Load::step”

The possible reasons behind the message are described by Audacity and the associated suggested solution is also given.

I then performed a restore with the audacity project tool 1.0.3 (several times now). Unfortunately without success. See the process in cmd below. It appears that the restore process went smoothly. BUT, the project still cannot be opened, always with the same error message 101.

I sincerely hope that someone can give me a tip/hint or help in some way. As you can imagine from the size of the project, countless hours, days, weeks, and basically even years went into it.

  • I checked the permissions for the directory in which the project is located after the restore, as well as for the file itself and also for the program directory. Full access available.

  • The last version I used before the crash was 3.3. In the recovery process, the required version is 3.1. called. I have the Recover with both 3.3. So it was also completely done with 3.1. Both without success. For any help, thank you very much in advance!

Im Anschluss noch der Verlauf im cmd:

Verzeichnis von C:\Users\maife\Downloads\AudRepair

04.11.2023 18:26 .
04.11.2023 18:26 …
31.03.2023 11:08 1.452.424 audacity-project-tools.exe
04.11.2023 12:57 52.017.713.152 broken.aup3
04.11.2023 18:26 32.768 broken.aup3-shm
04.11.2023 18:26 0 broken.aup3-wal
31.03.2023 11:08 1.252.232 sqlite3.exe
5 Datei(en), 52.020.450.576 Bytes
2 Verzeichnis(se), 282.919.546.880 Bytes frei

C:\Users\maife\Downloads\AudRepair>audacity-project-tools -recover_db -recover_project broken.aup3
Project requires Audacity 3.1.0
Using ‘sqlite3.exe’ for recovery
Executing query #110961 (PRAGMA writable_schema = off;)…ks (blockid, sampleformat, summin, summax, sumr)…
Recovered 1626 sample blocks from the database


If you care to upload the original offending .aup3 file, BEFORE your unsuccessful recovery attempts, then PM me a link, I’ll take a look at it later today and see if there was something you missed.

I have the same issue

Another post says this is a known error and there will be a 3.4.1 release that fixes it.

That would be nice. We’ll see…

Hello Jademan!

First of all, thank you very much for your offer of help :smiling_face:! After I found out that >PhilB1000< apparently has the same problem, that Audacity is aware of it, and that a new release 3.4.1 will be released, I had high hopes. I just installed it and tried it out immediately. The result is negative. Both the aup-file, from the previous backup and the file after the recovery with the tool. The exact same error message appears for both. That’s why my desperation is correspondingly great again :sob:. This is a bit embarrassing for me now, but how can I even send you a PM message? I just can’t find the function here :man_facepalming:.

Sorry it took me so long to get back to you. I think you just click on my icon and send me a message.

Have you tried the Corrupt or Otherwise Broken Audacity Project Recovery ?

Yes, you are quite right, I think right around 22Gb is about the largest file I have ever worked with, and I’m not sure that I have 50GB, but if you have some way to post it, I’ll still take a stab at it (I have some hidden resources up my sleeve). However, as I am re-reading your post at the top of this thread, it appears unlikely I would be successful at recovering this project.

Note: I am thinking that if you have a 50GB project, something is desperately wrong;

  1. Either you are not using the tool for the job (take a look at some of professional DAWs out there), or
  2. You have got lots of unused smart-clips (which is very likely).

You can get a handle on your unused smart-clips by copying your project to a new project as follows:

  1. Ctrl+A (Select All)
  2. Ctrl+C (Copy)
  3. Ctrl+N (New Project)
  4. Ctrl+V (Paste). When prompted, do NOT copy smart-clips.

Save both .aup3 projects and note the size difference. You might find that over 75% of your project is nothing but bloat and is being consumed by these unused smart-clips.

I don’t know why your project was damaged to begin with. I suspect the introduction of 3.4 was only an unhappy coincidence. More likely would be some issue with network drives, or with closing the database (or related), possibly a drive error.

Many thanks for the quick response :blush:!

Yes, it is of course possible that the project file was not closed properly and was then saved “incorrectly”. However, it would also be a really strange coincidence if this happened at that exact moment :man_shrugging:.

Admittedly, I came to Audacity and the idea of such a project by chance and completely unaware. There is no professional structure at all and there are an extremely large number of single clips, duplicates and empty spaces. But unfortunately this realization comes a little too late for me.

Well, I don’t know what to do next at the moment. It seems difficult to transfer such a large file.

At this point, a fundamental question: Let’s assume there is such an error when closing the project file, or a drive error. Can the Recover tool even fix such errors so that you can even open the project file? Or is the file essentially lost forever? It would be extremely valuable to me if I could get hold of the project file at all. Even if a significant amount of files/clips are lost.

What I noticed when reading the recover log was that obviously elements (1600 sample blocks) were recovered. Isn’t it a good sign in principle?

And furthermore, there were also occasional crashes or database errors in the commercial Firebird SQL database. The database could then always be restored or even opened and repaired once with an external tool. Please do not misunderstand. I am in no way an IT professional. Let’s say just a heavy user :tipping_hand_man:.

My waves of frustration and hope have been very extreme in the last few days :sob:. If I read between your lines correctly, I should slowly say goodbye to a successful rescue? And the upcoming version 3.4.2 is certainly no real reason for hope, right?

Yes. You do have a backup somewhere. Somewhere ?

So my offer still stands. If you can find a way to host a 50GB file, I’ll try to pull it and see what I can see. Do NOT expect overnight service.

Yes. I wouldn’t keep high hopes on 3.4.2. You can download their development version just now to double-check: Merge pull request #5566 from crsib/5543_play_region_crash · audacity/audacity@30cc55b · GitHub - scroll to the bottom of the page (and you may need to create a login to download the file). Note: Do NOT do any production work on this development version.