help getting rid of buzzing on audio

I have a DVD with a loud shrill, crackling, buzzing on the audio throughout. I demuxed it and now have an audio wav file. I’ve tried the noise removal in Audacity (selected a section of audio that’s silent except for the buzzing, get noise profile, select the whole file) many different ways (even going so far as setting all the sliders in step 2 all the way to the right. This turned the sound to mush, but the buzzing was still loud and clear) and it’s not making the slightest difference in the buzzing. I’m using version 2.0.3 on Windows 7 x64 SP1. Is there a script that would help fix this? I ask this because I tried the script in this thread ( for a hum on a different DVDs audio and it worked like a charm. Any help with this would be greatly appreciated. Thanks.

This is possibly a useless piece of information:
Odd thing I noticed it the top of the sound wave is higher than the bottom of it. Both right and left channels are identical, it’s that the bottom of each is around -0.5 and the top goes a good deal above 0.5. Not sure if this is actually odd but I remember waves looking uniform on top and bottom.

We arrived in the middle of the second act.

I have some home-made movie DVDs…??
I’m trying to rip BlockBuster Video DVD movies…??
I’m trying to edit camera-burned Data DVDs…??

You have a collection of very highly unlikely symptoms so we need to know more background. What exactly are you doing?


It’s a DVD I bought from FYE. It’s a cheap bargain bin one that’s sourced from a VHS (complete with overscan line along the bottom of the screen). I own a VHS of it too (which wasn’t as cheap). It has the same buzz. My plan is to fix the audio so I can watch it, because as is it’s like nails on a blackboard. :frowning:

Can you export a WAV file a few seconds long containing some noise on its own followed by noise with some signal (audio you want to keep). See for how to attach files.


Thank you for the reply, Gale. Here is a clip. Also I’ve been fiddling with the file and the only thing I’ve found that gets rid of the buzzing is the Paulstretch effect. It also ruins the rest of the audio, but something in that effect is helping with the buzzing so…

Noise Removal won’t get rid of much of the crackling, and I think the crackle is too widespread in the upper frequencies to use Notch Filter. If you want a quick method, just open Equalization and reduce all the frequencies above 800 Hz by 30 dB (in Graphic EQ, move the sliders down).

It will then sound very dull and you will almost completely lose the trumpets at just after 4 seconds but you will also lose the crackle (attached).

Cut the frequencies above 800 Hz by less than 30 dB to keep more treble and more crackle.

You may want to try selecting and Edit > Duplicate on that trumpet fragment (or any other bits where the crackle is not too bad) which will then preserve it and mix it in with the EQ’ed track. You may want to turn the -…+ gain slider down on the original track where you keep any original fragments that are worth keeping.

I am not an audio engineer so those here who are may have other ideas.


A smart DSP-trick to reduce noise in the upper regions (while keeping a proportional big amount of the useful signal) is to average the samples.

(snd-avg s 7 7 op-average)

Put the code into the nyquist prompt and press OK.
The value 7 is the amount of samples that are averaged. Higher values result in higher attenuation of the noise (and higher frequencies as well). Give it a try.

Thanks, Gale and Robert. I tried the lowering the EQ. Moved all the sliders above 800 Hz all the way down and get muffled sound and the buzz is still there. And when using the Nyquist avg code it returns a “Nyquist did not return audio.” dialog box. :confused:

What are you trying to get rid of? I thought you meant the “crackle” distortion that is there slightly in the background noise and actually increases when the music occurs.

Has what you want to remove been removed from the sample I attached?

That code seems to fail for stereo audio. If I make the track mono (Tracks > Stereo Track to Mono) that code truncates the audio and speeds it up. If you use Change Speed to slow it down again you can hear a very bright sound with the crackle reduced but not removed.


Maybe we’re working at cross purposes, I didn’t hear any shrill, sharp buzzing in the test clip, either. Just the occasional crackle. Koz

The noise is gone from the sample you uploaded, Gale, but the soundtrack at the tail of it is destroyed. When I tried I lowered the sliders as low as they would go for all eq above 800 Hz. My file didn’t sound like yours. It ended up a more muffled version of what it was, with just the soundtrack and unpleasant background noise lower and more compressed sounding. If it will help matters we can refer to it as crackling too.

You may as I suggested have to trade between brightness and crackle, or see if Robert has another version of his script. The recording is badly damaged, after all.


Is this file intended to have the irritating buzz in it or not?


I’m at sea. slimwaffle complained about serious buzz and then Gale came back with a solution to the crackling. Then slim responded with a comment about the buzz.

Then Gale responded with an 800Hz rolloff sample inexplicably labeled

Anybody else expecting the March Hare to make an appearance?

Anybody else wishing a lot more of the show was available instead of the special-effect sound segment at the end?

Anybody else wishing we had a clip representing the actual complaint?


Sorry, the code was indeed for mono sounds, And there’s a wrong step-size, thats why it speeds up. Here’s the correct version:

(defun noise-red (s)
  (snd-avg s 50 1 op-average))
(multichan-expand 'noise-red s)

As you can see, the value is much higher than before.
You can choose a smaller value and simply repeat the process (ctrl-r).
I haven’t any hiss either. I had such a shrill, whistling sound recently, but it was due to a bad 6.0 mm > 3.5 mm adapter in the line-out setup.

You should first use a noise gate to get rid of the noise inbetween the pauses. This has the advantage that the louder bright sounds are preserved at that stage. We than can look how many crackles are over and which are not enough masked by the louder sounds.
Here is a rough code example that illustrates this:

(defun gate (s)
  (mult (s-max 0.01 
        (snd-oneshot (s-abs s) (db-to-linear -23) 
                     (/ 1000 *sound-srate*))) s))
(multichan-expand 'gate s)

All sounds can pass that are louder than -23 dB, all others are attenuated by -40 db (the value 0.01)
There is only “stop and go” in this code, therefore you should really use the noise-gate on the wiki.
The threshold of -23 is rather high, but lower ones still allow some crackles to get through. However, we should aim for about -40 dB and less to preserve some dynamics and remove the remaining crackles with click removal or a similar tool.

I renamed my dull-sounding but crackle-fixed file, sorry.

This sounds a reasonably good compromise between crackle and brightness, and still has some quite audible signal between 600 and 900 Hz. Mine had little audible signal above 600 Hz because I was trying to eliminate all “crackle”. In Robert’s achieved signal, 1000 Hz is almost entirely removed, then there is some signal remaining between 1000 Hz and 2000 Hz (but much reduced in volume to about -60 dB, so hardly audible).

As you can see from the graph above the EQ Graphic Mode sliders, each slider is centred on its frequency and operates in a range outside that frequency, so reducing the 800 Hz slider actually reduces the volume between 600 Hz and just over 1000 Hz, with most reduction at 800 Hz.


If I understand you correctly, Robert, you want me to run the second script and then run the first one? When I did that I got lots of sound drop outs (I also tried them in the order you wrote them and got the same drop outs. Kind of like it was too in the red and shorting out). I then tried the first script alone and that gets rid of most all of the crackling. It’s a little more muffled than I was hoping for, but at least it doesn’t sound compressed. Thank you. Is there anything to brighten the sound?

I’ve been looking for a way to get rid of the crackles that remain in the silent parts of the sound.
I’ve tried click-removal, but it seems to fail completely, even with extreme values.
It now came to my mind that I’ve already written a plug-in for extreme click sounds. I’ve modified it to work with stereo sounds and added a control for the attenuation level.
On Windows, it plays a preview of the sound that are removed. If you press the debug button, you can see how many blocks were found and how many of them were damped.
The effect won’t affect continuous signals (like those at the end of your example). those sounds are defined by the threshold and distance controls.
You can tell the plug-in how wide the clicks are and how much their volume should be reduced (total elimination sounds weird and unpleasant).

Let me know if the plug-in was of any assistance and if it causes any problems.
silence-cleaner.ny (2.36 KB)

Curiously, Effect > Noise Removal working on only a small selection of the noise gets rid of the noise quite well if applied with high “Noise Reduction” and “Sensitivity” settings (or applied a few times).

Noise Reduction barely harms the sound track audio (in the fragment that was submitted) because the distortion in that seemed to be created by the signal itself.


Sorry for the delayed response. Again, thanks Gale and Robert for the help. Robert, the silence cleaner plug-in causes Audacity to crash every time I try to process the file. I’m using version 2.0.3 on Windows 7 x64 SP1. And Gale, using the noise removal effect with noise removal and sensitivity high gets rid of the noise, pretty much totally (with smoothing set high it seems to remove the tinny low-but rate sound too). The volume sort of fluctuates doing this though. I’m not sure how to accurately describe it. It sort of pulses lower and higher.

Does the cleaner plug-in play the preview or does it get stuck during execution?
Does it function on short sections (10 s or so).
Try it with the debug mode, maybe there will be additional information be given.
It may well be that it doesn’t work with longer selections, due to stack overflow.

(2 minutes later)

I’ve tried it with a 7 min recording in stereo and it works perfectly well, even with preview on.
I am on a similar system as you (W7 AMD 64).
Have you tried it with another file?
I’ve no idea why Audacity should crash on every single attempt. I am very sad and sorry.