Hearing echo from recording [SOLVED]

Good, that was the right thing to do first.

Windows also has its own “software playthrough” type setting, which is located somewhere in the Windows Sound Control Panel (sorry, I’m not sure exactly where as I’m not using Windows). The setting is called “Listen to this device” and my guess is that you get to it by right clicking on the relevant device in the “Recording” tab of the control panel. “Listen to this device” should be off (not selected).