Hearing echo from recording [SOLVED]


I have a problem with recording my voice in audacity (version 2.1.3).

Whenever I try to record my voice I hear echo with slight delay making recoring way harder for me (trying to speak while hearing your echo from half a second ago is quite hard :cry: ). I tried to look into FAQ but the box for “Software playthrough” that should control this was not checked (also tried to check it, save and then ucheck it).

So far the only solution to my problem was muting the audio track while recording but since this is the first time I had such problem with Audacity (been using it for 5 months) and I’m owndering wether that is the only solution.

Thanks in advance :smiley:

Good, that was the right thing to do first.

Windows also has its own “software playthrough” type setting, which is located somewhere in the Windows Sound Control Panel (sorry, I’m not sure exactly where as I’m not using Windows). The setting is called “Listen to this device” and my guess is that you get to it by right clicking on the relevant device in the “Recording” tab of the control panel. “Listen to this device” should be off (not selected).

Thanks for quick response. There was indeed a problem with other software I forgot about (no problem with audacity). Thank you again :slight_smile:

(this thread can now be deleted / marked as solved)

I’m hoping to raise this topic again, I am dealing with a similar issue to the original. I’ve spent the better part of the last two days trying to solve a malfunctioning Audacity 3.3.3 usb microphone interface on WIndows 11.

At first I was unable to get any kind of signal at all, after which I received good advice to turn off system enhancements on my computer which solved the problem of no sound coming through my microphone but left me with this latency delay coming through my monitor when recording a new track. I cannot seem to get rid of it no matter what I find online.

Even more frustrating, when I dowhat everyone says and turn off my Software Playthrough setting on Audacity and then try to record, the cursor takes around ten econds to reach the 1 second mark and all data drops out after I press stop.

I’ve been using Audacity for over ten years to make music and this is by far the biggest and most disheartening bug I’ve ever encountered, are there any ideas out there about how to solve this?

Thanks all :slight_smile: