Hang/freeze when I stop a recording

Audacity freezes when I stop a recording. The application stops responding and shows the rainbow pinwheel. Bottom left-hand corner says “recording” even though recording is stopped. Sometimes it takes a couple iterations of stop>record>stop>record before it occurs, but if there is more than 1 minute of audio since the last save, the program will hang/freeze every time I stop recording. It does not resolve and I have to force quit the application.

No error messages, because the application freezes until I force quit, although when I restart Audacity and recover the project it gives me the error message: “Warning: Problems in Automatic Recovery. Project check found file inconsistencies during automatic recovery.”

Running audacity 2.3.2
Downloaded from audacity website, not running from the dmg
Running on macOS Mojave 10.14.5
Recording with a RODE NT-1 with a Scarlet Solo Focusrite phantom power supply with USB connection

I have tried:
-Resetting Audacity using these instructions: https://forum.audacityteam.org/t/resetting-audacity/50613/1
-Deleting the entire Audacity folder from Application Support
-Clearing more space on my hard drive (currently 179 GB available out of 500 GB)
-Making sure the project is stored on my local hard drive, not on my external drive or in the cloud
-Checking the list of known bugs

I had this problem two weeks ago, on a different project, and resetting Audacity seemed to solve it. Not this time.

Please help, I have a book due and this is driving me nuts!

How much stuff do you have running in addition to Audacity? If you look at the doc (bar at the bottom) how many applications have little lights or indicators under them?

I used to regularly get a division manager out of trouble at work by closing the thousands of apps he had open. He used to quit applications without closing them and they eventually filled up his machine—the internal memory, not the hard drive.

I noticed “Restart” wasn’t in your list. I favor Shut Down, Wait, and then Start over Restart, particularly if you have something wrong.

Does it get any better if you disconnect or shut down your network? iCloud can appear a little magic if you have an app not used to it, whether or not the app uses it.

It can get a little more evil. My browser would occasionally fill up the machine with animations, displays, music and links…all in the background. The days of opening up a simple link from a web page are gone.


Thank you, Koz, for responding so quickly, and for reminding me to try these simple fixes. Unfortunately they did not help, but I did pinpoint the problem a little.

I have tried, didn’t work:
-Closing all other apps (indicator below only Audacity and finder in dock)
-Turning off wifi to stop icloud/dropbox/whatever syncing
-Restarting computer
-All of the above, restart, and resetting audacity together.

I then tried recording using my intenal microphone instead of the RODE NT1 and Scarlet Solo. This worked! I was able to record a significant section. So the problem seems to be related to using the external microphone. This is odd to me because I did record a 1 hr story two weeks ago (when I was having this problem before and it was solved by a reset).

More info about my computer:
MacOS Mojave 10.14.5
Macbook Retina 12-inch, Early 2015
1.3Gz Intel Core M
Memory 8GB 1600 MHz DDR3
Graphics Intel HD 5300 1536MB

Do you have any suggestions given this new data?

Another note: When I plugged my microphone back in, I was able to record two very short (1-2 sentences) bits. Both times it reported a dropout when I stopped, but did not freeze. The third time I stopped, it froze. I do get a lot of dropouts, which are never audible to me in the final product. Could this be related?

stevethefiddle suggested this via email:
" Try setting the recording / playback devices to one of the “hw:” options in the device toolbar. This will cause Audacity to access the ALSA device directly, bypassing PulseAudio. "

I don’t understand this direction as there is no Hw: options in my device toolbar that I can see. I see four dropdown menus:

  1. Core Audio only option
  2. Built In Microphone or Scarlet Solo USB. I experience freezes with the scarlet solo but not the built in microphone
  3. Mono or Stereo (I always record in mono)
  4. Output can be built-in or Scarlet Solo USB. I always set this to Built-in.

The link above just explains the toolbar and not the “hw:” direction, ALSA, or PulseAudio direction. I also scanned the Preferences and didn’t find anything like this.

Sorry, my mistake. That advice refers to Linux, not macOS.

On a Mac, the problem “may” be due to the audio buffer settings.
If you open Audacity’s preferences and look in the “Devices” section, there’s a setting for “Buffer length”. The default is 100 milliseconds.
Try decreasing that, 10 milliseconds at a time, and test for 90, 80, 70 …
If the problem gets worse, try increasing it 10 ms at a time: 110, 120, 130 …
Hopefully you will find a sweet spot where it is reliably stable.

If that doesn’t help, reset it back to 100 and we’ll have to try and think of something else.

Thank you, I will try this!

I’m still having this problem.

I’ve tried resetting the buffer to numbers between 60 and 140 in increments of 10 with not much success. On one of the days I tested it, it didn’t crash regardless of the buffer setting. On another day, it would not crash but would report dropouts. Every other day, it has crashed at all of these settings, even after recording only 1-2 seconds of audio. I’ve done over 30 trials all together, nearly all of which resulted in the hang/crash.

So I’m ready for the “something else” please! If this continues past today I will have to switch to another recording program. It will be a huge pain for me to learn a new program just when I had begun to be competent in this one, but this book can’t wait any longer.

To add to the mystery, I am now on an entirely new computer and am experiencing the exact same problem. Here are the stats for my new computer:
MacBook Pro 13" 2019
Processor 2.8Ghz Intel Core i7
Memory 16GB 2133 MHz LPDDR3
Graphics Intel Iris Plus 655 1563 MB

If this continues past today I will have to switch to another recording program.


I’ve been avoiding doing the final upgrade to Mojave because of odd unexplained interactions with Audacity. Worse yet, some respected app licenses seem to think it’s perfectly normal to start running processes and jobs on my machine whether or not I’m using their app. All these odd jobs use system resources, so Audacity doesn’t always have the free hand for clear recording it used to.

You should seriously consider what you would do if we can’t pull this out.


I’ve watched the CPU monitor during many of the hang crashes and there are not other jobs consuming extraneous amounts of memory, just Audacity at 100% and making my fan cry. But, yes I am already watching tutorials for Reaper. Thank you for trying to help me.

Audacity has served me well up until now, as has your advice specifically, koz (I’m thinking of your posts on audiobook mastering). I hope at some point they can figure out the cause of this problem and solve it.

Audacity at 100% and making my fan cry.

See, that’s not normal either. Audacity does not soak up the whole machine to the point of overheating. Something is very wrong and I don’t think this is going to be easy or fast to fix.


Did you get Audacity from us?