Frustratingly cannot locate FFmpeg.

My sincerest condolences for your loss.

macOS Sierra Version 10.12.6
After many failed attempts, it has led me here. It seems I cannot program Audacity 2.1.3 (both .dmg and zip) to locate LAME FFmpeg libraries in the system. Numerous attempts to locate the library manually have also resulted in the same issue. Always ‘Library not found’.
Any help would be greatly appreciated.

Kind regards, Robert.

Assuming you have followed the steps here the first thing we need to do is verify that the libraries were installed in the correct location. Please look in

/Library/Application Support/audacity/libs

to see if the FFmpeg libraries are indeed installed there.

The easiest way to get to that folder is to click on the Go menu in the Finder and choose “Go to folder…” then type in /Library/Application Support

– Bill

Following the instructions as per above email. The attached file screen shot shows /Library/Application\ Support/audacity/libs/libmp3lame.dylib
It shows the library in the correct location (I think)
Screen Shot 2017-08-31 at 6.00.40 pm.png

I see you have the Audacity installation DMG mounted. You’re not running Audacity from the DMG, are you?
– Bill

And what Bill is getting at here is that you really should be dragging Audacity from the DMG to you Applications folder :nerd:


Thank you for the prompt replies. I believe I have ‘dragged’ Audacity into the applications folder. I have also put previous Audacity downloads into the trash and re-downloaded, both Audacity 2.1.3 and 2.11 and tried to follow steps ‘verbatim’.
All to no avail.
The latest attempt, Audacity appears in the ‘Launchpad folder’’ however when clicking on the Audacity icon within the 'Launchpad folder, Audacity now does not load.

I don’t use Launchpad so I don’t know why Audacity would fail to launch from there.

The Audacity DMG window looks like this:
Once you have dragged the Audacity icon onto the Applications icon, there should be an Audacity icon in your Applications folder.

Once you have verified this, eject “Audacity 2.1.3” from the “Devices” section of the Finder sidebar.

Now double-click the Audacity icon that is in your Applications folder.

Tell us what happens.

– Bill

Ok, Audacity is up and running again, as per instructions above. However it still cannot locate the FFmpeg library, even when it is manually selected.

Screen Shot 2017-09-06 at 6.11.59 am.png

You appear to be looking for the FFmpeg library in the LAME installer DMG in your Downloads folder.

Did you follow the instructions here, under “Recommended installer?” If you do that, the FFmpeg libraries will be installed in ~/Library/Application Support/audacity/libs and Audacity will be able to find them the next time it starts.

– Bill


I seem to be having the same issue–except that my screenshot, instead of showing me directing Audacity to locate the FFmpeg in the Downloads folder, would show it in the Application Support/audacity/libs folder, where I think it should be, right? I select it and click Open, and the message is STILL “FFmpeg library not found”–no matter what I do. I just downloaded the most recent version of Audacity, I replaced the old one, and I’m opening it from my Applications folder.

I am just trying to open and edit .m4a files. My old version let me do it yesterday, but today it opened them but would not export them again as .m4a. So I downloaded the latest version of everything, downloaded the FFmpeg, and now it will not even OPEN my .m4a files.

I would really appreciate any help! Thanks.

If you are running Audacity 2.3.1 you need the 64-bit versions of the FFmpeg libraries. We recommend using the PKG installer, which puts the libraries in the right place for you. On startup Audacity should then automatically locate and load the FFmpeg libraries.
– Bill

Having this problem as well.

Using Audacity 2.3.1 on MacOS 10.14.4, and confirmed that FFMPEG library properly installed in ~Libraries/Application Support/Audacity/libs (see photo). But still, Audacity claims “FFmpeg library not found” when selected

Any thoughts?

Screenshot at May 10 13-08-49.png

That image is showing libmp3lame64bit.dylib, which is the LAME library.
LAME and FFmpeg are different things.

I was having the same issue as some others where I could locate the FFMPEG and LAME libraries, but Audacity would still not recognize them. Short story, I found this line in the logs “/Library/Application Support/audacity/libs/libmp3lame64bit.dylib: mach-o, but wrong architecture”, and I discovered that I had installed Audacity from Sourceforge which has version 2.1.0. Installing version 2.3.1 solved my issue.