Flat Line with Terratec DMX 6fire USB - pls help!

HI all,

Using Mac OS x 10.8.2
Processor 2.5 GHz Intel Core i5
Memory 4 GB 1333 MHz DDR3

Audacity 2.0.3 - dmg version, though I re-tried with zip version this morning and got same issue.

Sound card - Terratec DMX 6fire USB

I am very new to all this, so apologies if I have omitted something really obvious!
I am recording from vinyl records.
I was previously using an ION USB turntable w/ Audacity and this recorded fine, i was not happy with the sound quality so decided to upgrade to better quality soundcard to use with an old freestanding turntable.

Now I am just getting a flat line in Audacity when I try to record.
The weird thing is when I first select ‘start monitoring’ i get a surge of red light and then nothing…
Audacity recognises the device in ‘input device’, I have the Terratec set as Input device in Audacity, and the sound is coming into the computer, because when i go Apple>System Preferences>Sound>Input & I play the record, the blue lights move to indicate sound is there.
I have the Terratec set as Input device on Midi settings, but a weird thing there is all the sound controls are greyed out. There are seperate sound controls you can bring up for the Terratec so that could be why??
So I think the sound is coming in to the computer ok, but its not coming into Audacity…

I have been fiddling about with this for ages now and I have scoured the forum / manuals and not found anything it could be. I hope someone can help as I am at a loss!! :frowning:


Go into Audacity Preferences and make sure they’re not set to mono instead of stereo.

Audacity > Preferences > Dervices > Recording > Channels.

Also make sure you’re at 16-bit, 44100 sample rate.



thanks for reply,

Yes I’m set to Stereo

I just tried again set to 44100 16-bit, and it hasn’t made a difference… still a flat line :frowning:

To be honest though, the reason I bought this soundcard as a replacement to the USB turntable was for a better resolution conversion.
The rips I did previously from the USB Turntable at that res did not sound good. I believe 44100 is CD- quality (?), but I really wanted to work at a higher quality than that, at 96 / 24.

any thoughts?

many thanks,

There’s a lot more to sound quality than the numbers :wink:
44.1/16 can sound extremely good, or it can sound terrible.

When recording in 16 bit you need to take more care over the recording level than when using 24 bit, but if you set the recording level so that there is a bit of headroom but not too much (about 6 dB is good) then a 16 bit transfer can sound just as good as 24 bit.
With modern equipment, 44100 Hz sample rate can capture the full audio range - there is little reason to go higher. Claims about better “transparency” or improved “transient response” with higher sample rates are just marketing hype - no-one can hear frequencies above 20 kHz so recording them does not improve the recording in any way.

A specific sound card may perform better with certain settings than others, but there is no technical reason why a 16 bit 44.1 kHz vinyl transfer should not sound just as good as 24 bit 96 kHz.

Sorry I can’t help with Mac specific issues - I don’t use Macs, but once you get the Terratec working, spend some time experimenting with sample rates and bit depths and use whatever sounds best. (keep in mind that 24/96 will use a lot more disk space than 16/44.1 and may not play in some programs. Standard audio CDs MUST be 16/44.1 stereo.

I’m still fascinated by you getting the Mac System Preferences to work and yet Audacity fails, even though it recognizes the device. That’s extraordinary. You are at 44100, 16-bit, stereo right? Depending on the USB device, the control is ceded to the device and the Mac stops trying. So it’s really important to match the digitization standards and rates.

Just to do it, try setting Audacity to mono. Then Audacity > Transport > Rescan. Audacity only searches for USB devices when it starts, or when you force it to with that tool.

So if you plug a USB device in after Audacity is running, they will not see each other.


Another oblique idea. Is your device muli-channel over 2? Are you expecting 6 or 8? The system settings should match each other whatever they are.


Why are we recommending recording with Audacity set at 16-bit rather than its default 32-bit?

If ballerina.toast is going to be doing any processing like noise-removal or amplification she/he will be better off working in Audacity’s 32-bit mode and then down-sampling to 16-bit WAV or AIFF with shaped dither on export. This is what we recommend in our tutorials in the manual.


And is the underlying problem here that the Terratec DMX 6fire USB device is a 24-bit device - I thought that Audacity could only work with 16-bit devices unless you built your own Audacity with ASIO support :confused:

Certainly my Edirol-UA-1EX USB soundcard will only work in 16-bit mode and not 24-bit (the Edirol is switchable between 16 and 24 bit) :nerd:


I don’t think we’re concerned with the connection quality. We’re concerned that the connection doesn’t work at all. Koz

On Windows operating systems.

(The 2.0.4 version of Audacity will support WASAPI as the host system which I think does support 24 bit)

I believe that to be the case - but reports indicate that WASAPI in Audacity can be a bit flaky :frowning:


Hi all, thanks for the replies,

@ Steve - yes, I am sure you are right about the ‘numbers’ and I will definitely do some experimentation at different resolutions when I have everything working, and when I feel more confident w/ enhancing etc

@ Koz - what a dummy I am! Yes the device is multi channel, and the ‘phono’ input is 3/4, so I have tried recording on channels 1-4 and lo and behold I have sound on 3/4, and flat line on 1/2!! So is this how I would record, on 1-4 and then delete 1/2 afterwards?

@ Waxcylinder - I am a ‘she’ :slight_smile: And wow - I am confused now. I thought I had read on many (internet) places of ppl using 24-bit soundcards w/ Audacity, in fact, I think this is where I got the idea from.
So is this not the case?
Or do you have to tailor the program yourself to do this, to make them ‘work together’? Is this some kind of plug-in that’s easily installed or is it something quite tech-y, because if so, it is definitely beyond me!
Or is it not a problem as I am on a Mac?
Sorry what is WASAPI?

So I have managed to get the sound in to Audacity now, but now my problem is a massive background buzz, almost as loud as the music! Didn’t have this buzz with the USB turntable & Audacity…could this be a 24bit soundcard compatibility issue?
The soundcard has a phono earth / ground ‘knob’ so I don’t think it’s that. As a test I did a short recording into GarageBand on same machine with same equipment and no buzz? So I think the buzz is something to do with Audacity.

Sorry for all the (what i’m sure are) inane questions,
Many Thanks,

Assuming that there is no way on the DMX 6fire to configure which channels the phono inputs connect to, then yes I think that you will need to do it like that.
Unfortunately Audacity does not currently have “channel mapping” so there is no way in Audacity to assign which channels the inputs connect to.
Perhaps there is some way in the Mac Sounds set-up to configure the channels? (I’m not a Mac user).

Audacity will work with 24 bit sound cards, but up until the (yet to be released) alpha version, on Windows the recording was limited to 16 bit, so even if you set it up to record 24 bit it would actually record in 16 bit. 24 bit recording should work correctly on Linux and Mac.

It’s the latest sound system on Windows computers. Sound on Vista was a bit of a mess but since then Microsoft has introduced a new sound system called WASAPI (Windows Audio Session API).

Does the Terratec have a “ground” connection? If so, you should connect the ground connection on your turntable to the ground connection on the Terratec (with a piece of wire).
Answer: Yes it does - middle / bottom at the back of the device:

Ah, ok I will keep testing with the 4 channels. Didn’t want to do loads of recordings like that if it was a long way round! :slight_smile:

Thanks for other explanations!

Re. The earth cable - yes I am screwed in to the earth ‘knob’ on the back of the Terratec which is why I don’t understand the buzzing. And like I said, it’s only happening in Audacity, as the buzz wasn’t present in a test recording I did into Garageband with the same set up… So really confused as to what the buzz is?


I’m not at all convinced that WASAPI (except possibly loopback recording of computer playback) is ready for release. If it was my call, I’d say no, without “beta” type warnings attached to it.


FWIW, WASAPI was introduced with Vista ( http://en.wikipedia.org/wiki/Technical_features_new_to_Windows_Vista ) and as regards Windows audio features that Audacity supports, little has changed in Windows audio architecture since then.


Have you got Transport > Software Playthrough or Transport > Hardware Playthrough (which almost never works) enabled in Audacity?


Hi gale,

That’s a thought -I’m not sure. I am out and about for a couple of days, but I will definitely check that when I am back - thanks!