file won't go over 2GB

I have Audacity 2.0.5. Since I started to use it, I have done the recording and then exported the file in .flac format (and played the recording in foobar). I’ve done a radio show off and on (now on) and occasionally I have done a file that would be over 2.0GB (these were marathon countdown shows), which wasn’t a problem. (My drive is/was an NTFS drive, and one show was actually 9.5GB, with more than a dozen others above 2GB.) My last recording was in January 2013, BEFORE I bought my new computer with new OS – last computer Vista, this computer Windows 7.

I have tried to record long shows over the past several weeks and when it gets above a certain length, exporting compresses the file more than usual. Audacity will compress the file exactly down to 2.0GB if it would be over that size. So what is typically compressed ~50% can be compressed as much as 75% or more. When I try to play it, the beginning will play, but the recording length is unknown and I can’t move forward or backward, needless to say I need to have files that can record more than 2GB.

I have updated both Audacity and Foobar to I believe latest versions.

FLAC is limited to 2 GB on Windows - see .

WAV is limited to 4 GB, but many applications cannot play WAV files over 2 GB.

What format were you using that was 9 GB and played correctly?


I was using FLAC. I have FLAC files that are as large as 9.5GB. They were recorded before I got a new computer and changed from Vista to Windows 7, as I’ve said in my first post.

If it would help for proof, I’d be happy to actually post the contents of the folder that has all the large files (“Marathons”) if that is even possible to do so. (I don’t know how to copy contents of a folder to some other place as an image).

Open the file manager window. Hold ALT on your keyboard and press PrtScr. Open Paint. Edit > Paste. Save as PNG. Please see here for how to attach files: .


If the requirement is to play lossless copies of shows of unlimited length in Foobar, try exporting as RF64. Please see: .


This should do it for you.
Marathon screen print.png
I wonder if the specs about the Flac maximum size came with Windows 7, since the problem wasn’t there before. (Every file on that list was exported and saved before I switched). So in the end I’m probably going to have to use a lossless file type with no maximum size. I heard good things about Ogg Vorbis – do you concur? Will I need a plug-in for that? Do you recommend something other than that?

This was a long-standing issue in the FLAC encoder when built on Windows that I didn’t think had anything to do with the NT version of Windows the encoder was being run on. See: FLAC-Free Lossless Audio Codec / Bugs / #260 2GB limit still there! .

Was your Vista 64-bit or 32-bit and is your Windows 7 a 64-bit or 32-bit system?

I don’t understand whether the bug being marked “closed” means that Josh Coulson built flac in line with the recommendation given there to remove the limit, or he just won’t fix it.

I thought the limit still existed, but I have a flac.exe that was supposedly built without the 2 GB limitation, so I’ll try that and also the current flac.exe. Please give me some time because exporting huge files is not quick (I don’t have Vista).

Also, what version of Audacity were you using on Vista that exported FLAC files larger than 2 GB? Was that also 2.0.5?

The usual workaround we recommended hitherto was to install Linux or run a Linux live CD and export from Audacity on that. However not everyone will want to do that.

Do you mean a “lossy” file type? OGG is good, but I already suggested RF64 above if you want lossless.

OGG is fine, but for greatest interoperability with other players, you want MP3 or MP4 instead.


Oh, I didn’t realize that Ogg was lossy. I sent that message and then saw your message about RF64.

Please tell me how to determine what my new computer’s OS bit amount is. As for the older computers, I don’t really know how to find out whether 32 or 64. The oldest files from '07 were from an even older computer using XP, I didn’t get my last computer until 2008 (& this one in 2013). Seems like the XP was fine too. I don’t have time for the Linux platform.

I only recently installed 2.0.5 a few days ago. I was using older versions previously.

Take your time. Is MP4 lossy?

Is MP4 lossy?

AKA M4A. Yes.
MP3’s full name is MPEG1, Layer 3. So this compression process has been going on for a while.

There’s a really short list of “lossless” compressed audio formats, and some of them, as you found, have other problems.


See the first reply here:

Audacity 2.0.5 uses libflac 1.2.1 which would have been just before the suggested patch in the bug report.

We updated to libflac 1.3.0 after release of 2.0.5 so I tried doing a standard FLAC export using File > Export Audio > FLAC Files in 2.0.6-alpha on Windows 8.1 64-bit. It was a 3 hour recording at 192000 Hz and I exported it as 24-bit FLAC, compression level 5. Audacity exported the complete file at 5.2 GB and Foobar2000 seems to play it OK.

So I suggest you try 2.0.6-alpha (top file in the list here: ). There is no need to uninstall 2.0.5, just ensure you File > Exit 2.0.5 then unpack 2.0.6-alpha to its own folder and run it from there.

The 2 GB limitation existed in the command-line encoder flac.exe as long ago as 2002. Audacity does not directly use flac.exe on Windows unless you choose “(external program)” when you export and point Audacity to your copy of it. Even so, I still don’t understand how you got previous Audacity to export FLAC files over 2 GB on Windows - no one else I know of had managed it.


I just recorded a nine-hour recording. I see that I do not have the RF64 as an option on my Audacity. How would I record it to RF64? Should I get the plug-in, somehow?

Oh, I saw your other instruction. Won’t have time to try it now, but hopefully later in the day or this weekend.

Just confirming that in 2.0.5 release on Windows 8, I too get FLAC exports over 2 GB trimmed to 2 GB.


I have Windows 7, not 8.

I am aware of that. There would not be any point testing on Windows 7 as you already have done so, but you were suggesting there could be differences between different versions of Windows.

Anyway, the issue is fixed now by the libflac update, so there is no more to discuss.


No, the issue is not resolved. What you propose is not working because what you are proposing is an experimental version that has not been released, therefore it is not tested, and when I try to extract it it does not work.

The issue is resolved in our source code.

It is your choice whether you use an “experimental version” or not. We are just trying to help you and make suggestions. The original Windows limitation comes from the supplier of the encoder, not from Audacity.

As you can read here, I have tested the FLAC export over 2 GB.

Audacity Team typically only use the -alpha version, even for production work (making appropriate backups). So the -alphas “generally speaking” are constantly tested.

There is always a chance of a significant problem in an -alpha build, but at this point in time there is no known problem in 2.0.6-alpha which would preclude its general release. There are issues we would like to fix, many of which also exist in 2.0.5 release.

Please say exactly what you mean by “it does not work”. If you mean you cannot extract from a zip file, try right-clicking over the zip > Extract All… .

Alternatively use RF64 until 2.0.6 is released.


Sorry, I probably came across as rude.

I do not seem to have an RF64 plug-in for my Audacity, which is now presently 2.0.2. Can this be found? And, would I have to close out and start over if I want a long enough file to try RF64 on?

I have consulted with my tech people here locally; we concluded that it must have been an older version of Audacity that was allowing me to make files over 2GB. That simply follows logically from the facts. So 2.0.2 did not work, and I would like to try some kind of Version 1. I have the website up. Do you recommend any one in particular?