Won't Export Full Recording

I have been making and exporting files that were 6 or 7 hours long.
Suddenly, each time, it exports a shorter and shorter portion of the total recording.
I tried “select all” and exporting “Export Selection” and it still will not export the full audio file.

Help! What do I need to do to restore the ability to export the entire recording?

If you are exporting to WAV it’s maximum 2 GB for most players, meaning about 3 hours 20 minutes for 44100 Hz 16-bit stereo (6 hours 40 minutes for 44100 Hz 16-bit mono).

For other formats, Audacity will trim the exported file without warning if you don’t have enough disk space to write it. Check in Windows how much space you have on the drive you’re exporting to.

Make sure you are using Audacity 2.0.5 from Audacity ® | Download for Windows (see the pink panel at the top of this page).


Thank you very much, Gale. That explains the problem. I will just select appropriate lengths and “export selection.”

If you want an uncompressed export format for 7 hours plus of stereo recording, you can use RF64 which has a limit of about 16 exabytes (that is, no practical limit).

Choose “Other uncompressed files” when you export, click the “Options…” button, choose “RF64 (RIFF64)” Header and choose the bit depth in “Encoding”. If you choose 16-bit encoding and 44100 Hz project rate it will use 600 MB of space per hour for stereo or 300 MB per hour for mono, just like WAV (Microsoft) 16-bit PCM.

However Windows Media Player won’t play RF64. VLC and Foobar2000 will.


where are this line? :"Choose “Other uncompressed files” when you export, click the “Options…” button, choose “RF64 (RIFF64)”
from the file exportAIFF(APPLE)16 BIT…
and more
the software v 2.0.5
where i can found the Choose "Other uncompressed files? and the button, choose "RF64 (RIFF64)

In the “Export dialog” Audacity Manual
“Other uncompressed files” is at the top of the “Save as type” menu list.
Then click on the “Options” button to specify “RF64 (Riff64)” as the “Header” and “signed 16 bit PCM” as the “Encoding”.