Feedback about Ver 3.1.2

Hi all,

Finally got round to testing the latest 3.1.2
Actually bought a second hand laptop just for this, it’s a, HP ProBook 4710S
with a nice 16.7" screen, Win 7 (32 bit), Core 2 DUO 2.7 GHz CPU, 4 GB RAM and 320GB HDD
and ATI Radeon graphics.

All in all, not a bad machine (for it’s age) and only paid 50 bucks for it.
Amazing what can be found in a thrift shop, :sunglasses:
I can see why it was sold for so cheap, no battery (no problem just run it on mains)
and has an awful soundMAX audio card buit-in.

Now at least have a PC to try new Audacity releases as they come out without fear of it trashing anything important.
Don’t have any other uses for a Windows computer…oh wait there is Solitaire. :wink:

Since 3.1.2 works on this machine, it will pretty much run on anything I guess.

Also loaded versions 2.3.1 and 2.4.2 to be able to compare any speed differences.
Happy to report that 3.1.2 runs no slower than previous versions and is just as responsive.

Tried various ny, vst and LADSPA plugins, all good with the exception of TAL filter vst,
the latest version crashes after a few minutes of loading TAL.
On the plus side, it did recover the audio files once I restarted.

After about an hour of use, I suspect maybe I closed 3.1.2 too quickly and it crashed.
The test project was un-recoverable, but here is an interesting thing, no waveforms were being displayed
yet when I pressed the spacebar, the audio started playing.
I then proceeded to solo each track, export it as wav and in that way, was able to recover all the tracks.

Maybe something that others can try if they have had a crash, at least you get the audio out.

Another thing I noticed, if I mute a track, then select that track and select “export selected audio”,
the latest version will crash and offer to send a crash report.

Other things I like about 3.1.2, the looping feature is nice, the time shift feature I’m still getting used to
so no comment on that as yet.
The multi-view is nice but unfortunately, the dB waveform display option is gone, same as in 2.4.2 but is there on 2.3.1
I use this feature a lot.
Perhaps it’s still there and I don’t know how to enable it.


It was just a case of not reading the manual.
Steve posted below on how to select the dB scale.
Simply right click on the track’s vertical scale and select either dB or linear.

What I don’t like about the new version is the AUP3 format and how prone it is to crashing and potentially trashing a project.
In 2 days of testing, it crashed 3 times for several reasons.

The devs have done a good job in modernizing Audacity, but I will not be upgrading just yet as I feel that
Audacity and the database pgm (mySQL ??) used to store projects, are still too “disjointed” and I don’t feel it’s quite ready for “prime time”.
I certainly don’t have enough confidence yet to use it on a real project.

I must repeat that I only tried the 32 bit Windows (.zip) version as the OS on this machine is 32 bit.
I’m assuming the 64 bit will be much the same.

I also notice that the audio level error that I wrote about that exists in previous versions is still there.

Wow, it’s a monster :smiley:

Good catch. That’s a bug and happens here too. I’ll log it (if it’s not logged already).

Right click on the track’s vertical scale and select “dB”.
(More details here:

Ha, so it was lurking in the shadows all along.
Thanks Steve.

Just noticed another difference, in previous versions under “View History”, the user could select
any previous action and clear it to so as save on space.

No option available in 3.1.2
Also tried left and right click on each listed item.

That was removed several versions ago in 3.0.0 to be exact, 2.4.2 was the last version with the History Discard button.


Glad that that’s still the case.

Before 3.0.0 with the new AUP3 SQLite database was released I did extensive (and I do mean extensive) QA speed testing to ensure that the new database structure did not degrade the performance of Audacity. :nerd: :sunglasses:



In between other work, doing more testing with 3.1.2 on the dedicated machine.

Created a bigger project with 6 stereo tracks, each 10 minutes long.
Purposely cut them up into multiple clips, applied loads of effects and even doing some recording
directly in Audacity.
(AUP3 file size, just under 1GB).

I saved and exit and re-open multiple times.
Added tracks and deleted some, and some tracks are showing “multiple view”, all to stress test.

Been doing this for the past 2 days and so far, all is good.
Starting to like the new time shift feature as well.
BTW, the new colours in spectral mode are really great and do help a lot.

CPU usage with normal playback, hovers at around 2-5%, going up to 50% when applying some CPU
greedy plugins.
For a Core 2 DUO at 2.7 GHz, it’s very acceptable.

Will keep at it and report back.


One thing I’ve noticed, depending on how many changes (and size) of changes, will determine how long
Audacity takes to compact and save the project when closing down.
ATM, there is no pop-up or progress indicator whilst the saving is happening, only when compacting.
Some users may be frightened that Audacity has crashed, whilst in reality it hasn’t.
Perhaps a progress indicator will help?

Another thing, which is probably due to Windows (7 ??) and not related to Audacity,
when applying .ny effects that really pressure the machine (e.g. Paul L’s declicker),
the Nyquist Prompt window will at times show “…not responding”.
Ignore it, it’s just so busy processing that the OS thinks that it has crashed.

I like that too - in particular I like that you don’t have to shift in and out of the Selection tool in order to move tracks/clips.

Thanks for the feedback,



Found an unloved HP laptop in the equipment store at the studio and loaded Audacity 3.1.2 on it.
Specs as follows:

i3 @2GHz (with AVX extensions) , 4 GB RAM, Intel HD 520 GFX, Win 10 64 bit.
Audacity version loaded was 3.1.2 (32 bit) as the plugins I wanted to test with are 32 bit.

What I found is that the play head marker in Audacity is rather jerky and there is a slight delay
in playback start and also quick play.
The delay is only when starting (or jumping to a new position), there is no audio stuttering
even though the marker is jerky.

Another thing I found is that there is a short “thump” in the audio when playback starts.
This is not due to Audacity (as VLC also does it) and probably related to a
'orrible driver or sound card hardware issue.
The soundcard is a Realtek which are normally OK, so my money is on the driver.
I did update the driver to the latest, yet the problem persists.

I reckon they tried to get “clever” and switch off the sound card when not being used
to save power and the result is the “thump” when it switches on again, who knows!!

As a “fix”, I got one of those 10 buck USB sound cards and the “thump” is gone.
The downside is the “mix” recording facility is no longer available.

So to sum up, the GUI experience of Audacity in Win 10 is actually worse than on Win 7
with a lower spec computer (Core 2 DUO - Win 7 versus an i3 - Win 10), both using Audacity 3.1.2 (32 bit).

At all times, the CPU usage did not go above 10% and RAM peaked at 54% with some plugin processing.
(The total RAM usage in the screenshot includes other apps too, hence slightly higher at 62%).

To lighten the load on the Win 10 computer, I completely nuked all the useless stuff
like Microsoft store, weather, Xbox live, Photos and a myriad of other junk.
All sound “enhancements” are turned off.

Also notice that in Win 7, one could set the priority of apps from low to almost realtime, it seems to be gone in Win 10.
Have to add, first time using Win 10, really not impressed with it overall.

Further Update:

Unfortunately finding 3.1.2 extremely jerky once I go over 10 tracks, by the time there are 15, it’s unusable.

Even just moving the mouse, causes the play head marker to stop, and then catch up later.
The audio continues uninterrupted.
It’s as if Audacity processes the updated position for the marker in blocks of time or samples.
At no time does the CPU go over 19% and RAM is at 58%.

There is also a lag when any track in muted and unmuted whilst playing.

The same tracks on the same computer in Reaper and everything is super smooth and responsive.

I’m not sure what is going on, as mentioned before, the computer is an i3, so not exactly a power house,
but no slouch either.

Perhaps then, this is the same thing that is causing others to mention on the forum about Audacity’s responsiveness?

Another thing, when there are many tracks, 15 in my case and one selects “View → Track Size → Fit To height”
it kind of gives up after certain number of tracks.
I thought that it would shrink the height of all the tracks to make sure they are all in view, irrespective of how shrunk they may become.

Have tried setting the screen resolution to 1920 X 1080 and even all the way up to 4K (3840 x 2160), same thing.

Last update, at least for now.

Made a decision, deleting 3.1.2 and going back to 2.4.2.
I know that the devs have put a lot of effort and work into the latest updates, but sorry,
it’s not ready for anything bigger than a casual project.

The same 15 tracks mentioned above, super smooth with 2.4.2.

Then, latest test I did, importing audio from a mp4 video.
Nothing special about the codecs used, h.264 video (1920 X 1080p , 25 fps, 2Mb/s) and audio is
48 KHz stereo, 192 Kb/s AAC.

The video is 2.5 hours long, version 3.1.2 took 11 minutes to import the audio, whereas version 2.4.2
took just over 2 minutes.
Huge difference and same ffmpeg import lib used.

Also, maybe it’s just my imagination, but 3.1.2 seems more prone to crash with some plugins, whereas 2.4.2 (and 2.3.1)
just seem to be more tolerant.

It was interesting to test the latest version, and glad I did to satisfy my curiosity, but will wait several months
until the new version/s mature and perhaps will revisit then.

Thanks for posting the results of your testing.

My performance tests have not been as bad as yours, but I’m using an i7 with SSD, so that’s to be expected. Nevertheless, your comparison with earlier versions seem to tally with my experience. I’m finding that 3.1.2 works pretty well with simple and / or short projects, but with larger / more complex projects the performance and reliability seem better with 2.4.2.

I’ve noticed in the commit log that there have been a number of recent changes aimed at improving performance. I’m expecting that they will be in the next release, so you might be interested in giving that a quick test when it comes out.

Hi Steve,

Thanks for confirming that your results are pretty much in correlation with mine.
Yep, the i7 with SSD will make a big difference, BTW I wonder what the average computer of
the average Audacity user is.

My normal setup at the studio is Audacity (2.3.1) on a Mac Pro 6-Core Xeon E5 3.5GHZ and it’s an absolute monster,
processes those 32 bit audio samples without even breaking a sweat, at home I use a Macbook Pro i7 also with 2.3.1,
so that is probably part of the reason I’m finding an i3 with Win 10, a bit clunky.

My Debian boxes all run 2.2.2 with various CPU’s ranging from a Celeron to an i5.

Will keep an eye out for the new (hopefully improved) version of Audacity and give it a test run.

I’d guess that it averages out around an i3.
We certainly have a few users on Chromebooks and even Raspberry Pi, but also some pretty high end machines.
Mac users tend to have fairly high spec machines as older 32-bit Macs have become obsolete.

I used to test on an old Pentium II with XP, until we finally dropped support for XP (around 2017).

Steve wrote:

I’d guess that it averages out around an i3.

Fair enough, so my using an i3 is pretty much average use case then.

I used to test on an old Pentium II with XP…

Hope you re-purposed the machine with some Linux distro and didn’t just throw it away.
Put jack audio server on it plus a guitar rack and hey presto, instant effects rack.