"Failed to read from a file in C" when opening project

Hi, there. So, I have a project that I spent a lot of hours on that I foolishly thought was being backed up automatically to an external disk. Well, it wasn’t, and this morning after a few crashes, I received the error message “Failed to read from a file in C” when I tried to open the project. No matter how many times I try to open it, it’s the same error. I’m worried that I lost all that progress, but I’m hopeful there’s some way to recover it.

I’m using Windows 10.0.1. My version of Audacity was 3.0.2 when I received the error. I updated to 3.0.3 to see if it would help, but it didn’t. I also ran diagnostics on my C drive and made a copy of the project folder to see if it made any difference. So far, no luck. I’ve tried googling and searching this forum, but I only see people receiving this error when their project is already open and they’re trying to export or add effects. Some people also say it can be a lack of hard drive storage, but I have plenty.

Here are the problem details:

“timestamp”: 1629411735,
“event_id”: “481f13b86d1f8843bbae1290fa21e469”,
“platform”: “native”,
“release”: “audacity@3.0.3”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.19042”
“exception”: {
“values”: [
“type”: “File_Error”,
“value”: “Audacity failed to read from a file in .”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “101”,
“sqlite3.context”: “SqliteSampleBlock::Load::step”

I’d really appreciate any help I can get to see if I can retrieve this project. Thanks.

So this error is frequently caused by a damaged .aup3 file. I will be happy to look at your file for you if you wish to zip it up and upload it to a public file server. If you do this, post or PM me a link.

Thanks so much. I’m zipping the file right now.

I … thought was being backed up automatically to an external disk.

Why did you think that? Did you set up an automatic backup task? Windows has one.


And you can do it using third party software.

this morning after a few crashes

Does Audacity crash all the time? So what’s different this time is Automatic Recovery failed?

Do you have enough original files or tracks to put the show back together from zero if you had to?


I have a WD external drive with automatic backup software, and I didn’t realize that the auto backup hadn’t been working for a little while. It’s my fault for not checking.

As for the crashes, it occasionally happens for me in Audacity, especially when the file gets to be large. Up until now it’s always recovered perfectly when I reopened the program.

Did you ever finish zipping the file?

Sorry, yes. It’s a large file and took me a while to upload it to Dropbox.


You are telling me! 17GB. 3 hours. 104 Tracks. I did not know Audacity projects could get this large. :wink: Anyway, working on it…

Thank you so much! And yes, it’s pretty large, lol. You can imagine my horror when it wouldn’t open.

I have something uploading now. It will be another 10 hours or so; if all goes well, I should have a link to share by tomorrow. :smiley:

You are amazing!!! You seriously just made my week, thank you so much.

Don’t thank me just yet - it is still uploading. And, it is still on track to finish tonight. Keep your fingers crossed. :smiley:

:frowning: Bad news - upload failed. Don’t know why - it said not 'nuf room - but there was. I am now trying to create rar file then I’ll try again…

Ok, thanks, I really appreciate all the work.

This is not work, just frustration with google. :wink: So it is on its way again - it says just over 8 hours from now. So I’ll take a look then, and hopefully I’ll be able to post a link around that time. :smiley:

6 hours later: the upload is still on track.

Finally! The upload finished! I sent you a PM with the link. :smiley:

I just sent you a request to access the file. I seriously can’t thank you enough.

Try again now. :smiley:

Downloading! :smiley:

After a few fails it finally downloaded perfectly. You are a serious lifesaver!