Exporting .wav files with different changed sample and format not saved

I have a Windows 11 home version 22H OS build 22621.2134, a Lenovo laptop, and I have Audacity 3.3.3 freshly installed.

I am exporting .wav audio files from Finale which are stereo, 32 bit PCM and have a sample rate of 48,000.
To use this audio with my Tascam2488 recorder, the .wav file must be mono, 16 or 24 PCM (of course, I prefer 24 bits) and sample rate 44,100.
After loading the Finale file, I selected ‘Split Stereo to Mono’, and deleted the second mono track. The tracks were recorded with everything at center so both were nearly identical.

I then selected the rate and format items from the audio file’s drop down menu to the left of the audio graph and chose ‘24-bit PCM’ and ‘44100 Hz’, and then proceeded to export the file selecting ‘Export->Export as WAV’.

In the ‘Export Audio’ popup window, I selected the file destination with new name, saved it as type ‘WAV (Microsoft)’, and saw that the encoding was ‘Signed 24-bit PCM’.

I then closed the file and Audacity, reopened Audacity and tried both importing and loading the newly exported file ‘The_Gown_Sail_yet_again.wav’ but although it is mono, it has the initial sample and format values.

Am I doing something wrong?
Should I use something other than ‘WAV (Microsoft)’?

I went into ‘Edit->Preferences->Audio Settings’ and under ‘Quality’, I changed the Project and Default sample rate values to ‘44100 Hz’ and now the exported file has the correct sample rate.
But even though I updated the ‘Default Sample Format’ to be 24-bit, opening the exported file still reports ‘32-bit float’.

Thank you in advance!

The Project Sample Rate under Audio Settings determines the sample rate for the exported file. (The “rumor is” there are some changes coming that will make this easier.)

You select the bet depth when you export and I’m sure that’s working fine for you, but by default Audacity works internally at 32-bit floating point and if you re-import it will always show that bit depth and it’s fooling you.

You can check the actual format with MediaInfoOnline (or you can install MediaInfo on on your computer).

1 Like

Thank you, Doug! I just discovered the fix for the rate in Edit->Preferences->Audio Settings myself, but I didn’t understand why the format wasn’t reporting correctly.
Also, thanks for the link to check the format!

In the upcoming 3.4.0 release the Export dialog is upgraded to give you full control over these and other parameters at export time.

The dialog for Export will look like this:


1 Like

Thank you, Peter!

Are there any plans to incorporate time stretch directly into Audacity?
I should have known (but didn’t think about it) that after converting my audio from Finale for my Tascam recorder, the pitch was lowered and the song was slowed down.
I saw in the forums that there is a plugin, but it seems that for any utility that can convert the sampling rate, there should be a way to compensate for the conversion?
Anyhow, it seems like there is a work around, so thanks to everyone at Audacity and in the forums!

One of the Muse developers is currently working on stretchy clips - and Muse are hoping to have this in for 3.4.0 (but will depend on there being no major bugs with it).

I believe that the functionality for this made it to the alpha test builds last week sometime - but Muse QA testers have already logged a fair few bugs.


1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.