Export Multiple Files Hangs

I am new to Audacity but managed to get it up and running.
Running Windows 10 and Audacity 2.3.2
Copy LPs to digital format.
My initial project was to record an LP, both sides, into Audacity, label the tracks and then Export as multiple to local harddrive.
On export, the export function stopped and the “file” became “not responding”. Had to close Audacity.
The file where the export stopped happened to be the last file on the 1st side of the album where I had paused the recording process to turn the LP over.

  1. Error in the log is
    12:33:42: Error: Couldn’t find symbol ‘AudacityModule’ in a dynamic library (error 127: The specified procedure could not be found.)
  2. I have loaded the FFmpeg (avformat-55.dll) in a folder I have pointed Audacity too.

I started a new project and recorded just one side of the LP; on export it hung on the same file. I then deleted the last file from the project and the export completed successfully. It appears that there may be some issue at the end of the last file; maybe not closed properly when Audacity is either stopped or paused.

Any suggestions on how to correct this problem
Oct21.txt (2.97 KB)

I won’t attempt to solve the problem but I can give you a work-around.

I just select/highlight one song at a time and then File → Export → Export Selected Audio, one song at a time… (Usually, I’ll select a little extra, then open the files one at a time and zoom-in for more-careful trimming.)

Thanks for the suggestion…
This would take a lot of time to do one song at a time.

I have been trying to understand how/when this error occurs.

  1. The error seems to indicate that the Audacity Cross Platform Sound Editor stops responding

  2. This appears to happen on any LP I try to export in multiple; hangs on the last song on that side; oddly the 6th song

  3. I can export the entire recording as one file with no issues.

  4. If I record the first 5 tracks from the LP, no issues exporting in Multiple

Is there some limitation in Export Multiple I’m not aware of?

None that I know of - I have digitized thousands of LPs and tapes that way

WC

How are you placing your labels? What is the exact text of the label for the file which hangs? Are you removing the “silence/junk” between the last track of side A and the first track of side B; if so how? Basically the same question for when you only record one side of the album - are you trimming the excess after the end of the music?

One thing to try… After you have done all of your editing on the long recording (one or both sides), export the entire thing as a WAV file; close audacity, then restart it; import that long WAV file; place your labels; try Export Multiple again.

Edgar in response to your questions:

Labels are placed by navigating to the space between songs; edit/labels/add label at selection
The text varies but no punctuation I.E one label is - Kitty Can
I am not removing or modifying anything; simply record the LP, place labels, then export multiple

I will try your suggestion to export as a WAV file; import and then place the labels and export again in multiple

From what you say, I suspect you are using “region” (non-point) labels; I’ve also digitized thousands of albums using Audacity but I always use “point” labels and remove all the “stuff” I don’t want. We might need to see either a picture of your project or have you zip up a failing project for us to inspect. Let’s start with a picture; first, go to the View menu and select “Fit in window”; next, do a screen grab (toward the top right of your keyboard there is a print screen key - pressing it will send a copy of your screen(s) to the clipboard. Using your favorite painting program (Paint3D comes with Windows 10), paste the clipboard and save the resulting image to your desktop(or wherever you choose). Reply to this thread; below the text input area you will see a tab labeled “Attachments”; clicking it will expose a" Add Files" button - choose it and follow the directions to post your picture. The forum will not allow you to post an Audacity Project so if you decide to zip up a project you will need to post it to something like DropboxAnd post the link here.

Your text in the label should be okay then; I wondered if you might be using characters which your file system did not recognize.

I imported a previously exported continuous file. Added the labels and tried to export as multiple. Same issue at the same song/file.
I am exporting the file as "WAV(microsoft) signed 16-bit PCM which was the default when I started Audacity. Maybe not what I should be using.

I did a multiple export of the same file but changed the export to MP3 files - standard 170-210 kbps; this file exported successfully.

Is there any chance you are running out of hard drive space? WAV files are a lot bigger than MP3s. Are you adding any metadata (tags)?

Space isn’t an issue; I have 711Gb free.
No metadata, just the labels.

Could the file size be an issue?

Not with that available storage. I’m at a loss here!

FWIW, you asked about other than WAV - that format is virtually obsolete and has a number of minor drawbacks (especially tagging and lack of file-size compression). It is lossless, which is very good for some things (archival storage of original raw data) but for general usage FLAC might be a better choice (it can be both lossless and compressed in size). If your player(s) can handle it you might like it (other than car stereos, most do).

I’m not going to pursue this.
Since the MP3 files work fine and are smaller in size they would work better for me.

I am having an identical issue on Ubuntu 23.04 and Audacity 3.3.3. Does not matter if I install it over appImage, apt (v3.2.4), or snap(v3.1.3). Is there a way to debug this?
Thanks

Update:

  • When I switched to Windows 11 on the same machine, the export worked.
  • When I built it from source on Ubuntu in Debug mode ( see: https://github.com/audacity/audacity/blob/master/BUILDING.md), the export also started working.
  • Then I tried to install it over sudo apt install audacity and the export started working as well, so it might have been due to installing the dependencies mentioned in the BUILDING.md file or there was a glitch that was fixed by rebooting the system…