Error Opening Sound Device

I recently downloaded Audacity 2.4.2 on my Windows 10 operating system. However, I have not yet been able to use it. I opened an MP3 file, and tried to play it, and received an error message that read: “Error Opening Sound Device. Try changing the audio host, playback device and the project sample rate.”

I’m not sure how to begin going about solving this problem. Any recommendations would be appreciated, thanks.

The first thing I’d suggest is to reboot the computer.
Ensure that your headphones are connected before you launch Audacity.

I have the same issue and tried all the things listed in the online help documents. I need to create an mp3 from a file and I can’t do so with the newer version. An older version I had required me to download a LAME file, but apparently those are included in the latest version of the program.

That sounds like a totally unrelated issue :confused:

I was able to use the older version with all the sound devices and they opened easily. Now, nothing is recognized.

That’s the issue, I can’t do anything with the 2.4.2 version, I have worked through all the troubleshooting and setting adjustments and it appears as if nothing is recognized with this new version. Yet I need the 2.4.2 in order to create mp3s now since the older versions are not supported.

The first step is getting sound devices recognized by the program, then I can create the mp3

Old versions of Audacity still work on Windows.

I concur, they do. But they don’t support creating mp3’s without a LAME file (not included in my older version), which cannot be downloaded from the Audacity website since the current version has that already installed. I’m at a standstill, use the older version to record so I can hear the audio, but I can’t touch the conversion to mp3…

Trying to figure out what I can do, I though the simplest thing would be to figure out why I can’t get the sound devices opened and recognized.

What is the exact error message and when does it occur?

On program startup, I get an “error initializing audio”

It says Could not find any audio devices. You will not be able to play or record audio.

Error: Internal PortAudio error.

After I click the ok button I go immediately to the diagnostics for audio and I read

Default recording device number: -1
Default playback device number: -1
No devices found

I have done all that I can do with the online troubleshooting and I still get these errors. Just confused as to why it works in older versions but not this one and if there’s anything that can be done to correct it.

Which was the older version? Do you still have it?

2.1.3 and it came on a cd with the cassette to digital recorder that I just purchased.

I definitely still have the version on disk.

I’ll shut my pie hole now…

It appear that there was a LAME .exe file on the disk… nowhere in the instructions for this device does it mention the two files on the disk… I’ll try using the older version to fix my issue with the LAME file installed.

The exact error message I’m getting is, “Error Opening Sound Device. Try changing the audio host, playback device and the project sample rate.” It occurs when I try to play an MP3 file after it is open.

I’m also receiving another error message when I open Audacity which says, “Error Initializing Audio. Could not find any audio devices.”, although the full error message is blocked by the Audacity logo on startup. When I close the message I can briefly read for a split second what the rest of the message says, something about “You will not be able to record audio. Error: Internal Port Audio Error”

I recently installed Windows 10 on my computer, so maybe I’m missing some drivers that I need?

I am able to listen to audio files, such as on YouTube.

Thanks for your help.

That’s possible.
What is your computer and if you’re not using the on-board sound-card what sound card / audio device are you using?

My computer is a 2014 ASUSTeK x64 based PC. OS: Windows 10 Pro. Processor: Intel(R) Core™ i5-3570K CPU @ 3.40GHz (4CPUs). Memory: 8192MB RAM.

My audio devices are: Digital Audio (S/PDIF) (2-High Definition Audio Device), ONA18HO015C (High Definition Audio Device), Speakers (2-High Definition Audio Device). The status of the devices shows that they are working properly.

In the Audacity Help tab > Diagnostics > Audio Device Info, there is listed:

Default recording device number: -1
Default playback device number: -1
No devices found

In the Edit tab > Preferences: Devices, the boxes for the fields Interface Host, Playback Device, Recording Device, and Recording Channels, are all blank.

Does this mean that Audacity is not compatible with my device drivers?

For more help see:

Is that the speakers in your monitor?

Do you not have a recording device? No microphone or any other analog audio input?

ONA18HO015C (High Definition Audio Device) is the speakers in my monitor.

I don’t have a recording device, or any other analog audio input.

I’m only trying to use Audacity to edit MP3 files that I’ve downloaded from YouTube.

If I try to use Audacity to open an MP3 file, a message appears that says that the file is being imported, and I can then see on the screen that the file has been successfully imported. The problem is that I’m unable to play the file. Do you know what the reason could be for why I’m unable to use Audacity to play the MP3 files?

As I previously mentioned, I’m receiving 2 error messages. The first error message occurs at startup when I launch Audacity, which reads: “Error Initializing Audio. Could not find any audio devices. You will not be able to record audio. Error: Internal Port Audio Error”. The second error message occurs when I try to play an MP3 file, which reads: “Error Opening Sound Device. Try changing the audio host, playback device and the project sample rate.”

Thanks for your help.

That’ll be the problem. Audacity requires an input device (it’s an audio recorder after all).

It’s highly unusual for a PC to not have any recording device at all. Why doesn’t your computer have one? Have you disabled the built-in sound card?

So I assume your issue is only with Audacity and that you are able to play mp3 files through VLC or some other audio player…

Sometimes, Audacity gets stuck with a particular I/O device, for example, bluetooth headphones. When this happens Audacity just gives up and can’t seem to find any devices at all. One thing to try is to eliminate and/or disable all of your USB and bluetooth audio devices, and then re-start Audacity. If this fixes the problem, it is a simple matter to re-enable them one-by-one to find the culprit.

Recently, some other folks on Mac were having difficulties with some plugin causing similar symptoms. So another desperation move would be to rename your “audacity” configuration directory to see if something hiding in there is causing the problem. On Windows, the directory is located at C:\Users<your name>\AppData\Roaming\audacity. Note that AppData directory is hidden, so you may need to check show “Hidden items” in the View tab in File Manager.

I hope this helps. :smiley:

I’m having the same issue. NO Bluetooth active. I’ve uninstalled Audacity 2.4.2, re downloaded & reinstalled…same error - Could not find any audio devices.