Error Opening Sound Device

I am currently running Windows 10 and Audacity version 2.2.2. Have been using Audacity in Record mode for several years with this configuration, except was using Audacity 2.2.1. immediately prior to this problem.

“Out of the blue”, with no changes to my system (including Windows updates) I suddenly (when trying to record) get the well known error message “Error opening sound device. Try changing audio host, recording device and project sample rate”.

I visited the Audacity forums, help files, and various web searches, and have implemented the following attempted solutions (multiple times) to no avail:

  1. In both Windows and Audacity sound settings, insured that both Playback and Recording sound devices are selected and enabled. My Recording device is “Stereo Mix: Realtek High Definition” and my Playback device is “Speakers: Realtek High Definition”.

  2. Verified that Project (Sample) Rate is compatible with above mentioned devices. Am using 48,000, but also tried 44,100 and lower settings, all of which are compatible with the Realtek integrated sound board.

  3. Tried using each of the audio host settings available (MME, Windows WASAPI, Windows Direct Sound).

  4. Uninstalled and Reinstalled Audacity, upgrading to latest version 2.2.2

  5. Uninstalled and Reinstalled latest Realtek audio driver from my computer manufacturers website, using my specific model and serial number.

  6. Made sure all “Software Playthough” was turned off in Audacity Preferences.

  7. Restarted Windows Audio Endpoint Builder service.

All of the above was performed multiple times and in multiple combinations.

My external computer speakers work fine both before and after this recording problem.

Need solution to be able to record.

Have been using Audacity in Record mode

Is that fuzzy-speak for “I’m recording free music from YouTube?” Settings for that are different from recording a live microphone.

Realtek audio driver from my computer manufacturers website, using my specific model and serial number.

Did the drivers say, “OK for Windows 10?” They should. Windows 10 is not a fluffy update. It’s a whole new OS and software has to be written for it. Win10 killed off lots of legacy equipment whose older Windows drivers didn’t work any more.

Uninstalled and Reinstalled Audacity, upgrading to latest version 2.2.2

Audacity Windows Installer has a click to make it completely reset all preferences and settings. Did you click that? If you didn’t, you got the older settings brought forward at every install.


Recording device is "Stereo Mix:

Are you trying to record streaming audio?

Have you tried recording from a microphone or from line-in (if your computer has line-in)? It might be helpful to know if everything is totally fouled-up, or if it’s just a problem with Stereo Mix.

For streaming audio try WASAPI loopback.

I have had this same problem since the latest big W10 update. As far as I can remember I think I had Speakers as my recording source option but it is no longer available as an option. For years I have been recording online interviews and lectures with Audacity so I could listen to them at a more convenient time but I am no longer able to do this. It seems not to be a problem with the speakers as I am able to record the same material using a different app but I would prefer to use Audacity if I could get it to work.

See this sticky thread:



ONE: As per DVDdoug’s suggestion to use WASAPI Loopback, this works:

  1. Set Audio Host to Windows WASAPI

  2. Set Recording Device to Speakers (Realtek High Def Audio) loopback

  3. Set Playback Device to Speakers (Realtek High Def Audio)

Recording function works normally.

TWO (THE REAL CULPRIT): As per waxcylinder’s suggestion to enable microphone settings, this works:

  1. In Win10, go to Settings+Privacy+Microphone. Turn on Allow Apps to Access Your Microphone (toggle).

  2. In Audacity, can now use typical recording settings: Audio Host to MME, Recording Device to Stereo Mix (Realtek High Def), Playback Device to Speakers (Realtek High Def).

Recording function works normally.

Many thanks to Audacity Forum members.

Thank you jai2 for the correcting process. My microphone works fine mow. The real culprit was the Windows update. Wasted 6 hours trying to fix the problem in Audaccity.

Thank you. WASAPI has worked for me. This is such a relief. I greatly appreciate the help.

Oh my frkn goodness! After Hours of Troubleshooting the long list of things to try ^ THIS was the issue!
So simple. Yet with the privacy setting thing… Does that now mean Microsoft can listen to anything anytime around the mic?

@waxcylinder Thank you so much for your post in this thread. I had to register to this forum just to thank you.

^ This fix worked for me! After hours of troubleshooting I knew it had to be something to simple…

Thanks again… I’m copying and pasted the thread here in case it helps others;

For some users Windows 10 is now blocking Audacity from using the microphone, on the basis of privacy settings.

After upgrading to version 1803, a small number of users have been reporting that the microphone is getting detected, but it doesn’t pick up any sound.

In order to get around this issue, Microsoft recommends that you need to enable the microphone in your Privacy settings using these steps:

  1. Open Settings
  2. Click on Privacy
  3. Click on Microphone
    4)Turn on the Allow apps to access your microphone toggle switch.

See this Microsoft website for more details: … ows10_1803

I note that there are two settings there one for the apps to access the mic - and another (a bit more hidden behind the button) for Microsoft access.

I haven’t tried turning of Microsoft access to the mic and then trying to run Audacity - maybe I should …


I found a solution that worked for me, the previous solutions hadnt, but this worked
I have my current settings set to Windows WASAPI, the recording device is my Speakers (realtek(R) Audio) (loopback), and my output device is the Speakers (Realtek(R) Audio)
But there is one thing I changed, which is the audio channel I believe, its the number to the right of the recording device, it is usually set to 1 (mono), but I instead set it to 2, which didnt work, then I tried 3 which also didnt record anything, and then it worked of 4
Otherwise, I would always get an error stating that the device is inavlid, it was error -9996

Ok I also found another issue, but some times it still gives me the error of it finding no device, usually it gets fixed when I have atleast some audio playing, so if I unmute the online meeting or something of that sort

Zoom and other online meeting software programs have a tendency of changing device settings and making it difficult for Audacity and other audio recording software to function properly.

I believe Zoom can send you a recording of your meeting if you make a request.

I hope this helps. :smiley:

I got the error tonight when I chose speakers (Realtek Audio) (Looback) and tried just about everything. I use Wasapi in Windows 10. Then I realized I had been recording my mic and had it set it to Mono. Simply switching to 2 (stereo) recording channel did the trick for me. Hope this can help someone else.

I have got rid of the problem by enabling the audio device.