"Error opening sound device"

Hey, I’ve tried to fix this for a long time today by watching many videos and such. When I press record, I get the error message “Error opening sound device. Try changing the audio host, recording device and the project sample rate.” I changed the sample rate to fit my headset (Logitech G433 Gaming Headset) so that shouldn’t be a problem. I also set the preferences to fit my headset, though it seems I can’t record any audio from games or YouTube, etc. I really don’t know what to do, but my headset is connected to a USB two-in-one. I don’t know what to do…I can record mono but when I change it to my main audio input and output (both speakers logitech g433 gaming headset). Does anyone know what I can do to fix this so I can record youtube videos and such to make music edits? Thank you.

Does anyone know what I can do to fix this so I can record youtube videos and such to make music edits?

It depends on your drivers.

[u]Recording Computer Playback[/u] suggests several ways of doing it. If you have Windows 7 or later the WASAPI loopback method usually works. …Make sure you’ve selected “loopback” from the device the sound is coming out of… If you’re listening through USB headphones, select the USB device, etc.

Or, there are [u]tools for downloading YouTube (or other Internet audio/video[/u]. Once you have an audio/video file, Audacity with the optional [u]FFmpeg library[/u] can open the audio from almost any audio/video format.

Note that it’s a violation of the YouTube user agreement to download or record from the site, and since most of the program material is copyrighted it’s also usually a copyright violation.

You’re not alone: there was a Windows [10] update a few days ago which appears to be responsible for this problem,
see …

My Windows 10 updated over the weekend and I have the very same issue with the same pop-up when I click record - all my Audacity/Windows sound settings are correct.

I rip vinyl through a USB soundcard at 24/96kHz with all the current divers installed.

Microsoft appears to have changed the presentation of their sound settings. When I click on input>device properties>advanced on the new sound settings page, Windows defaults everytime to 16/48kHz after clicking ‘apply’. The original sound control panel is found on the right hand menu and this does allow me to set my recording quality to 24/96kHz.

However the pop-up still occurs everytime.

I also have Audition and tried to record with that however they have the same issue.

Oh Microsoft …what have you done now? :unamused: :unamused:

Anybody figured out a fix yet?


Ook ik heb dit probleem nadat ik een Windows-Update heb gehad. “FOUT BIJ OPENEN VAN GELUIDSAPPARAAT”
Ik ben vinylplaten aan het opnemen via de microfoon ingang. een week geleden werkte dit perfect en nu dus bovenstaande foutmelding.
Ik heb audacity 2.2.2 voor windows. Ik heb mijn drivers ge-update en audacity opnieuw geinstalleerd maar dit heeft niet geholpen.
Graag een oplossing
Wim :?: :!: :?:

Google translate:
I too have this problem after I have had a Windows Update. "Error opening sound device "
I’m recording vinyl records through the mic input. A week ago this worked perfectly and now so above error message.
I have audacity 2.2.2 for Windows. I updated my drivers and installed audacity again but this hasn’t helped.
Like a solution

Hello folks! I believe I have found the solution to this little issue.

It seems our cruel gods over at Microsoft have added a new feature under the Privacy tab with the latest update (as of this post). I believe this to be the source of our sound device errors:

-Firstly, Head to your Settings menu and go into Privacy, from there click the Microphone tab.

-You see that “Allow apps to access your microphone” section? If you’re reading this forum, then you probably have the slider below it set to “Off.” It appears that’s what it defaults to post-update (thanks, Microsoft :unamused: ). Let’s try sliding that to “On.”

-Now a bunch of the sliders further down will slide On. This is probably for the best, so ignore it.

Aaaaand, that’s it! Upon changing this setting, my Audacity is working fine! (Sucks that I bought a whole new audio interface since I thought my first one was busted… But, oh well! :confused: :laughing: )

I hope this helps the (many) others who have run into this issue! Happy recording!

Bingo …that worked!

Well done for working that out, I no longer get any device error warnings.

I had the same problem, and your solution worked like a charm. Thanks.

OMG, I just spent 3 hours with Dell trying to figure out the same issue. They gave up on me. This settings tab did the trick. Thank you!!!

Hello !

Thank you very much for the tip MultipleMeanings ! The record function run again :wink:

Thank you so much for sharing this!!! I have a new TEAC turntable, and I couldn’t record from either Audacity or Golden Records Converter. I tried everything I could think of and was about to throw the turntable out the window!!! Everything is working great now!!!

I should have known it was a Windows issue!!! :laughing:

This is replay for many people here.
By receiving this message ‘Error opening recording device. Error code: ´9999 Unanticipated host error’
do the follow: Enter Configuration and in Privacy , select microphone . Check if it is grayed or not.

Please Help?
I have this same “error opening sound device” error.
I see you all have the solution!
Why can’t I see it?

I am running windows 7
Where is this “Settings” you all refer to?
Where then is this “Privacy” tab?
Are we in Microsoft Windows or Audacity?
(I can’t find these tabs in either)

I have scoured google & youtube for a solution but they are rare & indecipherable to a non-techie like me…highspeed videos of unreadable actions on a PC. I have updated Audacity as well 2.1.0