Audacity 2.2.2 for Windows 10 Error

Good afternoon Audacity Forum Administrator. My name is Dan Pettegrew. I’ve been using Audacity since 2.0.5. I’ve had much success in using the software. Thank you for offering it to the public. Yesterday, I encountered the “error opening sound device. Try changing the audio host, recording device and the project sample rate” message when I click the record button. I’m using the Alesis IO/2 interface on a Toshiba laptop. I’ve attempted to change the audio host, recording device and project sample rate but still am getting the error message. I’ve scanned the internet for possible solutions and nothing has worked. I’ve uninstalled the software and attempted to reinstall 2.0.5, 2.1.1, 2.1.2 and 2.2.2 to see if I can get a version to work. The error message still pops up when I select the record button. Is there anything else that I can try to resolve the problem? I’m using Audacity for a training broadcasting program for teens and young adults. We’re in the middle of a broadcast assignment and this has brought me to a halt. Any recommendations would be greatly appreciated. Thank you, Dan

Check that your Alesis interface is enabled in Windows recording devices …
If it’s not enabled, Audacity can’t “see” it, and will give that error message …
Error message.png


Good afternoon Trebor. Thank you for the tip. I checked to see if the Alexis IO/2 is enabled and it is. I’m able to import/open a file, edit a file, save a file and play a file but won’t allow me to record one. There was something I did differently on Saturday. I sent a 1khz test tone through channels one and two to calibrate the levels on the IO/2 from an external playback source. I recorded two songs through channels one and two for our Tea Time With Teen Day Music Library with no trouble. Upon recording songs three and four, the IO/2 channel two wasn’t responding properly to the input levels in relation to channel one. I had to boost the levels on channel two once the song files were recorded. The Audacity software was closed. I wanted to run another test tone through the IO/2 but instead of sending it from the external source, I went online and played it directly through the Toshiba.

I also have Sound Forge Audio Studio 10 on the laptop. It was open at the time and the playback of the test tone crashed the software. I closed out of the program. I tried logging into Audacity and that’s when I encountered the error message. I wasn’t recording in either Audacity or Sound Forge at the time the test tone was sent. I thought I may have corrupted a recording device, so I was able to find how to check sound recording drivers in the laptop and didn’t locate any damage. I’m not the most savvy when it comes to computers. This one has me stumped. I saw you also provided an alternate audio recording software. I’d like to retain Audacity as my primary, if possible. I did reinstall the Alesis IO/2 Driver but selected the repair option. Could I try reinstalling the Alesis IO/2 Driver and reinstall it as a new install? Thank you for the help. Let me know if there are any other troubleshooting tips I can try. Have a great day, Dan
Sound Recording Devices.JPG

Good afternoon Trebor. Forgot to include this on my previous post. I uninstalled both Audacity and Sound Forge to see if that would work. Audacity was able to reinstall. When I entered my Sound Forge Product Serial Number, it wouldn’t allow me to reinstall. Trying to reach Customer Service but doesn’t appear they are supporting Version 10 any longer. I’m downloading the Ocenaudio software to see if I can get that one to work. As of now, I’m unable to confirm that I’m able to record at all with any software. Thanks, Dan

This recent Windows10 microphone-privacy feature could be the problem …

Hi Trebor. I just downloaded and installed the Ocenaudio software. This is interesting. Can’t get it to work in either playback or record. The control buttons are grayed out. Contacted their online feedback form to see if I’m doing anything wrong. Couldn’t find any help section or online manual. Everything seems to point to the laptop. Will check out your Windows reply too. Thanks, Dan

Hi Trebor. I checked the Windows 10 microphone-privacy feature. It’s defaulted to “On”. At least, it narrows down what could be causing the problem. Thanks, Dan
Microphone Privacy Settings.JPG

It’s normal for OCENaudio transport buttons to be light/dark gray, they still work …
OCENaudio drag'n'drop then play.gif

Good afternoon Audacity Forum Community. I’d like to thank all of you for your assistance regarding my Windows 10 Error Message. I attempted to use all of your suggestions to pinpoint the trouble but the error message still kept appearing in my record window. Finally, I accidentally fixed the problem yesterday. Somehow my Windows 10 microphone setting was indicating it was on but actually it was in the off position or jammed. Not exactly sure. I had received a notification from Google that my Google Voice # had expired so I had to create a new one. When I attempted to record a new greeting, this error message popped up on my screen. Please see attached. (Continued)
Google Voice Error Message.JPG

I had remembered early on that I was advised to check my microphone settings and it showed that the microphone was on. I went back into the Microphone settings and it still showed that it was on. I wasn’t sure what I was looking for but it had something to do with the microphone settings. I noticed that the apps selections listed below the access button were grayed out. Didn’t know if that was ok or not so I used the cursor to slide the Allow Apps To Access Your Microphone button to the on and off positions for a few times. I noticed that the apps selections switched from grayed out to an active mode. Then some of them defaulted to the on position. Please see attached. I scrolled down the list and saw Voice Recorder. It had defaulted to the on position. I closed out of the screen and opened up the Voice Recorder app. There was a record button which I selected and it began to record. I clicked the stop button and a play button appeared. I clicked the play button and heard the few seconds of audio I had recorded. I then closed out of the Voice Recorder app and opened up Audacity. I clicked the record button and it began recording. Thank you JESUS!!! I clicked the stop button and selected play. It played back the few seconds I had recorded. I’m hoping this helps anyone else who encounters a similar problem that I had. I do believe playing the online 1k test tone through my laptop to adjust the Alesis I/O 2 interface recording levels had something to do with jamming my microphone setting. Please contribute to this post with additional recommendations and comments to assist other Audacity Users. Again, thank you for all of your help with getting Audacity working properly on my laptop. Have a Blessed Day, Dan
Microphone Settings Screen.JPG