Error Opening Sound Device - Tried EVERYTHING - STILL NO CHANGE

Help! I keep getting “Error Opening Sound Device.” I can’t record or play back. I downloaded 2.3.0 and have also tried some earlier versions. I’ve set my Mac Audio MIDI setup to correspond to the sample rates and other things in Audacity. Nothing in the Audacity manual helps. I have been able to record and playb back with Garageband, Quicktime player, OceanAudio, and Audacity 1.2.5!! So it’s not my hardware. Some switch must have been ticked that I can’t find.

The audio host is Core Audio (the only selection on Mac OS), the recording devices are set to Built in Input and Output (for the moment), and the Project Sample Rate is set to 44100. The Audio Midi Setup on my Mac corresponds to the input/output set up in Audacity and I have the format set to 2ch-32bitFloat. I can’t record or play back with the latest versions of Audacity at the moment. Anyone have any ideas? I would greatly appreciate any help in solving this problem.

Which Mac and what is the system version?

Apple (upper left) > About This Mac.

Screen Shot 2019-01-20 at 10.54.39.png

Thanks so much for responding! Here’s the screen shot:

Cool So it’s an older iMac which probably has “real” analog stereo inputs and outputs similar to this.

Audio MIDI Setup is nice, but I like using Apple (upper left) > System Preferences > Sound input and output because this tool has the bouncing sound meters. You never said what you were recording. Does it have an analog connection like this or something similar?

Connect it, turn it on ( leave Audacity closed) and see if that panel’s meters jump. This is checking the system in the middle to make sure the sound makes it that far.

What is the eventual sound source and what’s the show?


Thanks, Koz.

Oh, the meters definitely jump. No doubt that the sound is being received because I can record with Garageband,QuickTime Player, and ocenaudio. In fact, I’m using the newest version of ocenaudio right now while I try to solve the Audacity problem. It’s not as fully featured as Audacity, but does almost everything I need for now. But I LOVE Audacity and have been using it since summer 2011 and I don’t want to use another program (although I’m pretty happy with ocenaudio so far).

What is frustrating is that all the fixes that the error message mentions are fixed. The sample rate (44100), the host (Core Audio), and the playback device (built-in audio or Rode NT_USB). No dice.

I’m using a Rode NT1 USB mic right now, which connects to the computer directly or through a hub.

I have a podcast named EPITOME. I also have recorded some audiobooks for Audible.

Thanks for your help. I don’t know if it will ever be fixed. I can’t understand what caused it in the first place.


There is one semi-hidden problem. I think Audacity comes out of the wrapper with Audacity > Preferences > Recording > [X] Overdub selected. If you do that, Audacity is expecting the recording and playback setups to be perfect. So an error anywhere in either system will cause a failure.



That’s what frustrates me to no end. I have the Overdub unchecked, just like you and the other sources I researched suggested. Still. No. Go. I’ve rebooted the computer. I’ve reinstalled several past versions of Audacity, meticulously checking that all the right boxes were engaged. The program tenaciously continues to blast that error message like some smug politician who won’t back down even though the facts incriminate him or her. In 2.3.0 it at least differentiates the error message. It specifies “Error code -9997 Invalid Sample Rate.” The sample rate is 44100. When I attempt to play a pre-recorded file I drop in, it gives me the generic “Try changing the audio host, playback device and the project sample rate.” All of which are correctly set.

You see the extent of my frustration? You have been very gracious in your help suggestions and I’m grateful. It must be some gremlin within the system laughing uproariously at me.

Best always,

The Audio Midi Setup on my Mac corresponds to the input/output set up in Audacity and I have the format set to 2ch-32bitFloat

Try 16 bit. Audacity always runs internally at 32-floating, but not everything in the outside world supports that.


Thanks, Koz.

Unfortunately, that also did not change things. sigh I suspect a teeny little virus that might have corrupted something in the communication line as all this just appeared with me having done anything different than I had been doing for years.

I had a weird thing happen with my Password Vault program and now I can’t get into it! I think I have all the most important passwords saved elsewhere but we shall see. Yikes!


I have exactly the same issue as the OP.

I believe this to be a known issue and it should be fixed.

I am using a Macbook Air
with OS Catalina 10.15.7
and Audacity 3.0.0 which I downloaded because I had the same problem in an older version.

I have checked that my Mac’s settings in Audio Devices match up to the settings in Audacity.

I recorded a short test track AND played it back -
input: mic via external interface; output: headphones via interface.

The second track I recorded, Audacity would not allow me to play it back through my headphones via my interface. I hadn’t closed Audacity; I hadn’t changed any settings.

What the actual … is going on here?

Hate to think I’ll be forced to forking out tons of cash for Audition :confused:

That does not sound like the same issue. The OP said that they were not able to play anything.

So the problem that you are having is what, exactly? That you can’t hear the previously recorded track while recording a new track?

I was having a similar problem (my USB CODEC device no longer would open in Audacity, although it worked in other applications) and I was trying numerous things that you talked about – such as unchecking overdub, changing the sample rate, etc. Then today, I came across a post from two years ago (see below). This fixed my issue, and I thought you might want to see if it helps you too.

by steve » Tue Feb 05, 2019 10:41 am

A problem of no recording level in Audacity may occur in some versions of macOS due to Apple changing the “Privacy” settings for recording devices.
Note that although macOS refers to this setting as “Microphone”, it applies to all recording devices, including external USB / Thunderbolt interfaces.

To fix this problem:
On your Mac, choose “Apple menu > System Preferences, click Security & Privacy”, then click Privacy.
Click Microphone.
Select the tickbox next to an app to allow it to access the microphone. Deselect the tickbox to turn off access for that app.

Hi. Same problem for me since one month. I was using Audacity from years without any trouble. One year ago, I changed my MacMini for a new one (3,6GHZ Intel COre i3, OS 10.15.7 with 8Go RAM), reinstalled Audacity and used it without problem.
One day, it became impossible to read a file because of the Error opening sound device (I did not make any change in my configuration before this). The file loading process is OK, all functions seem OK but no reading.
As you, I read forums, I checked all the parameters In Audacity and my audiodevice, I deleted Audacity cfg.files to reset them, I reinstalled Audacity (release 3.0), I tried another audiodevice, I tried the recent purpose from RKindy about Microphone Privacy,…
And all my other music softwares work normaly in reading and recording (GarageBand, Music, all plugins, etc). So the only diagnosis is a specific problem in Audacity.
As Bogon55, I realy like Audacity and I need it but I can’t use it anymore !
So, every new idea will be appreciate…

Does Audacity have permission to use the microphone?

Hi Steve. Audacity doesn’t appear in my list of softwares for microphone privacy : only GarageBand and GuitarPro. So I can’t select the tickbox. I didn’t find how to add Audacity to this list. Thanks.

There’s a suggestion from billw58 here:

By default, Apple blocks all apps from using any audio recording devices (they use the term “microphone” to mean any audio recording device), unless it is Apple software (as is the case of Garage Band) or purchased through the Apple Store. It’s becoming increasingly difficult to provide free open source software for Mac users - our developers have to pay a fee to Apple just so that Audacity will run on modern Macs at all :imp:

Thank you Steve for your answer.
I tried the suggestion from billw58 : when I try to record, I don’t have the dialog box asking to give permission to Audacity to use the microphone but directly the error " 9997 Invalid sample rate" even if I change the sample rate to be the same that my audio device (Line6 HelixLT : 48000Hz). One detail : my config is a MacMini and i am not sure there is a microphone installed in it, so I can’t choose it by default at the first step.

I am not surprised that this problem comes from Apple against open source softwares but I have one doubt. Because Audacity doesn’t work anymore, I downloaded Ocenaudio (free version from his website, not from the Applestore) and it works without problem EVEN if I uncheck the microphone privacy. Same results with GuitarPro7 wich is not free but not present in Applestore. If I do so, Ocenaudio tells me that It cannot play or record sound but a dialog box ask me to Enable Mixer (see picture 1). If I do, it works normaly still the microphone privacy REMAINS unchecked in MacOS (picture 2).

Why is it different for them : is the Apple fee necessary to view Audacity in this dialog box even if we don’t allow microphone privacy?

Windows guy here… I am looking over your post and trying to understand. You say “read”, but I’m thinking the error message is more related to recording or playing. Perhaps this is a language translation issue?

If you start with an empty project and Generate some audio, say “DTMF”. Can you play it?

If you start with an empty project can you record anything ?

Hi jademan. Sorry for my bad english… By “read”, I mean Play. It’s the same if I generate a new file with DTMF instead of open or import one (see capture). The bug is here without any recording, just with playing.

OK, I see from your image that you are getting the error as you try to play to the Line 6 Helix LT Guitar Multi-effects Processor. I do not have personal experience with this device, but I am wondering that it might not be accepting output from your Mac. Do you have any other devices you can try to play to (internal speakers, for example)?