Error opening device since update to 1803 [SOLVED]

Greetings -

The title says it all. Nothing else has changed in my setup. I did my monthly maintenance - which includes virus and spyware scans, defragging the drive, etc., as well as this particular Windows Update - and now get the following message when trying to record:

Error opening sound device.
Try changing the audio host, recording device and the project sample rate.

Did all that and more - uninstalled/reinstalled Audacity and the driver for my interface and rebooted the computer several times - all to no avail.

Has anyone else had problems since the latest Windows Update? Looking forward to your reply. Thank you!

Rick Manasa

Is the error open the recording device or the playback device (the error message usually says).
Which version of Audacity?
What are you trying to record, and with what equipment?
Have you checked the FAQ? (in particular:

Yes - with the latest update Windows “helpfully” turned off both my onboard microphone and my Stereo Mix as available input devives.

It had me puzzled for a while why I no longer had them available in the Audacity Device Toolbar - D’OH :confused: :imp:


Thanks for the quick reply, Steve. As the error message says, it’s related to the recording device. Audacity plays existing projects, mp3s, etc., just fine.

I have been down the Wiki and manual rabbit hole with the link you offered before I posted. Truly, nothing has changed except the update. Everything good two days ago, do the update, everything bad.

Audacity version 2.2.2, Windows 10 Pro, version 1803, build 17134.1, updated May 1, 2018.

I use a Behringer UMC204HD preamp for my mic (I do voice over work.) As I said in the original post, I’ve uninstalled/reinstalled both Audacity and the driver for the Behringer. No joy. Next I’m gonna try installing Audacity on my backup box and see what happens. I will report.

In the meantime, if ANYONE has any idea what has happened and how to address this please let me know. I’ve got work to do. lol Thank you!

Rick Manasa

Update: Installing Audacity 2.2.2 on my old machine - Windows 10 Pro Version 1709, Build 16759.371 - “fixed” things. Clearly, there’s something in the latest Windows Build that Audacity doesn’t like.

Thanks to all that have looked at this thread. I can get back to work today, but I hope someone can look into this and drop 2.2.3 to address the incompatibility.

Rick Manasa

Please see the reply from waxcylinder earlier in this forum thread.

Hi Steve -

I did see WC’s post. Audacity does see the Behringer as my input device as well as being able to record in both mono and stereo. I did not specifically respond to those items and apologize for that.

i’m rolling back Windows to v1709 on my main music machine at the moment. I will post again once that’s done.

Rick Manasa

What recording device do you want to use?
Is it enabled in the Windows Sound Control Panel?
How many channels is it set to record (in the control panel)
What sample rate is it set at?
Is it selected as the recording device in Audacity’s device toolbar?
Is the “Project rate” (lower left corner of the main Audacity window) the same as the device sample rate in the control panel?
What sample rate are you using?

In the control panel, assuming that the device is enabled, when there is an input signal, do you see a green meter responding to the device?

I had this issue. Installed the win 10 April 2018 update - lost all sound. Sound Blaster ZxR. That was fixed by a driver re-install. I did a quick check on the recording side and got this message: Error opening device.

I did find a solution (well it worked for me). If you did the Windows 10 April 2018 update, did you (like I did) go straight to the privacy part and start turning stuff off?

Open your setting, go to privacy and then microphone. Did you turn if off? If so that’s your problem. Turn it on again and restrict just the apps.

TADAAA you should be back in business. Hope that helps someone, as has bugged the hell out of me.

Solution got from:


JD :wink:

Steve and JD -

Thanks for your replies. I have rolled back to V1709 and Audacity is a happy camper.

To your questions Steve, I can only point to my earlier response that I followed all the suggestions in the Manual and Wiki without success (I believe I said I’d been, “down the Wiki and manual rabbit hole.”) However, I do appreciate the time you took to formulate them, and will address your questions individually to the best of my memory:

Recording device - As I’ve said, I’m using a Behringer UMC204HD for voice recording.
Enabled in windows? - Yes
How many channels in Windows - per the Wiki, I set both Windows and Audacity to two (even though I only need and use one.)
Sample rate - Again, per the manual and wiki I left it at the default of 41000.
Device in Audacity device toolbar? - Yes
Project Rate - Again, per Wiki and manual, left it at 41000.
My sample rate - -Again, per the troubleshooting guides i read and followed, I set my sample rate at 41000.
Green meter - I did not check this at the time. It does respond now that I’ve rolled the OS back.

Again, I’m going from memory on this, so if I’ve misstated something, it’s more likely a memory glitch on my part than a, “You did that wrong” problem on my part.

You can force the download to the latest version of the OS by going to:

Or you can wait for the official rollout on May 8. Once you “upgrade”, I’d be curious to hear your experience. Honest and truly, the ONLY thing that changed from Monday to Tuesday was the Windows 10 Pro upgrade to Version 1803. All other Windows and Audacity settings remained the same.

Thanks for your reply, JD. That is a wonky work around, but I’ll file it away if I absolutely positively have to upgrade before Audacity addresses the issue from their end. Thank you!

Rick Manasa

I don’t think there is an issue from Audacity’s end. The problem looks to me to be between Windows and the sound card drivers. If the computer sound system is not fully functional, then Audacity will not work properly, and it seems to me that after update 1803 your computer sound system is no longer fully functional. The answer is to fix the computer sound system.

Just want to wrap this up with a bow before letting the thread get closed. JD’s suggestion is spot on, however wonky. I now have two computers that have been pushed to 1803, and both have been “fixed” by turning on the mic and turning off the apps. All happy … until the next time something changes. lol Thanks to all for viewing and posting.

Rick Manasa

Thanks for the update.
I’ve added a link to JD’s post so that others may find that post easily, and shall now close this topic as “solved”.