Error message from Crossfade Tracks effect

I’m somewhat new to audacity but absolutely love it.
I’m having some problems though cross fading tracks.
I’ve laid out some screen shots to help explain my problem.
I’m working on a Mac Mini with Sierra Operating system.
And Audacity 2.1.3
I highlight the tracks to crossfade
Select the crossfade function from effects.
Select the fade type, click ok an get this Nyquist dialogue box that I don’t understand.
And when I click ok nothing happens to the tracks. The crossfade effect has no effect on the selected tracks.
I’m sure it’s operator error.
Can any tell what I’m doing wrong.
I’ve checked online tutorials but see nothing.
Many Thanks
Screen Shot 2017-05-11 at 4.21.48 PM.png
Screen Shot 2017-05-11 at 4.22.08 PM.png
Screen Shot 2017-05-11 at 4.21.24 PM.png

Try clicking the “Debug” button rather than the “OK” button. I expect it will show an error message. Copy and paste the error message (all of it, as text) into your reply.

Also, when you have a new question, please start a new topic and give it a relevant title.

Thanks for the help Steve.
It was lengthy error message.
Here it is in three parts.
Thanks so much.
Screen Shot 2017-05-11 at 5.04.37 PM.png
Screen Shot 2017-05-11 at 5.04.13 PM.png
Screen Shot 2017-05-11 at 5.03.58 PM.png

Have you been trying to modify the plug-in?

Also, please post error messages at text rather than as a screenshot.

No, I wouldn’t know how to modify the plug in.
I’ve literally just gone through the steps I outlined in the first post.

Well it looks like someone or something has modified the plug-in file, because the word “COLORADO” does not exist in the “Crossfade Tracks” plug-in that we distribute.

I searched for Colorado music in safari. I edited music, perhaps even titled Colorado in Audacity, but I’m not quite sure how that would have any effect on the plug-in.
Like I said, I have no clue how to modify the plug in.
I’m not even sure how I could have done that by accident.
To be honest, I’m not sure where the plug in is located, how to access it, or even what it does.
That said, can you explain where the plug-in is located and how I get it back to the factory default settings so I can use the crossfade feature?
Thanks so much for your help.

For a default installation, the plug-in will be in:
~/Library/Application Support/audacity/Plug-Ins

The plug-in is just one file, called “crossfadetracks.ny”

Please attach that file to your reply so that I can take a look at it. Hopefully that will cast some light on what is going wrong.

Thanks for the help Steve.
Audacity is intuitive and user friendly which is what I love about it.
I’m not technologically savy enough to “tinker” or modify it.
Besides I use it because I like the features the way they are.
But you may be onto something as to why this isn’t working.
I don’t see anything listed as Audacity plug ins.
Here is the Library path.
I got there by going:
Library/Application support/audacity
The Plug-ins folder is missing.
The only folder there says, “libs”
Hopefully, that helps in solving the mystery.
Again, thank you very much.
Screen Shot 2017-05-11 at 6.32.16 PM.png

Wrong Library. Steve said to go to

~/Library/Application Support/audacity/Plug-Ins

See the tilde (~). That means your user Library in your HOME folder. Use the Go > Go to Folder menu item in Finder to get there.

However I expect the plugin is more likely inside Audacity. Right-click or Ctrl-click over the Audacity application, and click “Show Package Contents”. Open the “Contents” folder then look in the “Plug-ins” folder.


Thanks Gale,
Perhaps this is the information you’re looking for.
In the 2nd screen shot I noticed the Nyquist folder, which is part of the initial error message I received.
Don’t know if you need that, but I thought I’d include it anyway.
Many thanks.
Screen Shot 2017-05-11 at 7.08.11 PM.png
Screen Shot 2017-05-11 at 7.08.54 PM.png

For each image you add, please click the “Place inline” button. This makes the images fit the Forum layout and will save us having to do it. If the images are not inline, then on lower resolution monitors it will not be possible to view the entire width of the image conveniently .


In your first image, you can see crossfadetracks.ny in the Plug-ins folder. Copy crossfadetracks.ny, move to your Desktop or somewhere easy to get to, and paste crossfadetracks.ny. Then attach that file here.


Here it is.
crossfadetracks.ny (2.62 KB)

Nothing wrong with that. It’s perfect and works exactly as designed.
So it seems that your Audacity installation is FUBAR.

What other apps do you use on your computer? Are you getting weird problems with them, or only in Audacity?

Thanks Steve,
I work with only a limited number of apps, all related to voice over work.
Source Connect, which connects me with production companies around the world,
Audient ID, which is the audio interface,
Reaper, another audio editing software which I used before Audacity (But I like Audacity better),
And Open Office, which is Word compatible word processing application.
I don’t have any problems with them that I’ve noticed (unless they’re in some way causing the conflict with Audacity)
I have had a couple of random issues with Audacity but they were corrected when I replaced an older audio interface and re-installed the Sierra Operating system.
For the most part Audacity works perfectly now, but it just won’t perform this crossfade function.
Any suggestions on how to correct it?
Thanks again.

In the effect, click the “Manage” button, then hover over "Factory Presets"and click “Defaults”.

But I would try quitting Audacity then use Go to Folder in Finder to open

~/Library/Application Support/audacity/

In the audacity folder, delete pluginsettings.cfg. This will cause you to lose custom settings in all effects. If that would be a problem, then attach the pluginsettings.cfg file.


OK I’ll give that a try.
Thanks Gale.
How do I attach the plug in settings.CFG file?

The same way you attach an image, by browsing to it and opening it.

However we don’t accept files with .CFG extension for security reasons. So please could you rename pluginsettings.cfg to pluginsettings.txt before uploading it. To rename it in Finder, select it and press Return or Enter on your keyboard.


Is it possible this could be an anomaly?
The word Colorado was perplexing me. I tried using the crossfade with a new selection of music and it worked.
Could that Colorado file have been corrupted and possibly prevented the crossfade?