Error Code -9996 Invalid Device.

“Error opening recording device.
Error code: -9996 Invalid device.”

I get this code when I open Audacity and press the record button. I have followed and completed some troubleshooting steps like updating my PC, making sure my playback and recording devices are enabled, restarting my Endpoint Audio and reinstalling Audacity but to my efforts have not been successful.

Any help to resolve this issue will be much appreciated!

Thank you again for your time and help.

I updated the 2.3.1 Manual (alpha right now, as yet unreleased) to explain the numeric error codes - see:

A good read of the whole of that page should help you.


While the link you provided was very informative it did not resolve the issue. I receive the error code even when I don’t have anything plugged in also when I change from WASPI to MME or Windows Direct Sound it does record however when I go to import the mp3 to another device I get an error message and cannot import the mp3(s).

If there’s no device plugged in, then wouldn’t that mean that the disconnected device is “invalid”?

What do you mean by “import the mp3 to another device”?
“Import” acts on files, and copies the audio data from the file into the Audacity project.
The “audio devices” are used for playing and recording - they have nothing to do with importing files.

I get the error code regardless if a device is connected or not, so while the answer to your question is obviously yes, it doesn’t explain why I receive the error code regardless if I have a device plugged in or not.(I’ve also tried multiple other devices and have had the same outcome)

When I currently import(transfer the file to another device) an mp3 I receive an error and the mp3 cannot be opened, used or transferred to the device example: my phone, PlayStation, old mp3 music device or even another computer.
While I am well aware that the audio devices have nothing to do with importing files I’m simply including all of the known “new” issues I’ve been receiving since this error code started to appear.
I brought that up mainly due to the fact that any mp3 I currently create cannot be transferred but if attempt to transfer any mp3 I had created before this error code started to appear they transfer just fine.

I fixed the 9996 error message this way:

In Audacity, go to the area below the se 3 icons: [scissors - copy - clipboard]

Select [Windows Direct Sound]

To the right, next to the microphone icon, select: [Primary sound Capture Driver]

I tried all other suggested fixes and chose other options in the two Selection Boxes above, but nothing worked. I also did a Troubleshoot of my Windows 10 recording, but this did not fix the error.

The problem started after I updated to version 2.3.3

Hope this solution helps someone. Cheers from a guy in New Zealand.

Win ver: 1909 (OS Build 18363.628)
Audacity 2.3.3
Sound Blaster Audigy Fx
error code -9996

Odd Channel setting ?

Windowds WASAPI
Speakers (Sound Blaster Audigy Fx)(loopback)
Recording Channels -2 (Stereo)Recording Channels
Speakers (Sound Blaster Audacity Fx)
I receive an Error Message:
Error opening recording device
Error code: -9996 Invalid device

when I attempt to record.

Speakers (Sound Blaster Audigy Fx)(loopback)
Recording Channels -6
Speakers (Sound Blaster Audacity Fx)
and I can record as expected.

So here is a peculiarity that caused me much hair pulling to record; selecting 6 channels.(else there was no audio)

I just wish I did not have all these channels displayed every time I begin recording. Perhaps someone may have a suggestion or tip on how to clean the display ? (only show a Right & Left channel)

How many channels are playing through the Audigy?

5.1 (6 speakers connected.) Now, how many speakers play off an mp3 file is yet undetermined.I have run a Creative test, all 6 speakers do make sound.
Similar setup, with on board sound, is set for 2 channel stereo, Must be a driver thing ?

WASAPI works like a pipe for audio data. What comes out of the pipe has to match what goes into the pipe, so if you have 6 channels at 48000 Hz sample rate going in, then you need to capture 6 channels at 48000 Hz at the other end of the pipe.
If you only want to record 2 channels, you could try configuring the sound card to play (output) and record (input capture) 2 channels.

I use Audacity to do my podcast. Works great every time. Then, I go to record last night, I hit record, and it pops up, "Error opening recording device, error code 9996, invalid device.
What the heck? I’ve done every tutorial on freaking youtube.
Nothing…what is wrong???

You’ve not given much information to work with. Perhaps your USB mic has come unplugged.

I’m getting the same problem. I recall seeing something on some forum that fixed it on my old pc but that’s long since lost in memory. I’m using the same headset and I’ve gone through all my settings on Audacity in my old computer and set it the same way on my current one but that hasn’t worked. I’ve unplugged and plugged my headset back in a bunch of times and that hasn’t worked. I’ve tried going through my headset settings. It’s set to 7.1 and everything.

Try setting it to 2 channels stereo 44100.

I realized that this error started coming when I installed Equalizer APO ( graphical equalizer )
When I uninstall it the error goes away and I can do the recording.
I hope this helps.

It’s simple, actually. U just have to uninstall the program, then reinstall it, and reset any and all preferences. Worked like a charm.

If that worked for you, perhaps it was resetting Preferences (restoring default settings) that fixed it. Reinstalling is unlikely to be relevant as it simply replaces files with identical files.