Error code -9996 Invalid Device since Windows upgrade


I’ve got an old (10 years ish) Dell laptop running Windows 7 Home Premium. Originally it was on Vista and I used Audacity 2.3.2 successfully to record external sources (eg. cassette, smartphone) connected to the Line-in 3.5mm input jack. Since upgrading to Windows 7 from Vista I get the Error code -9996 Invalid Device.

I’ve tried working through various self-help tutorials to ensure the sample rate in Audacity matches the Windows setting for the Line-in device rate 44100Hz.
Line-in properties.png
However when I run diagnostics in Audacity on the input device it appears there is no supported rate listed (Device ID:17 below).
deviceinfo.txt (6.9 KB)
I’ve also tried switching between MME, Windows DirectSound and Windows WASAPI - all report the same error.

I’d be really grateful of any suggestions for what I’m missing!

Thanks very much

Sounds like the problem (with solution) posted here:

Hi Steve,
Thanks for your reply, but that appears to be an issue with Windows 10, not Windows 7? I can’t seem to find a privacy setting for the microphone in Windows 7. Also the laptop microphone does work fine with audacity when I select that as the input device.
Do you have any other thoughts on this?

This “privacy” issue was first introduced in Windows 10. I think that Microsoft have now rolled out this “feature” to all other versions of Windows that they currently support. Unfortunately I can’t find much information about Windows 7 because it is almost obsolete (Windows 7 becomes obsolete in January).

In the Windows “Sound” control panel, do you see the green meter on the right of “Microphone / Line In” respond when you talk into the mic?

If you do, try setting the recording input in the device toolbar to “Microsoft Sound Mapper”.

Yes I do see the green meter in Windows Sound on the right of the “Microphone/Line-in” respond to sound from the internal microphone.
If I set “Windows Sounds Mapper” in Audacity it select the internal microphone and works ok with no error code. But I can’t work out how to get Line-in selected with Windows Sound Mapper. If I connect a source to the 3.5mm Line-in jack, a windows pop up appears that shows it has detected the plugged in source, but in Audacity the input device remains as the internal microphone.

When Audacity is set to record from “Sound Mapper”, it records from whatever the default device is in the Windows “Sound” settings.

I’m still struggling with this. Here’s a grab of when I select Sound Mapper:
sound mapper - microphone.JPG
When I plug in a source to Line-in it is recognised by Windows:
Line in confirmation.JPG
But I can’t get Audacity to monitor the Line-in if I leave Sound Mapper selected.

If I manually change the input device to Line-in and click Monitor I get a -9999 error:
line in selected.JPG
Last night I tried uninstalling the sound driver and re-installing it, but that has made no improvement.

Do you have any other suggestions? I’m really reluctant to give up because Audacity is great!

This is the relevant Windows “Sound” control panel. The default input (red arrow) displays with a white tick in a green blob. When the input is working, you should see the associated meter (green arrows) responding to the input sound / signal.


Thanks for your help here. I think it must be a problem with the sound card set-up since I installed Windows 7.
I’ve got an even older laptop (sorry!) running Windows XP Home SP3 and I’ll have a go with that. Please can you advise which is the most suitable version of Audacity to install?
Thanks again

If you have an SSE2 CPU - then 2.1.3

If an earlier CPU you will need 2.0.6