Error Code -9986 Internal PortAudio error

Mac Big Sur 11.2.3. Audacity version 3.1.3
This is my first time using audacity. I went to press record and the message came up:
“Error opening recording device.
Error code -9986 Internal PortAudio error”

Please help me in letting me know what this means and what I have to do. I’m working off of a deadline by March 20th.
Thank you so much,


What is your input device?
Have you given Audacity permission to use the audio input device? See
– Bill

I have hit the same error code, -9986 Internal portaudio error. I am also on Mac Big Sur 11.6.5. I checked under microphone-Privacy and I already have Audacity checked. I am trying to record from an old reel to reel tape through a Behringer UCA202. I have sent the error in several times. The Behringer shows up as USB audio codec. I last ran this setup about a month ago and it worked. I checked the audio MIDI setup and the Audacity Preferences, but don’t seen anything I recognize as off. I may have updated Big Sur since the last time I ran it. Any ideas?
thanks, jeff hecht

Are you also on 3.1.3? Version 3.1.2 had a bug that could manifest this error. :slight_smile:

Yes, I’m also on Audacity on 3.1.3 . It had worked for me before the last time I tried using it on April 6 or 7.

Checking my Apps folder, I do not see much installed after April 6 except a new Firefox, new version of iMovie, Kenote ando other Mac apps, and an Install Monterey app that seems to have installed itself on April 27. I am still on big sur.

I am running this on a 2017 MacBook Air with 37 gig free out of a total of 121 gig on the machine.

One final thought - the last time it worked I was using the Behringer to record from a different reel to reel recorder, but I’ve never before seen a differece in trying to digitize from the two reel to reels.

Thanks, Jeff

Try Transport > Rescan Audio Devices.

That did the trick. I had forgotten about that option. Thanks.

Thanks for the Rescan Audio Devices tip – fixed my errors.

I keep getting the 9986 error message. The rescan my audio is a great temporary fix, but the error keeps coming back. Particularly when I monitor the audio first, stop that, then switch to record. I get the error message almost every time I switch. I am on MAC Monterey 12.6.3 and Audacity 3.2.4. I recently bought a new recording device, but it is the exact same brand as before. This time it is read as a USB Audio Device whereas before it was read as a Plug and Play. Anyway, the rescan really helps but I wish I didn’t have to do it so frequently.

When you do Help > Audacity, what version do you get ?

3.3.3 is the version I have.

And you are getting 9986 errors after Transport > Rescan Audio Devices and then completing Audio Setup ?

I’m using Audacity on my Mac with Big Sur 11.2.3, and I’ve recently upgraded to Audacity version 3.1.3. This is my first time using Audacity, and when I hit the record button, I got hit with an error message saying, “Error opening recording device. Error code -9986 Internal PortAudio error.” I’m on a tight deadline with a project due by March 20th, so any help would be greatly appreciated.

And you did Transport > Rescan Audio Devices ? I guess the next step would be to reboot, although I am not sure that will fix it.

@LWinterberg, we need to add this error code to: Error codes - Audacity Support