Error after editing.

On xmas eve I recorded a broadcast on local radio to listen to later on that evening. When I came to playing it back I thought I would trim the first 15 mins or so as that was just news and adverts. I selected the part and deleted it. Then I thought I would save the resultant project in case I didn’t get chance to listen to it all. When I attempted to save it as a project I got this error message:-
I think I chose the last option at first. Now I get this every time I open the project and I have missing audio for a few seconds. Not only that I can’t export the project in any other format. I get this message instead:-
Although I can’t save or repair the file, I can listen to what remains, so all’s not completely lost. However this has never happened to me before and I’ve used audacity many times to create my own multitrack recordings. I’m now somewhat reluctant to even open any personal projects in case I lose important data. This occurred after I had updated to 2.2.1.

Any ideas? How safe is it to use?

However this has never happened to me before and I’ve used audacity many times to create my own multitrack recordings.

It’s a computer!!! Once in awhile you’re going to have a problem… :cry:

I’m now somewhat reluctant to even open any personal projects in case I lose important data.

Simply opening (reading the files) shouldn’t hurt anything but make a back-up before you open it.*

In the future, I recommend exporting to WAV (or FLAC, etc.) as a back-up immediately after recording. A regular audio file is a single-file so it’s easier to move-around a harder to corrupt/screw-up. (Of course it depends on what you’re doing but I rarely make an AUP project, I mostly just export audio files.)

And of course if it’s super-critical, make multiple back-ups and store in multiple locations, etc.

If you’re recording something critical and there’s no possibility of “take two”, I recommend two recorders running in parallel (and a UPS or battery-powered laptop).


Hmmm… so basically I can reduce your reply to two words: “S**t happens”? :unamused: Anyway I have just tried it again, same procedure, and got the same result. Latest build, windows 7. If anyone else wants to try and replicate this here’s what I did.

Recorded a couple of minutes audio from an online radio player.
Saved file as aup. Closed program.
Reopened file with audacity - no problem.
Selected a chunk of audio from beginning, approx 30 secs, and deleted.
Saved file as aup. Closed program.
Reopened file and got the same result and error message as above image 1.
This time got new error message after choosing action:-
audacity error.jpg
Still can’t export file in any other format.
Can’t save as aup either. Saying location is not writable or disk is full!

I may have the previous version of audacity somewhere else so I can do more tests, but until then I’m not using this version on my own projects. I do rely on the aup format for multitrack recording and editing, so it’s very important to me! And yes I do make backups as would anyone using this software for music production.

I reported a similar fault with 2.2.1, using Vista, about a week back - lots of emails to/fro up to Xmas day: await the ‘fix’…
Same result on another Vista laptop.
It arose by saving the aup project (a second time) into the existing name, with every edit leaving a destroyed data file (dialog box as in your screenshots).
The solution seems (tho’ have gone back to 2.1.3) to rename the 2nd project with a different name and again for each subsequent save.
As it apparently affects more than Vista this seems a major bug; with no site notification…!

I’ve tried following those steps multiple times and I’m not able to reproduce the problem. Each time I open the project I get exactly the project that I’m expecting, and no errors.
Where exactly are you saving the project and what file name are you using?

Please try running a full virus scan on your computer - the problem may not be caused by a virus (although that’s not impossible), it could be that your virus checker is suspicious of Audacity and interfering with Audacity’s normal operation - if that’s the problem, then a full scan is likely to throw up some false positives.

Similar, but different, so if you wish to discuss that on this forum it would be better to start a new topic.

This morning I have used a different pc with V2.1.3 installed and was unable to replicate the problem - all normal. Whilst doing this I ran a virus scan on the ‘updated’ pc and no results were found. I uninstalled the latest version and installed this older version instead. Once again I couldn’t replicate the problem that I had with the latest build. I tried to open the damaged files but still got the same error messages and was still unable to export in any format, so I guess I can’t repair those. For now I’m going to stick with the older version which I haven’t had any issues with.

I think that’s the best idea for your work, but it would be helpful if you could also help us to try to discover what the problem is with 2.2.1. Would you be willing to help with that?

Yes I’ll try and help the best I can but I’m not too software savvy, in fact it doesn’t usually take much of a software issue to beat me! I did notice that on one error message there is a ‘show log’ icon. Would that be of any use?

The log will probably just list the file names of the missing / orphan files.

I’ve asked the developers if there are any specific tests that you could do to help isolate the problem. I will write back here if there is anything.
If you’ve not done so already, you could click the “Subscribe topic” link at the bottom of this page so that you will be emailed when there are new posts to this topic.

Thanks for offering to help - much appreciated.

I myself work in engineering maintenance and when I get a fault reported to me I like to gather as much info as possible and from varying sources. With that in mind, here’s a snapshot of the fault log. Every little helps as they say!
I’m hoping that it’s just pilot error and not a program error. As I say, I’m not a software or PC wiz by any means.

Yes indeed :slight_smile: though it is even more helpful to save the log file (as a text file) and then attach the text file to the forum post.
To attach a text file, use the “upload attachment” tab below the message composing box (not necessary on this occasion as the log is fairly small and I can see what I was expecting to see).

A quick breakdown:
The “FFmpeg” stuff shows that you don’t have the optional FFmpeg library installed (not a problem - it’s optional).
There are 4 “.AU” files listed in the “.AUP” file that can’t be found in the project’s “_data” folder - this is the problem and we need to find out why this occurs.

With well over a million downloads of Audacity 2.2.1 for Windows, it’s weird that there’s not much more than a handful of cases of this problem. Makes me wonder what’s so special about your machine. Perhaps you can fill in a few gaps:

  • The exact version of Windows?
  • What is the system language of your computer?
  • What anti-virus / other security / maintenance products on your machine?
  • How much free space on your C: drive
  • Is your C: drive a spinning disk hard drive or a SSD?
  • Does your computer hibernate / sleep when left inactive - how long does it have to be left for, and any chance that this could be related to the problem?
  • Did you download Audacity from here:
  • Anything that you can think of that may be “untypical” about your computer?
  • Did you use the “EXE” installer for Audacity?

Ok I’ll try and fill in some gaps:-

Windows 7 professional service pack 1
system language - english (I hope that’s what you meant by ‘language’)
Avast antivirus (up to date)
Intel i5 3.20ghz
16gb RAM
64 bit operating system
440 gb free space on a spinning hd
No hibernation or standby/sleep settings
I updated audacity by clicking on ‘check for updates’ and following the first link.

I can’t think of anything that would be different for the new version rather than the old, other than the update itself. What I didn’t do however is uninstall the previous version first, I simply double clicked the newer exe. I’ve attached the log file as a txt.
audacity error log.txt (3.25 KB)

We’ve made some progress in discovering what is going on.
In your steps:

  1. Recorded a couple of minutes audio from an online radio player.
  2. Saved file as aup. Closed program.
  3. Reopened file with audacity - no problem.
  4. Selected a chunk of audio from beginning, approx 30 secs, and deleted.
  5. Saved file as aup. Closed program.
  6. Reopened file and got the same result and error message as above image 1.

It appears that step 5 has to be:
Save file as aup using “File menu > Save Project As…” command.

“File menu > Save Project” is the normal command to save the project with its current name. This is what I normally do, which is why I could not reproduce the problem, Only by using “Save As” does the problem occur. The developers are now working on a fix.

Ah good, at least you’ve found something! I’ve always hit the ‘Save project as…’ command simply as a matter of habit, I don’t think I’ve ever clicked on ‘save project…’.

Why not get used to using the shortcut Ctrl+S (shortcut for “File>Save”) - I always find that much easier.


BTW the Bug report for the issue you found for us - or led us to with some further investigation - is here:

It’s logged as PI so must be fixed for the next release, as it can cause data-loss (something we take very seriously).

Good catch :sunglasses:


Hey no problem, pleased I could help, although finding faults is the easiest job in the world, it’s fixing them that takes real work!
As a footnote, I reopened the damaged ‘test’ file to see if I could do anything with it and found that if I chose the third option on the error message ‘replace missing audio with silence (permanent immediately)’ I am able to save or convert the file normally without issue, albeit losing some audio. A small victory but I’ll take it!

Yes I experimented with that when I was testing. I found that when I deleted audio from the bginning and then reopend I had 12 seconds of silece at the beginning. If I deleted at the end or the middle the sillences wre respectively in the end and the middle.

See the buglog:

Rest assured that this bug WILL be fixed before we make the next release (which may not be too far away).