Error 9997 Invalid Sample Rate -

This problem was posted before but the work around did not help me.
Running Audacity 2.3.0, MacBook Pro High Sierra 10.13.6 Blue Yeti Mic

When I try to record I get the error message I typed in the subject line.

Mic settings are set for Blue yeti as input and output
Neither the mono or stereo setting help
Screen shot of my audacity set up is attached
Screen Shot 2019-01-27 at 9.20.53 PM.png
Help would be greatly appreciated.

:unamused:

Open “Applications > Utilities > Audio MIDI Setup”, and see if you can set the sample rate for the Yeti to 44100.

Also, check in “Sound Preferences” that the computer is receiving sound from the Yeti.

this didn’t work for me. All of a sudden my mic isn’t being recognized or i keep getting this error message. I’m connected via a USB donnection. HELP

It seems that there are other problems on your Mac. In the case of your computer, this error could just be a symptom rather than a cause.

I’m having the same problem.

It was working fine on a first take. Then when I added a track with all the same settings now I’m getting this sample rate error 9997 on my Macbook Pro with Mondavi 12.01

Solved it by quitting audacity and rebooting the Macbook.