Effect 'limiter' suddenly not available

I have been using 3.2.4 every day for recording and editing audiobooks. A macro (ACX) that has worked perfectly until yesterday suddenly stops with the message "your batch command of limiter was not recognized". Apparently the limiter effect is no longer available at least I can’t find it anymore among the Effects. Also another batch command (ACX check) is not recognized either.

Did something change yesterday?

Testing on W10 with 3.4.2 (latest stable release) - and on 3.2.4

Works for me:


Thank you Peter. My audacity has no “Volume and Compression” option. And no limiter option as seperate effect. I suppose I could use compression as a substitute.

I assume something happened that caused this to drop out but would be very happy if it could work again since my work is backing up.

Yes, I enabled all of them just to be sure. It is not there apparently.

Mastering is a text-based Macro or Batch program that tells other programs what to do.


This is my copy of the text file. You can inspect it and then inspect the one you’re using for discrepancies. Depending on how your machine is set up, it may try to hide the .txt part of the filename. I insist all my machines show me the whole filename.

ACX-Check is a Nyquist Program, not a batch file.

My Effect > Limiter is way down at the bottom of the available effects. Effects is presented as two groupings. Limiter is in the second group.

You should try really hard to get Mastering working. It may seem simple, but it does a number of interconnected jobs. It guarantees ACX Peak and RMS (Loudness). That can be really hard to do with separate tools. It also incorporates a blast and rumble filter. Rumble can throw off loudness settings.

This is a Mac, right? When was the last time you shut it down? Close all your apps. No indicators in the menu bar at the bottom.

Apple (upper left) > Shut Down > Are you sure > Yes.

Not Apple > Restart. Watch the screen for odd icons like a spinning daisy. Time it. If you haven’t done this in a while, it may take some time to shut down in an organized manner.

Do you do all the Apple Updates? I wouldn’t do an Apple update during a job. People have had troubles with the last Mac-OS update. Do you have an Intel or M1/M2 machine?

Let’s see. Two others. Are you using iCloud for editing? Stop. Audacity dosn’t like that very much.

Are you filling up the machine? We tell the video people that sudden machine chaos can be caused by the drive filling up. Easy to do when you’re in throes of editing and not paying attention.

If you do this editing all the time, you obviously have a backup machine, right?


It might not shut down. You may start getting shards and fragments of damaged programs holding up the process.

“Ding-Dong” is in use and cannot be shut down. Close all applications before Shutting Down.

You could also not be the only user on your machine. That’s scary.


Where? I couldn’t tell, It’s not said, and I went by the menu bar at the bottom of the screen in the illustration similar to the one on Macs.

Much of the comments still hold. Windows machines are famous for hiding file extensions, etc.

Do a Clean Shutdown. Hold Shift while shutting down instead of a regular shutdown to make sure you clear out all the trash.


Bottom left corner of the OP’s image



My suggestion is that you reset Audacity (note that re-installing does not do that as the config files are held separately from the app).

See this page in the Audacity manual:


Many thanks to everyone. I am using Windows 10 on a PC. After trying most of your suggestions, another effect was ‘not found’, the ACX check. I uninstalled Audacity 3.2.4 and opened an older version 2.4.2 I think and that version had everything working perfectly so I cleaned up part of my backlog at least. I’m afraid to install the latest version again but will be brave and do it. Thanks again and perhaps the mystery will be solved.

You dodged it. So it’s just going to come back later.

Yes, 2.4.2 is the generally accepted stable version of Audacity before The Great Conversion to 3.

A note about that. 2.4.2 still uses the older, classic, legacy two-part Project: One AUP file and an associated _DATA folder. There’s rules for how those work. The older Audacity will not open the newer AUP3 Projects.

The newer Audacity will open both.

Got it.


This topic was automatically closed after 30 days. New replies are no longer allowed.