Edit Metadata Tags

I am using Mac OS Catalina version 10.15.5 with Audacity version 2.4.1

When I export a file, it pops up a “Edit Metadata Tags” window. When I click at “Add” button, it dose add a line for me to type. But after I did that and export the file. The file does not contain the added line at all.

Please advise what I did wrong. Thank you in advance.

What Tag are you adding? What Value? How do you check that the Tag and Value are written to the exported file? What file format (MP3, AIF, WAV etc) are you exporting to.
– Bill

On the additional line, I wrote copyright information.

I used two methods to check whether copyright information was written there:

  1. look at the file property which contains everything I wrote but the copyright part.
  2. I reopen the file by Audacity, and export it again, the Edit Matedata Tags window appears again, where everything I wrote was there but copyright.

It tells me, when I export the file, the file contains all the words I wrote on the Edit Metadata Tags but the wordings on the additional line.

Oh, it was MP3 format.

So, in the new line, do you write “Copyright” in the Tag column?
– Bill

So, with Audacity 2.4.1 on macOS 10.14.5, I import an MP3 that has metadata tags. Here’s what I get:
I edit the metadata to add a copyright line
I export this as MP3.

Then I close the project, create a new project, and import the MP3 I just exported, which should have the added tag.
This is what I see when I do Edit > Metadata
So I don’t understand why this doesn’t work for you. Are you doing something different?

– Bill

Yes, I did exactly the same thing but with a © symbol after Copyright. Would this © make the difference?

I tried again, it seems it does not like the symbol ©, without this symbol it works. And I even put @ instead of ©, it works as well. That tells me, it does work for some special characters but ©. I only tested with @, have no idea for others.

Clearly, the symbol © is an issue. But in general, when you have a statement of copyright, it would be written as “Copyright © Some company 2020”, always with this symbol ©.

Another thing: when I use my Mac to check file property, everything appears but the added line does not. I don’t know whether it is Mac issue or Audacity issue.

Testing with 2.4.1 on W10

  1. I can use the © symbol in a custom metadata filed that I create in Edit > Metadata

  2. And then when I export that metadata field is there and it contains the © copyright special symbol.

If I then
3) close Audacity
4) relaunch Audacity
5) Edit > Metadata
6) Observe: my custom field for Copyright is no longer there (expected behavior)
7) Import the file exported at step2
8) Edit >Metadata
9) Observe: the Copyright custom filed is there - and it contains the © copyright special symbol.

So work-for-me on W10.

Maybe then it is a Mac thing.


Repeating the same test on my Macbook Pro with Catalina 10.15.5 with 2.4.1 and the latest alpha test build I have for 2.4.2

I get the same results - the © symbol can be entered in a custom metadata field and properly used by Audacity.

I can also

  1. use the Template: Save… in Edit>Metadata to save a template with a custom copyright filed the © symbol
  2. Close Audacity
  3. Relaunch Audacity
  4. Edit >Metadata
  5. Observe: blank metadata template
  6. Import the templates saved at step 1
  7. Observe the custom “Copyright” field is there - and with the © symbol

So Works-for-me on Mac as well as Windows.

I do note that although I can enter the © symbol in any metadata field it can never be accepted as the first character input, there has to be some other text first. I can force it to be the first character by typing in an alpha character first, using the bcakspace to delete that character, then enter the © symbol.


Very interesting!

Your method does not work for my Mac. Catalina 10.15.5

How do you try to generate the copyright symbol.

I use Ctrl+V/Cmd+V to paste having copied it fro a special Excel/Numbers spreadsheet I have for special characters and accented characters.


On Mac, the copyright symbol is option-g – ©

Try that.

– Bill

If I use option-g ( © ) as the first character in the Value field, it works.
– Bill

The ID3 information you are entering is added to the file as a ‘TXXX’ frame, not a ‘TCOP’ frame. By “file property” I assume you mean what is shown in the “Get Info” window.

If you really want to see what is inside the file, I suggest using Hex Fiend.

– Bill

If your only purpose in opening then resaving the file is to add copyright information, perhaps you would be better off using one of the free ID3 tag editors available through the App Store. Opening an MP3 in Audacity then re-encoding (exporting) as an MP3 will always result in some loss in audio quality.
– Bill

OOH so it does too - works fine as well for first character typed in a field in my Mac with Edit>Metadata.

Thanks Bill,


Well, I have completely fallen down the rabbit-hole of MP3 tag editing. I’ve found a free and open source editor here:

The Mac download is here:

I’ve downloaded it and it seems to be safe.

If you download it, have a look at its configuration window (“tools” icon in the top toolbar), click the “Keyboard Shortcuts” tab and note the eerie similarity to Audacity’s Key Bindings prefs pane.

– Bill

The ID3 spec https://id3.org/id3v2.3.0 says this about the TCOP tag:

The ‘Copyright message’ frame, > which must begin with a year and a space character > (making five characters), is intended for the copyright holder of the original sound, not the audio file itself. The absence of this frame means only that the copyright information is unavailable or has been removed, and must not be interpreted to mean that the sound is public domain. Every time this field is displayed the field must be preceded with "Copyright © ".

From that I interpret that the © symbol need not be included either in the Tag name or in the Value.

For example, if the copyright in the original sound is “Jane Doe” and the copyright was made in 2019, then, in the Value field of the TCOP tag, you would enter “2019 Jane Doe”. If the software that displays the copyright information is in compliance with the specification, it would display “Copyright © 2019 Jane Doe”.

The Kid3 application allows the creation of a real TCOP tag. It does not enforce “begins with a year and a space character” when entering the value of the tag, but will highlight the field as a “standard violation” if the file is saved with a non-standard TCOP tag and read back in.

So, after all this, my recommendation (“I am not a lawyer!”) is: if you want to add a “real” copyright (TCOP) tag to your files, use Kid3. When Audacity writes ID3 tags outside the “seven permanent tag names” (Metadata Tags Editor - Audacity Manual), it writes a “TXXX” tag.

– Bill