Edit>Labelled Audio>everything greyed out

God damn it, for the first time in 3 years, Audacity has really annoyed me, to put it lightly.

I specifically need to “split delete” a selection of audio, yet when i go to Edit → Labelled Audio, all the options are greyed out!

This this is the case whether i have made a selection or not, whether the selection spans for multiple tracks, etc, nothing works. I haven’t messed with preferences and I have tried the keyboard shortcuts for “split” “split cut” and “split delete”, all of the options are greyed out. (when I try a shortcut, the default windows “error” sound is made as if I can’t do that action).

I am using Audacity 2.0.5, which in my opinion is better than the new ones, and have never had this problem until today. Working with a bunch of layered 24/48 wav files. Have saved project, closed and opened it again, no solution.

Attaching a print screen of the issue, as best as I can. “Silence Audio” actually does the trick, which is a button somewhere else in audacity, but I need these options to be functional.
audacity issue.png

Does your project have labels? (none visible in the screenshot).

In what way(s) better?

You’re probably stuck in the bear-trap of being in Pause mode - Press the Stop button and try again - does that work?

This is one of the many improvements that we have made in later releases - Pause no longer locks you out of doing stuff …


Hi everyone, Sorry for the late reply. I still have the issue, I will attempt to co-operate to help you guys help me solve the issue!

First (STEVE): My project has like 3 label tracks, and many labels, some selection labels and some individual labels. (I would have preferred it if all my labels went onto one label track but after I moved the first label track to the top of the project, subsequent “tracks>add label at section” created new label tracks at the bottom. I don’t know why this is necessary info, but there it is.

Second (WAXCYLINDER): The stop button trick did not solve the issue, sorry. I was not in paused mode.

To reiterate, this is something that happened roughly 1-2 weeks ago, and is affecting all projects. Before this, I never encountered this issue in my months/years of using this version of Audacity.

To be able to edit with the “Labelled Audio” commands, there must be a selection that includes labels. We can’t see if that is the case in your screenshot as you have not shown any of the label tracks.

You’re not kidding? When I have a selection that includes a label, this does indeed work. I suppose my question is answered.

I have never come across this observation before. By the way, are the options also greyed out when there are no label tracks in the project at all?

I ask because I don’t recall ever having to follow this “include a label track/label” rule before.

That said, I guess that was the issue. I am not satisfied with this because I have over 50 tracks in the project and it would be difficult for me to drag a label track next each audio track I want to edit. Alas, thanks for helping me get to the bottom of this.

In old versions of Audacity, if there was no selection, Audacity would automatically select the entire project.
While that option was sometimes convenient, it could also be dangerous because it made it extremely easy to unintentionally modify the entire project rather than just the bit that you wanted to modify.

It is still extremely easy to select the entire project (when that is your intention), by pressing “Ctrl + A” (select All).

You don’t need to drag tracks.

Let’s take a complicated example so as to illustrate how easy it is:

Say that you have 3 audio tracks, “track1”, “track2” and “track3”,
and 3 label tracks “A”, “B” and “C”,
and you want to edit the audio in audio “track2”, that is labeled in label tracks “B” and “C”:

All you need to do is to select the range of audio in “track2”, then use the up/down cursor keys to move focus to label track “B”. (The track with “focus” has a yellow border). Press “Enter” to toggle the selection in label track “B”.
Then use the up/down cursor keys to move focus to label track “C”. Press “Enter” to toggle the selection in label track “C”.

Most cases will be much simpler. Often you will just need to press “Ctrl + A” and then the “labelled audio” commands will be applied to all tracks (assuming that there are some labels in the project).

steve, I must apologise to you for having made a grave error.

The options I wanted to access were in fact under a different section of the “edit” tab. The options I desired were under the “Remove Audio or Labels” section all along.

It turns out that, after having not used Audacity for a while, I had forgotten where the actions were, and after stumbling upon the “Labelled Audio” section, and seeing actions I was familiar with, such as “split cut” and “split delete” I had falsely assumed that these were the actions I was needing. Which isn’t the case.

Turns out I do not need to worry about the “labelled audio” section.

Sorry to have wasted your time. If it’s any consolation, I wouldn’t have solved this issue if it weren’t for your help.

No worries. Glad you’ve got it sorted.