duplicating audio, and changing the rate issue

I’m using 3.2.1 downloaded from Audacity website. I’m using Mac OS Ventura 13.0.

When I duplicate a section of audio, then change the rate of the duplicated section, the whole section of audio (from which the duplicated part was taken) appears at the changed rate, rather just the duplicated section. I’ve never had this issue on earlier versions; been using Audacity since 2009 or 10 but not been on the forum before.

Could you describe step by step what you’re doing? With simple generated audio? That would help me reproduce the issue.
– Bill

I have a section of audio at 96khz. I highlight a 6 secondish section and press command D. I solo the duplicated section, then go to the dropdown bar at the the left of the track, go down to rate and then change the rate to something lower, for ex down to 48khz. when I do that the whole track appears at 48khz, instead of just the duplicated section. When I press undo, it goes back to just the duplicated section at 96khz.

I see what you mean. After changing the rate of the second track to 48000 Hz, the clip is expanded to the right. This appears to be an unintended consequence of smart clips, and I’d consider it a bug.

After duplicating the selection:
After selecting the second track and changing the rate:
– Bill

It looks like a variation of this bug that I logged just a few hours ago: https://github.com/audacity/audacity/issues/3877
@Bill, feel free to add more details to that bug report if you think it will help.

Bill, is there a way to disable smart clips or make the edit destructive? One of the reasons I use audacity is that once I close the file, all the edits are destructive. Forces decisions in the moment.

i tried version 3.2.0 and it has the same problem. I tried 3.1 version but it won’t run on my new MacBook running Ventura.

this is going to make using Audacity the way I do very difficult, only workout I can see is exporting duplicated sections as a wav, then reimporting them and changing the rate but that is going to get annoying very quickly.

Yes. Also, it seems you can do Tracks > Mix > Mix and Render which seems to have the same effect.

But note that the project will not actually decrease in size on disk until compaction takes place on savivg and then exiting Audacity.


Because it is retaining the undo history.
– Bill

Does anyone know how I turn off the smart clips?

Or is there any older versions that didn’t have smart clips that will run on Apple M1 Pro running Ventura 13.0?

The new version of Audacity is currently unusable for a lot of what I do with slowing down the rates, duplicating sections and editing them. I’ve used it for over a dozen years and don’t want to change to something else for what I use it for but it’s just a big headache now.

“Smart clips” cannot be turned off. It’s a core feature of Audacity 3.1.0 and later.

Audacity 3.0.5 and earlier do not have “smart clips”. Rosetta2 may be required to run older versions of Audacity. Older versions are available from https://www.fosshub.com/Audacity-old.html

thanks Steve, that seems to work ok. phew. just need to go through the few things I’ve been able to do since the update and convert the tracks to wavs and reimport them using the older version as they won’t open on the older version. then I can get back to making music.