Delay in headphones

Can anyone explain why there is a slight delay in my headphones while I am recording ? It’s really annoying.
Here’s what I did… on the Audacity Preferences page - Audio IO, I clicked on Software Playthrough. It doesn’t matter if I plug my cans into the line out in back of my computer or if I plug them directly into my Bose speakers, the same slight delay occurs. Is this a problem with Audacity or am I doing something wrong?

No it’s what’s known as latency - basically passing tthe sifgnal through the hardware and software of your computer takes a little time (varies with h/w and s/w).

To avoid such latency when recording you will need to monitor direct from the input side of the soundcard you are using (if using an external soundcard) - or direct from the signal producing device.


Thank you. That makes perfect sense. Unfortunately, I guess I’m stuck because I don’t use a soundcard and my microphone configuration is … I use a Shure KSM27 Studio Condenser Mike powered by a 48 volt PHP1 Phantom Power Supply and there’s no place to plug in a set of cans. Any further thoughts you may have would be appreciated !

I have a Presonus Firestudio Project audio interface. When I plug the headphones into the computer I get that same annoying delay, but when I plug them into the Firestudio I can no longer hear the click tracks or any other tracks. How do I get around this? Thanks. :wink:

Rockindaddy, in the Edit menu, select “Preferences” and look in the “Audio I/O” tab.
What settings do you have in there?


Playback = Realtek HD Audio Output (I think this is my soundcard?)
Other choices are:
Microsoft Sound Mapper Output
Presonus Firestudio Audio

Recording = Presonus Firestudio Audio

I checked the box that says “Play other tracks while recording new ones”.

Thanks for your help.

If you change the playback device to “Presonus Firestudio Audio”, then you should be able to hear click tracks and any other tracks by plugging your headphones into the Firestudio.

“Play other tracks while recording new ones” should be on (as you have already selected)
“Software playthrough” should be off (applies to Windows and Linux - not sure about Macs).

OK, that worked, but when I’m recording new tracks I can hear all the other ones but I can’t hear the current instrument I’m trying to record. How do I listen to previous recorded tracks while laying down a new one and hearing the current instrument without any latency? (I tried checking the box “Play new track while recording it” but I get the delay that throws me off. I’ve got the headphones in the Firestudio. Thanks.

I think you will find that “software playthrough” causes the delay.

Software playthrough should be off (not selected)
“Play other tracks while recording new one” should be on (selected).

I’ve had a quick look at the manual, and oddly, the option to directly monitor the inputs when using the WDM (Windows) drivers does not seem to be covered. If that feature is available, you will need to set it on the device itself, or through the Firestudio control panel (Firecontrol) rather than with Audacity. If you are not able to find how to switch it on, you will need to contact PreSonus, or ask on their forum

The only other solution I can think of is to do your recording in software that supports ASIO (Cubase, Reaper…). You can still use Audacity for editing after you have finished recording.