CTRL+select not working [SOLVED]

I saw a similar post from 2020 but no resolution… CTRL+A selects all tracks but CTRL+left click select only selects a SINGLE track. I recall CTRL+selects working for me in the past (to select multipler tracks and/or toggle selection) and am not sure when it quit working. Anyone else seeing this behavior? Audacity 3.2.1 on Windows 10.

Works for me on W10 with 3.2.1 (and the latest beta I have for the upcoming 3.2.2 and the latest alpha for 3.3.0)


So left-click on the track “Select” button will select that single track. CTRL+left-click on the track “Select” button will add that track to the current selected list (or deselect it if it is already selected).

@jademan Thanks for the reply.
unless I am mis-reading your reply… that is exactly what I’m doing. The steps are as follows:

  1. Select first track (no others are selected at the time)
  2. CTRL+LEFT CLICK next track - what this does is de-select the first track and select the track I am current on

CTRL+A works to select ALL tracks but so the CTRL button is being recognized by Audacity but I’ve not yet found a formula to solve why CTRL+LEFT CLICK is only selecting a single track.

Thanks for the reply - it also used to work for me but I don’t use this feature often and am not sure when it stopped working (or why).
Still poking at it hoping to figure out what is awry.

UPDATE - SOLVED. I was using an old technique of CTRL+LEFT CLICK. I had missed the (to me) subtle change from LEFT CLICK to the SELECT button on the left of the track. WORKING FINE NOEW@

Thanks for the update. I’ll mark this topic SOLVED and lock it.