Crackle when recording on external microphone

Hello, I’m having big problems recording through an external mic - there is a loud crackle. I’ve just bought a new Dell pc and this is the 1st time I’ve tried recording with it. Recording on the internal microphone doesn’t have this problem. I’ve used the external plug in mic many times before on my old Dell, with no problems. I’ve tried the sound settings, although can’t see anything to do with noise suppression. Another problem which seems to be solved for the moment, is I was recording piano and voice, and the piano wasn’t recorded although the voice was - very weird. Is this something to do with Windows 11? I’ve spent many hours turning Audacity on and off, and the pc on and off but the crackle is still there! Any suggestions? Here’s what it sounds like:

What’s the microphone? Make and part numbers?

How did you get rid of the Piano/Voice problem?


Until we get enough info to go on, I tried an experiment. I drag-selected two seconds of “clean” noise (no room noises) and Effect > Noise Reduction > Profile.

Then select the whole show and Effect > Noise Reduction > 6, 6, 6 > OK.

Then do it again.

Then do it again. Three times total…

This may be a despiration method to get somethng out the door until we sort the real problem.


Windows audio enhancements can do that : permit speech, but block music

Dell computers can have a second layer of audio enhancements called MaxxAudio that need to turned off if you want faithful recording & playback.

The electrical “crackle” noise is a mixture of mains-hum, and interference produced by the computer. Try to keep the mic cable away from any mains cable, and away from the computer.

Do you have any lamp dimmers in your studio? That’s the first thing I thought of when I listened to the sample.

There’s something you can try. Start a normal voice recording. You don’t have to say anything. Just move the cables around. The computer is wall powered, right? Move the power cable, move the microphone cable. etc.

I once had a noise problem I could change by touching the microphone.

Turn all the room lights off.

Play the track back and see if the background hash changes.


A lot of more detailed notes are going to have to wait until we find out about the microphone.


Which one? Are you plugging into the computer directly, or through a splitter or hub?


Thanks everyone - so helpful. I’m only recording in an amateur set up - it’s a prosound usb microphone and works perfectly on my old pc. I now have a Dell 14 2 in 1. I don’t use it on mains power because this caused a similar problem on the previous computer, and the microphone is plugged directly into the pc via usb port. I’m going to try the suggestions later today and will let you know. I uninstalled Realtek driver then reinstalledand that seemed to resolve the issue re only recording voice and not piano.

it’s plugged in directly. Tried it this morning, and the external mic is only recording the crackle, and no voice. Also, playback only works when set to Microsoft sound mapper. I’ve tried resetting and defaulting to Realtek but nothing plays back on that setting.

this comes up with empty value and ok is greyed out

no dimmers and I’ve tried moving the cable around etc. no change

thanks to all your suggestions, the crackle has stopped (for now!!), but the recording level is very low despite putting the input at 100%. This is the case on external mic and internal one. What should I do? Thanks

I spoke too soon! Now getting 9999 error message when I try to record with mic!

It still records on Microsoft Array (internal speaker) but it’s very soft despite turning the volume up

ok, I turned up the mic to 100% and succeeded in recording the piano perfectly, no crackle, volume good and all clear. However, when I tried to record the vocal track, I kept getting the 9999 error, so I rescanned audio devices, the mic was in the list. I changed the sample rate on the mic and Audacity to 48000 then the mic was recognised, but all it records is a very loud crackle. I uninstalled and reinstalled Audacity. It didn’t respond several times but then did. don’t know what to do next! Here’s the mp3 of latest attempt

Prosound is a low-quality chinese company. The USB microphone is probably not compatible with the driver that Windows 11 has installed. Contact Prosound for help with an appropriate Windows 11-compatible driver (good luck).

Thanks for your help. The strange thing is the mic worked perfectly recording the piano track, it only started recording loud crackle when I tried to record the 2nd track.

That’s usually a device error, such as “I can’t find the microphone,” or “I can’t find your headphones.”

When you’re overdubbing, playing or singing to an existing track, the computer had to do both jobs at once and everything has to work perfectly.

I can’t find the microphone information. Where are your headphones plugged in?


They are connected via bluetooth and are working fine

Do you hear your voice with crackling when you record? Do you hear your voice in real time with no delay or echo?