Compiling Version 2.1.2 For Windows 10 64-Bit w/ASIO Errors

Hi all,

Apologies if this has been answered before. This is first time I am compiling Audacity and have worked on it for the last 3 days and still have errors and questions. Hope someone can please help me.

I am using Windows 10 64-Bit
Microsoft Visual Studio Community 2013 Version 12.0.31101.00 Update 4
wxWidgets-3.0.2 (and I copied “…\wxWidgets_additions\wxWidgets-3.0.2” over it
Python-3.5.2 (added to Path when installing)
Got latest code using git clone AudacitySRC
I set system environment variables to:

When rebuilding wx_dll.sln I get the following results:
C:\wxWidgets-3.0.2\include\wx/msw/chkconf.h(19): fatal error C1189: #error : “wxUSE_ACTIVEX must be defined.”

========== Rebuild All: 18 succeeded, 4 failed, 0 skipped ==========

When rebuilding audacity.sln I get the following result:
24>C:\wxWidgets-3.0.2\include\wx/msw/chkconf.h(19): fatal error C1189: #error : “wxUSE_ACTIVEX must be defined.”
========== Rebuild All: 21 succeeded, 3 failed, 0 skipped ==========

I’ve attached the output from the wx_dll.sln and audacity.sln rebuilds as well as the : C:\wxWidgets-3.0.2\include\wx\msw\chkconf.h file. :frowning: :frowning:

Also, do I need do edit a file to select an option to add ASIO when I build audacity.sln?
chkconf.h (12.5 KB)
wx_dll.sln Build Output.txt (38.8 KB)
Audacity.sln Build Output.txt (108 KB)

I recommend following this document .

Git clone will give you 2.1.3-alpha, not 2.1.2. You can get the 2.1.2 code here


Hi Gale,

I spent the last 3 days to understand and compile wx_dll.sln and audacity.sln and finally was successful this morning to rebuild an Audacity.exe Release with no errors! Yeah! :smiley: It allowed me to record up to 16 tracks with my Saffire ASIO driver. THANK YOU!

However, I noticed a few things I hope you can please help me with:

Zooming In or Out or Fit in Window was very sluggish, taking up to 3-4 minutes to Fit to Window for a 4-Track 4 GB Audacity Project. Scrolling through the project takes a bit for Audacity to refresh the screen. I have an i7-4470 3.40GHz 8 Core CPU with 16 RAM and 1TB SSD with plenty of free space. The CPU is about 3-10% utilized when this happens. Is this normal when working with Audacity projects? I’m used to opening and working with 6-track FLAC files over 4 GB in Audacity and response is quicker.

I selected all the projects including help in the Configuration Manager when rebuilding audacity.sln, but I did not get the help folder. Instead I get the following message below.

You do not appear to have the ‘help’ folder installed.
Please view the content online or download the current Manual.
To always view the Manual online, change “Location of Manual” in
Interface Preferences to “From Internet”.

Is there a way I can include the help files in my compiled Audacity version like the Audacity 2.1.2 general release does?

The link in Section 7 of the instructions does not exist.

Thanks again, Gale! :smiley:

I’m glad you got it going. :slight_smile:

So did you build 2.1.3-alpha or 2.1.2 in the end?

It’s a known issue in large projects:

The help should get created as a “manual” folder inside the “help” folder in your source tree.

Audacity won’t find that “manual” folder if you are running Audacity from the \win\Release\ or \win\Debug folder\ . If you copy the “help” folder into \win\Release or \win\Debug\ then Audacity should find it, but it doesn’t for me, so there must be some bug there. :confused:

However if you compile then run the Audacity installer (\win\audacity.iss), the help folder will get packaged with Audacity and Audacity will see the help correctly.

Note that whether you built 2.1.2 or 2.1.3-alpha, building the help project will download the latest development Manual (so that for 2.1.3-alpha at the moment). If you built 2.1.2 release then you will want the 2.1.2 release Manual which you can obtain from

Thanks. The page is here: I fixed the link in compile.txt.


Hi Gale,

I compiled 2.1.2 that you pointed me to last week. Guess I could try 2.1.3 alpha. Is that the source code version now on GitHub? That’ll be fun to compile that now that I have my PC environment set up!

I’ll try your suggestions on the help folder tonight and report back.

Thanks for updating the link in the instructions. I’ll do the same in my copy that I annotated and added screen shots to make it clearer for me for the next times I recompile Audacity in the future.

Thanks again Gale. You’re the BEST! :smiley:


Yes. But if you want 2.1.2 release as well, install it, because compiling 2.1.3-alpha will overwrite the audacity.exe in your build folder.


Hi Gale,

I extracted the file to the folder location where I installed the Audacity.exe file and now Audacity shows the help files. Thanks a bunch! I’ll venture to compiling 2.1.3_alpha this weekend and let you know what I think of it.

Thanks again! :smiley:


if you do that I’d be very grateful to hear some feedback on the new improved Scrubbing&Seeking in Audacity 2.1.3.

Gale and I have been working on the documantation for that in the alpha Manual over the last couple of days:

Have a play around too with the new (optional) pinned play/record head:


Hi Gale and WC,

I downloaded the latest code for 2.1.3_alpha this morning from GitHub. When I try to compile audacity.sln, I get the following errors:

3> AudacityHeaders.cpp
3>c:\users\ed roux\documents\github\audacitysrc\src\memoryx.h(736): error C2059: syntax error : ‘{’
3> c:\users\ed roux\documents\github\audacitysrc\src\memoryx.h(740) : see reference to class template instantiation ‘IteratorRange’ being compiled
3>c:\users\ed roux\documents\github\audacitysrc\src\memoryx.h(736): error C2334: unexpected token(s) preceding ‘{’; skipping apparent function body
3>c:\users\ed roux\documents\github\audacitysrc\src\dirmanager.h(14): fatal error C1083: Cannot open include file: ‘MemoryX.h’: No such file or directory
========== Build: 0 succeeded, 1 failed, 21 up-to-date, 2 skipped ==========

I even copied wxWidgets_additions folders and recompiled wxWidgets and still get the same errors.

I am still able to compile 2.1.2 with no errors so my computer’s environment is good, at least with 2.1.2. Is there anything I need to do to compile 2.1.3_alpha successfully?


This looks like an issue that someone else reported that has now been fixed. I think you were unlucky and got the code at just the wrong time. Please try updating your source code.