Clear all Tracks

Is there a way to delete all tracks in a project without closing the project itself?

I know I can click on the “X” in each track, but when there are 4 or more tracks this is a pain!

First time poster…

Audacity v2.2.2 and macOS Sierra… :smiley:

This came up recently. I know I can Command-A select all and then DEL, but that leaves the blank tracks behind.

Do you have an actual reason not to close the Project? Are you going to depend on Edit > UNDO to get you out of trouble later? That leaves behind an enormous data blob when you do that. Audacity doesn’t actually have UNDO. It saves the whole show every time you take an action and just calls up the old show when you UNDO. That’s one reason you can’t UNDO out of order. That and Audacity saves the show in a special, super-high quality format. So it takes up a ton of room while it’s doing all those tricks.



Koz, I have been using Audacity for about a decade to record music, and am finally trying to learn to use it to serious edit audio.

Why not close the project? laziness I guess.

I am playing around learning how htings work, and I guess it seemed to me that if I did a Command-A and then DEL it wouldn’t be as good as deleting the tracks?

I am simply playing around trying to learn how to record on multiple tracks.

Does that make sense?

So that implies closing the project and starting fresh is better?

Mac Audio

Try “Command + W”.

Is there a way when the “Saves changes to project” pop-up appears, to toggle to the “No” button?

(I am used to being able to use the Tab key in many other apps?)


I think that’s supposed to be the same with Audacity, but it seems that it does not work.

On Windows and Linux you can tab through to the “No” button and press “Enter”.
Mac uses the space key instead of the Enter key, so tab through to the “No” button and press “Space”.

Note that it is “normal for Mac” that “Enter” acts on the default (blue) button.

The Tab key does nothing…

That is the problem!

Make sure ‘full keyboard access’ is on. Go to System Preferences > Keyboard > Shortcuts and select the ‘All controls’ radio button. Or press Ctrl+F7 to toggle that setting.


Cannot believe I didn’t know to do that?!

Thanks!!! :smiley:

I didn’t know either :mrgreen:
Fortunately Billw did.

That’s because Bill’s a true Macolyte - you’re a Linuxer and I’m a Windozer with both of us as Mac-amateurs .'… :slight_smile: