Chordino does not remain 'Enabled' [SOLVED]

Hello everyone,?

I’m Running Audacity 2.1.2. I Installed Chordino (nnls-chroma?) in the Audacity plug-in folder shown under the “Analyze” tab in Audacity. It’s not an “ny” extension, but instead it’s a “.dll”. It shows up under “add-remove plugins”, but it doesn’t stay “enabled”. I enable it and then close the plug in manager. When I reopen it, nnls-chroma is once again listed as “New” and not enabled. Happens every time and Audacity does not recognize it under “Effect” or “Analyze”. Does Chordino come in an “ny” extension? I don’t understand why Audacity won’t save it as “Enabled”. Can anyone help.
Thank you.

I neglected to mention that the computer is on Windows 10 - 64bit. I have two other computers which run Audacity-chordino perfectly. One is a
Windows 7 - 64 bit machine and the other is Windows 7 - 32 bit.

Is anyone else having the issue that I describe above…running Windows 10?

Thanks for your help.

I presume that you are referring to this plug-in:

Chordino is a Vamp plug-in.
On Windows, Vamp plug-ins should be installed in: %%PROGRAMFILES%%\Vamp Plug-ins (i.e. a directory named “Vamp Plug-ins” within the system Program Files directory, however localised and on whatever drive is relevant to this install of Windows).

I’m not able to test if it works on Windows because I don’t use Windows, but the 32-bit Linux version works.

Yes version 1.1 from works in Audacity on Windows 10.

If all else fails, exit Audacity and try deleting the pluginregistry.cfg file in Users<your username>\AppData\Roaming\Audacity\ . If you cannot see that folder, type




into the Explorer address bar then hit ENTER on your keyboard.


If you do that by clicking the red window Close button, that is the problem, because the Close is treated as cancel. After enabling a plugin, be sure to press the OK button bottom right of the dialogue.


Thanks, but I’ve been doing that. Nothing seems to work. Every time I enable it and hit the OK button and then reopen the plug-in manager, Chordino is disabled again.

Thank you, your help is appreciated. I had already set up a folder named “Vamp Plug-ins” in both Program Files and Program Files x86. Did not work. Chordino is not the only plugin that will not remain enabled. There are others also, but it’s only on my Win 10 machine. No issues on the two Win 7 units.

On Windows the nnls-chroma plugin is 32-bit only, so you only need to put it in Program Files (x86).

If other plugins are not remaining enabled you should try removing pluginregistry.cfg.

If you can, make a copy of the old pluginregistry.cfg file before deleting it. You could attach the old version if deleting it solves the problem, in case we can see what the problem was in it. Please see how to attach files to forum posts.


I downloaded version 1.1 and extracted the gz file using Winzip. Then I copied the dll file to the Audacity plugin folder. No luck. When I open Audacity and “enable” the “nnls-chroma” file, then OK it and close, it still does not remain enabled. It goes right back to “new”. My next move is to modify the registry as you indicate. I’ll back it up first.

Renamed the cfg file to render it inactive. Opened Audacity and once again I enabled all plugins, including nnls-chroma. Hit OK, close and reopened. Still no luck. It continues to revert back to “new”.

Perhaps I’ll try removing Audacity and reinstalling, although I’ve done it already.

NOTE: I checked the registry and there are no values set for Audacity anywhere. Seems a little odd not to have any values in the registry for this program.

VAMP plugins will not work in Audacity’s Plug-ins folder. Please see the link Steve gave

In other words,, nnls-chroma.dll and nnls-chroma.n3 should go in C:\Program Files (x86)\Vamp Plugins.

It isn’t the Windows Registry. It’s a file in Audacity’s folder for application data.


That will have no effect whatsover on the problem, even if you reinstall Audacity with “Reset Preferences” enabled.

Audacity’s application settings are stored in Users<your user name>\AppData\Roaming\Audacity\ and not in the Windows Registry.

There are settings for AUP file association and uninstallation in the Windows Registry.


I had the plugins installed in the “Vamp Plug-ins” folder on x86 but then deleted the folder when I read on the Internet that Audacity stores its plugins in its own plugin folder. I followed your recommendation and set up a Vamp Plug-ins folder on x86 and copied the three nnls files into it. Still no luck. Must be something to do with my Win 10 configuration. I’ll try deleting the pluginregistry.cfg file again.

Removed the pluginregistry.cfg file again. Didn’t work. Still the same problem. Audacity did indeed find the nnls files in the Vamp folder, but once again will not enable them. Have the same issue with the Ladspa plugins. They too, keep reverting back to “new”.

Very frustrating. But then again, I’ve been with computers since 1984 and have always been frustrated.

Just curious…I assume that the tech folks at Audacity read these forums and investigate to determine what the causes could be. I am not the first Audacity user to have this issue. I’ve read numerous other comments from folks having the same problem…enable does not stick and reverts back to new.

Developers do not read here. QA people of whom I am one do so.

You are welcome to attach the pluginregistry.cfg file and save the log file (Help > Show Log…) and attach those. Please see how to attach files to forum posts. We can have a look at those files just in case.

But I suspect you may need to debug your machine, test with System File Checker, or reinstall Windows. Also check permissions on C:\Program Files (x86)\Vamp Plugins (right-click the folder and choose “Properties”).

As you say, VAMP works in Audacity on your other machines.


Yes version 1.1 from works in Audacity on Windows 10.

I tried to attach the pluginregistry file to this note, but the program indicates " The extension cfg is not allowed".

As I indicated in an earlier post, there are numerous others who have the same issue as I do with this one. Running win 10 does not allow “Enabled” to work in Audacity with some users. I have see quite a few posts on the Internet asking this question. I do not understand why the Audacity tech folks have not come up with a solution. Anyway, thanks for your help.

Tried to show the cfg file as a text message here, but it does not upload. Perhaps because it’s so large?

I added your information as a file for easier reading.

pluginregistry.txt (104 KB)

It is a security restriction to keep the Forum safe, but the solution to that is to change the extension to .txt.

Yes we read that text before. For everyone else but you, deleting the pluginregistry.cfg file solves the problem, as far as I know.

Perhaps the solution is to make it a binary file not a text file.

You did not attach the log (Help > Show Log…) that we asked for.

Did you try System File Checker, and check permissions on C:\Program Files (x86)\Vamp Plugins?

Perhaps you were not aware, but all the developers are volunteers giving their time for nothing.