choppy voice recording

Please listen. Why am I getting drops, fluctuations, just plain drop out choppy voice recording? Using MaC Book Pro. 10.13.3 with usb plug in Audiotec mic. Have tried everything suggested in Audacity manual to no avail. HELP!

No silent-gaps where bits of words are missing, so it’s a buffer problem.
I don’t speak Mac, but this may be what you’re looking for …

Thanks, however where do I find the “Buffer”?

Oooops, found it under Devicesand am now experimenting. Thanks

Went in devices and found “Buffer” It was at 100 took it down to zero and started working back up. Still the same choppy recording. Further sugesstions? Also was I supposed to do anything with the play back buffer? Thanks

Have you tried any of the other suggestions in the FAQ?
– Bill

Can you make it worse? Troubleshooting responds really well to any change, either direction.

Make it so Audacity is the only thing running. Disconnect the network, shut down the WiFi (fan symbol upper right).

Pull up the Dock with all your applications in it. Mine comes up from the bottom.
Screen Shot 2018-03-11 at 20.23.26.png
How many icons do you have with the little glowing dot on the bottom like my FireFox? Open up all those applications and tools and really close them all.

Relaunch Audacity. Still have troubles, or I should say, still have the same troubles? When was the last time you did a clean Apple > Shut Down and then later Start?

There is a way to change APP priorities and I’m fuzzy on that one.


I think you can still get a MBP with a Spinning Metal Drive. Did you? SSDs are very highly recommended for serious sound (or video) production. Do you hear your machine ticking faintly as you go?


Thanks for the input. Tried it all to no avail. I am pretty sure it is something I am doing wrong in the system preferences so will ask if anyone using a MBP can walk me through their preference settings. Thanks again.

Tried it all to no avail.

“It All” meaning shut down all the apps, disconnecting the network, etc?

I don’t have High Sierra, so we need to wait for someone who does. We’re still missing that one step where you can force priorities. I’ve never needed it, so it’s not to hand.


I have a Macbook Pro with a 256 SSD - and using my Edirol UA-1EX to record from HM radio I get no such skips.

My Audacity and MBP settings are all default.


Yeah … shut down everything, restarted everything and have uninstalled and reinstalled Audacity at least three times.

Reinstalling Audacity won’t help.

Sorry, Denis, but we all seem to have drawn a blank. None of us can reproduce the problem (no-one here has your model of MBP), and we’ve pointed you to all the advice we know.

You may be able to use a different program (Garage Band?) to record your programs, then bring the recording into Audacity to edit.

– Bill

Other free multi-platform audio-editors are available, e.g. ocenaudio.

Yep, everything. Shut down restart, uninstall, reinstall …

Hey thanks for the ideas, folks. Using Grarage Band now but wanted more control and still uncertain where the glitch is, could pass it on (?) Will look at that other platform. Again thanks.