changing to WASAPI changes default sample rate to 48000?

Using Audacity 3.1.3 on Windows 11.
I just noticed that if I change on the main Audacity face from Windows Direct Sound to WASAPI in edit/preferences/quality the default sample rate changes from 44100 to 48000.
I don’t remember it doing that other times, but maybe it did…
I uninstalled and re-installed and doing the same.
Is this normal, is it supposed to change default sample rate from 44100 to 48000 when I change from Windows Direct Sound to WASAPI, or do I have some kind of problem here?

If I change back to Windows Direct Sound the default sample rate in edit/preferences/quality stays at 48000, should I manually change default back to 44100?, would default 48000 cause any problems when working with 44100 file?
If I load a 44100 file the project rate at bottom left will change from 48000 to 44100 which is correct, but just not sure if default should be kept at 44100, why does choosing WASAPI change it to 48000?

Microphone options - array intel smart sound tech / speaker realtek audio (loopback).
Speaker option - realtek audio,


Testing on W10 with the current release 3.2.2 and your 3.1.3 I cannot reproduce this,

My project Rate remains at the default 44,100 when I switch to WASAPI


As with Peter, I am unable to duplicate this behavior either on 3.1.3 or on 3.2.2 (current).

No what you are seeing is not normal. In fact, if this keeps happening to you, I would suggest uninstalling ALL versions of Audacity you have on your machine and re-download and install Audacity from here:

If for some reason, you are more comfortable with 3.1.3, you can re-download that from here:

Note that the Default Sample Rate that you specify in Edit > Preferences > Quality is NOT used for the current project. It is only used to set the Default Project rate the NEXT TIME you start Audacity (or create a new Audacity Project). Newly created tracks default to the Current Project Rate which is in lower left-hand corner of your Audacity Window.

I re-installed it 3-4 times, deleting all Audacity folders in AppData Local and AppData Roaming, although I used the same setup .exe file all times.
It seems to only change to 48000 only the very first time I select WASAPI, once it changes to 48000 if I go into default and change it to 44100 and then switch back and forth between Windiows Direct Sound and WASAPI it stays on 44100, so seems to only change to 48000 the very first time WASAPI is selected after installation.
It’s strange, I’m pretty sure when I originally downloaded it 6 months ago it did not have the problem.
I have now downloaded the latest 3.2.2 and do not have the same issue.

Very curious. Thanks for the detailed report. :smiley:

And I am glad to hear you are whole again. :smiley: