Catalina microphone issue with Audacity

Sorry no …

This issue will be fixed in the next release 2.4.0 scheduled for the end of March (I have been QA testing it on my Macbook Pro with 10.15.2 and latterly 10.15.3 where it records fine with no Terminal app workaround required.



The Catalina Terminal workaround as posted in FAQ>Tutorial>Audacity Manual in this forum doesn’t work, as far as entering those specific commands in Terminal. Which is to say, it didn’t work for me on Catalina 10.15.1 with Audacity 2.3.3 - Terminal wouldn’t recognise any of it, as is.
This workaround was posted:

BUT despair not, The Audacity Terminal launch workaround for MacOS Catalina will work automatically using Finder:

This solution is newbie-level simple; No typing anything in Terminal,and should have Audacity recording from Microphone/USB device - as well as allowing audio through to the computer’s speakers/headphone jack (to live-monitor your recording) if you want.

Open a Finder window, click:

Audacity (the app- if you located it here as per default install)
Then on the top bar of window select the button with the cog.
On drop-down menu select “Show Package Contents”

A folder called “Contents” appears, by itself in the finder window
Click to open it, then click to open:

Then double-click:
Audacity (the black-looking exec. file) - which should open a Terminal window and then proceed to automatically launch the Audacity app.
(can alternatively be opened by clicking the cog button>Open With>Terminal)

Wait for a Microphone Permission terminal box to appear to approve permissions (only need to do this the first time) * [see note below]

Audacity will now record with microphone/USB device!

(NOTE if you’re using one, your USB device should be already plugged in prior to app launch in order to appear as a recording input option under ‘built-in microphone’ menu - if not there, plug USB device in and quit Audacity and Terminal, and relaunch as per above method).

IMPORTANT : You have to keep the Terminal window open in background while app is running, otherwise the App will quit too. Also, if you quit the Audacity app, it must be opened via this Terminal workaround again, each time, for it to be able to record anything.

To get audio to play through so you can live-monitor what you’re recording…

Inside Audacity App:
go to Transport (top of screen)

Transport Options
and select “Software Playthrough (on/off)” (should have a tick)

This allows audio to output through computer speakers / headphone jack while recording from the microphone/USB device.
This would only be good turned off if audio output from speaker was interfering with your recording e.g. Speaking live into a microphone. (you could also just mute volume on computer)

Hope this helps someone, as it took me some time to figure this all out when nothing else seemed to work. :unamused:
Hopefully Audacity will upgrade soon and all this won’t be necessary.

  • NOTE : this all requires Terminal to have Microphone permissions in System Preferences.
    Check it if you still have an issue:
    System Preferences app

Security & Privacy
Privacy (tab)
Terminal should be on the list with green tick. Unlock the padlock in lower left corner of window to make changes.

Thanks for this! But I do not get the box popping up when I open Audacity that asks for permission to use the microphone, and when I go to System Preferences, Audacity doesn’t show up in the list!

Do these steps work for you:

I’m having the same problem. Yesterday, Feb 20th, everything worked well. Started Audacity through terminal. No problem. Today, Feb 21st, I can still open Audacity through terminal, but I press “click to start monitoring” the Yeti mic responds for one second, and then nothing.
In “terminal” it says /bin/bash is no good, change to /bin/zsh (terminal preferences), which I tried, and still no mic sound, beyond one second. Any thoughts on this are most welcome.
MacOS Catalina 10.15.3

Thank you so incredibly much for the code and instructions, I have been wrestling with Audacity not recording audio for the last three days, and it was such a relief to see it actually working! All the trouble-shooting solutions that I’d tried up to this point all involved making sure the sample rate was correct and that the microphone was actually paired with Audacity, but everything was set correctly, so it’s a huge weight off my chest now that I can actually begin using the software! :smiley:

Has anyone figured out how to resolve this issue? I’ve seen a couple folks on this board have it. I was plugging along just fine using the Terminal workaround until this evening, when out of nowhere this began happening to me. When I run the terminal command I now get an enormous long terminal list of errors that read like “PaMacCore (AUHUL)||Failed to open AUHAL component” etc etc etc “OpenStream 44100 returned -9986: Internal PortAudio error” (Not just 44100, but also 48000, 22050, etc etc etc). See attached image.

When I am in Audacity, and regardless whether I opened it with the terminal command or in the standard way, when I attempt to play a sound file I get “Error opening sound device. Try changing the audio host, playback device and the project sample rate” and when I try to record I get “Error opening recording device. Error code: -9997 Invalid sample rate.” See images.

Also of note: 1) All these errors happen whether I’m using an external microphone or just my computer’s mic/speakers. 2) Both Audacity and Terminal are granted audio access in permissions. 3) The sample rate is consistent (44110) in all places, Audacity and across my system, and 4) Garageband and Quicktime audio recording both work just fine. Only Audacity is screwed up, it seems. I have also tried reinstalling Audacity to no avail, and even resetting my NVRAM.

Can anyone help me? I am on Macos Catalina (of course) and Audacity 2.3.3 I’m at my wits end and need this for work. Sincere, humble thanks in advance. :frowning:
Screen Shot 2020-04-16 at 9.45.20 PM.png

MacOS 10.15.4
Audacity 2.3.3
I implemented Waldon’s Automator fix which will allow you to call up the Terminal script as an automated application from your dock and it works to enable my Blue Yeti and allows recording in Audacity each time I run the “Audacity Launcher” app from my dock. Once you implement this, it is transparent to you whether the terminal script is running in background. You just open the “Audacity Launcher” app, check your Audacity settings and then begin recording.

In Applications, open Automator app, select Application as document type then Choose.
Select Utilities under Library on left side in first column, double click on Run Shell Script in second column.
The Run Shell Script window opens on right side of screen. Select “/bin/bask” under Shell:, then select as “arguments” under Pass input:
Paste: “/Applications/;” into window just below.
Go to Automator menu bar, select File, Save.

When dialogue box opens, Save As: “Audacity Launcher” for file name (or whatever you want), Where: select Applications folder, select Save.
Quit Automator.
Go to Applications, open “Audacity Launcher”. It should ask for permission to use your microphone the first time.
If it works and you can record in Audacity then drag a copy from Applications to your dock and each time you want to use Audacity, select “Audacity Launcher” from the dock and it will open Audacity by running the shell script and enable your mic.

I went to System Preferences, Security & Privacy, Microphone and ensured the Audacity Launcher app showed up under apps list and was selected.
I also went to System Preferences, Users & Groups, Current User profile, Login Items and added the Audacity Launcher app, so it will always open the app each time I log into my profile.

Chris I LOVE YOU! A virtual, socially-distant hug and high five - you saved me my sanity this morning! :smiley: :smiley: :smiley:

I have Mac OS catalina. I tried your methods several times and it doesn’t work with an external Mic. It works only with your “built in microphone”.
Basically when I select “USB audio codec” and I try recording something I have a flat line.
I tried both methods: Going with the terminal and going to your “application - show package content - Contents - mac os…” and it doesn’t work with “USB audio codec”. Would you have a third solution? I need to record something professionally with my external mic and I am stuck. Thank you!

I’ve tried following your instructions but when I click on Audacity Launcher in Applications, it simply opens up the box that I created and saved. It doesn’t open Audacity itself.
One thing: in your instructions, you say that in the window titled “Run Shell Script,” for “Shell” we should select “/bin/bask.” My window has a “/bin/bash” option but not “/bin/bask.” Was your instruction a typo, or is that why I’m not able to launch Audacity when I open Audacity Launcher from Finder?

Worked for me and thank you! That was driving me nuts. Upgraded from Mojave to Catalina and this was exactly the issue. Terminal command started Audacity and I got the permissions prompt. After that, microphone works again like it did in Mojave.

I just upgraded from Audacity 2.3.3 to Audacity 2.4.2 and it solved the Catalina issue with the internal microphone (or soundflower).

Thanks for the feedback.

I made the mistake of “not allowing” the prompt for allowing the recording and not it does not show up again. How do I get that to reappear?

I think you should be able to enable it in Preferences.

  1. On your Mac, choose Apple menu > System Preferences, click Security & Privacy, then click Privacy.
  2. Select Microphone.
  3. Select the tickbox next to Audacity to allow it to access the microphone.

Greetings all.

I have not yet received an explanation as to why my Right audio is still coming in much quieter than my Left audio when I record via iMic system.

See attached screenshot. I have Audacity 2.4.2 on Big Sur and the same problem exists.

This is one of the reasons why we much prefer each new question in a new topic. If you post in an existing topic, it either detracts attention away from the original poster’s issue, or your question gets missed, or it creates a confusing mix of answers to multiple questions.

So that indicates that it is not an “Audacity” issue, but rather an issue with the sound system.

What is plugged into the iMic? What are you trying to record?

Hi, my first post here having read all those posts on this issue. I recently upgraded to Catalina (from Mojave) and have the no audio issue as well. Did try all the Terminal tricks but never got Audacity show up in the microphone permission list. When trying this command “/Applications/;” however I am getting a list of these messages:
||PaMacCore (AUHAL)|| Failed to open AUHAL component.||PaMacCore (AUHAL)|| Error on line 1263: err=‘-50’, msg=Unknown Error

and still get no entry to grant microphon permission.

I would like to suggest starting a new post for a new problem. Sometimes when you add to an existing (particularly long) post, your query gets lost in the weeds.

So I am a Windows guy, so I cannot help you directly. Until a Mac guy comes along, take a look at this post for ideas and inspiration:

Also, is your Audacity up-to-date ? See here: Audacity ® | Download for Mac OS

I hope this helps. :smiley: