Catalina microphone issue with Audacity

Joined here because I am having issues with Audacity and Catalina. It works in terms of opening, editing, processing and saving projects, the issue is that I am unable to record audio with either the microphone or USB. No sound. Other programs are working fine, so sound is coming into the system, and I’ve tried changing settings to no avail.

At the moment I’m recording raw audio using Oceanaudio and then opening files in Audacity to edit.

Audacity does not officially support pre-release operating systems.

Have you checked the microphone permissions? It may be slightly different on Catalina, but here’s the instructions for Mojave: No recording level

Yes I checked microphone permissions and Audacity was ticked. I also upgraded to 2.3.2 to be sure that wasn’t the issue.

Yes, thank you, have double-checked. It is a strange one, everything appears as it should, but no sound is getting to the app. I am assuming at this point that it’s something to do with bugs in Catalina. Audacity is working fine and seems stable doing what it’s best at, except recording audio.

If I recall correctly, there was a similar problem in the pre-release version of Mojave, which magically disappeared in the release version.

Hi early testers of Catalina (like me)…

I just ran into the same issue — mic can be selected but the monitoring levels are not showing and there is no sound being recorded with macOS Catalina 10.15 Beta (19A512f) and Audacity 2.3.2. Researching a lot and then all of a sudden remembering something that solves this thing (because something similar happened with OBS).

The fix to be using Audacity for recording on the macOS Catalina Beta is to run it through the terminal with the following command:


Open the terminal via Spotlight search for “Terminal” and then copy the code above and paste it — this is granted you have Audacity installed in the Applications folder, if not, adjust the path — now hit ENTER and see Audacity starting and you should get levels when you start monitoring your mic.

You are probably going to be asked to give your terminal access to the microphone in the System Preferences Security & Privacy settings, but other than that it’s working.

Hope this helps everybody who is running the beta of Catalina (and maybe future macOS beta versions).

Happy recording :heart:,


Thank-you Chris! this worked for me on both machines!

Chris’s recommendation worked for me too. Only thing is, Terminal doesn’t complete the processing, so I have to force quit it, which prevents the command from taking effect (i.e., the next time I launch Audacity, it isn’t recognising audial input).

The fix worked for me as well. Thank You !!!

I’m having this same issue but the command did not fully work for me. It allows me to see the microphone monitors moving but then there is no sound or ability to record. Has anyone found a fix?

I have experienced the same issue.
It doesn’t matter if you had already authorized Audacity under Mojave in System Preferences > Security & Privacy > Microphone. Whatever changed in Catalina is causing it to not recognize the old Mojave. I used tccutil to clear the microphone preferences and it still wasn’t recognized and now doesn’t appear in the list at all. I am running Catalina Beta 19A582a.

I do have an improved workaround. The same command to launch Audacity from the terminal can be run from Automator, under actions > utilities > run shell script. Automator can save this as an application which can be added to the dock, making it easy to run Audacity without messing about in the terminal.

Has there been any other solution to this? I can’t figure out the automator thing, and use audacity enough that I don’t want to be using the terminal each time. I just downloaded Catalina as a regularly recommended update and BAM no sound in audacity. Even from my built in mic on my computer. I have to meet deadlines here!

Same problem here. Thanks to Chris for the “Terminal trick.” That works, but when I start Audacity again there is no input at all. So am I correct in assuming that I must open Audacity every time using the Terminal trick until there is an actual solution to this?


See this post:

Thanks for that. So I guess the question now is whether I should try to keep using Audacity with the Terminal trick, or restore my system to the previous OS.

Scott549 , When you launch Audacity from the terminal, are you able to record?

I think that depends on what else works / is broken, and how important Audacity is to you.

The Audacity team is currently working towards releasing Audacity 2.3.3, so at this stage, none of the developers or testers are likely to be updating to Catalina, because doing so is likely to push the release many months behind schedule. Catalina won’t run many of the tools that are used for creating Audacity, and we don’t want to suddenly drop support for Mac users that aren’t using Catalina.

I hope I’m wrong, but it looks to me like the days of running open source software on Macs are numbered. Apple have certainly been purging open source from their own software. Nevertheless, the Audacity developers will be looking at ways to work around these problems.

Yes, when I launch Audacity from the terminal, I can record.

The question I am grappling with is whether this is a reliable solution or whether I need to either downgrade the OS or find another audio recording software. I rely on Audacity to produce a weekly podcast.

If you think that you can downgrade safely, then I’d suggest doing that. You will still be able to update later when things have settled down.

Any reason I would not be able to downgrade safely using the Apple time machine backup?

The fact that it seems to affect recording (for microphones and USB devices as others report) suggests that it may be down to driver issues.