Can't overdub with interface

I can record multiple tracks using a USB mic. However when I connect my M-Track Duo interface I can only record the first track. When I try to add a second track it won’t start recording at all. I can see the signal in the monitor but the transport won’t roll. Same result on two computers. The interface works fine with other apps. Any help would be appreciated.

When I try to add a second track it won’t start recording at all.

Assuming you’re set up for overdubbing in Audacity Recording Preferences, it’s possible the playback side is wrong. Overdubbing is magic because both the record and the playback side have to be perfectly set up and working.

Overdubbing may fail if either one isn’t right. Can you plain, ordinary play music to the M-Audio headphones?

Are both sides of the M-Audio using the same setups? 44100, 16-bit, Stereo. I have an interface that will vanish if the Stereo/Mono setting isn’t right.


I can play sound from other sources ie Youtube & Jamkazam through the interface. Both Audacity and the interface software are set for 44100.

I can record multiple tracks using a USB mic.

Which USB mic?

Which Audacity?


Yeti Mic. I was using the newest Audacity but yesterday I went to an earlier version (I think it’s 2.4.2). Initially that didn’t work with the interface either but I kept playing with the preferences and it eventually started working. Unfortunately I’m not sure what I did to get it to work. I was also using Reaper and when I made some changes in that setup it almost seemed like it affected the connection to Audacity.

Are you closing each application when you’re not using it? I used to regularly get one of the managers at work out of trouble by clearing all the apps he had napping in the background.

When you go into record, how do you do it? Keyboard R key, Shift+R or the red record button in Audacity?

Do you use any of the chat apps? Skype, Zoom, Meetings, etc? Those are famous for changing computer sound settings and sometimes the settings get stuck even after the apps close.

Have you ever done a clean Windows shutdown? Shift+Shutdown > Wait > Start. That should clean out all the settings, changes, and configuration modifications. Do Not allow any apps to automatically start.


Thanks for your suggestions. I did try most of those before accidentally discovering that I can only overdub through the interface when Audacity’s sound output setting is set to something other than the interface. This means I can monitor through the computer’s speaker but not through the interface headphone output. This isn’t ideal since there is much more latency through the computer than there is in the interface headphone output.
Any suggestions?

This isn’t ideal since there is much more latency through the computer than there is in the interface headphone output.

That, at least, is normal. You are listening to the trip into Audacity, turn around and play back out. All take time. The Yeti headphone connection should have no latency since it catches the local sound before encoding.

I looked briefly at the Yeti specifications. For a while there, overdubbing was missing from many microphone manuals, but this one is clear they expect it to work.

They also expect it to work at 48000 sampling rate and not 44100. You might try that.


Just to clarify, I’m not referring to the Yeti headphone output. I mean the computer’s headphone output. When I send a signal into the interface and monitor through the computer headphone jack I can overdub. But when I set Audacity to monitor through the interface headphone output the recording won’t start. It just sits there as if on pause. As soon as I switch back to using the computer headphones and hit record, everthings works as it should.

I think the sun is coming up.

The only way you can do perfect overdubbing—where you hear a theatrically perfect mix in your headphones—is for the interface to handle both the headphone and the microphone.

You can unplug the M-Track Duo interface and leave it on the sofa for a while. Connect the Yeti with its USB cable and use it for both recording and playback. Plug the headphones into the Yeti.

It’s the Yeti equivalent of this:

Screen Shot 2021-11-06 at 11.57.22.png
It’s also possible you can unplug the Yeti and use the M-Track Duo interface. I can’t tell from the instructions. Set that for both recording and playback and plug your analog microphone and wired headphones into the M-Track Duo interface.

You may need an adapter for the headphones. It looks like the M-Track has a 1/4" headphone connection instead of 1/8"

No guarantee the M-Track is going to work for overdubbing. The interface has to intentionally design monitor mixing for it to work.


That is exactly what I am doing. I’m using an analog mic and electric guitar into the interface so I can record both at once onto two tracks. I am monitoring through the interface. I want to go back and add other tracks as overdubs. But when I use the interface to make a new pass the record function doesn’t work unless I change the monitor output in Audacity to the computer headphone output. Audacity does create the new tracks and I can see the signal from the input but the transport won’t start rolling until I switch the output in Audacity back to monitoring through the computer headphones. When I make that one adjustment I can overdub as many times as I want.

OK. That’s where this came from.

I can record multiple tracks using a USB mic.

Connect the Yeti and everything starts working.

Audacity will refuse to roll for record if it thinks there’s something wrong with the data stream. Either the wrong configuration or missing.

I’m using an analog mic and electric guitar into the interface so I can record both at once onto two tracks. I am monitoring through the interface.

So you play the music into Audacity, record it, and you can hear the live performance in the headphones connected to the M-Track? Stop. Play the fresh recording. Can you hear it in the M-Track?


yes I can hear the first pass fine through the M-Audio headphone output. When I hit record again I can see the new track below the original one and hear and see the new signal in the headphones and in the montor display. But when I hit the record button nothing at all happens.

To clarify further I can hear the playback from the first recording through the M-Audio after I have finished recording it.

I think we’ve clicked through all the normal causes of this kind of problem. We can wait for a different poster with additional ideas.


Thanks for your help so far with this. I’ve been using Reaper instead, which does overdub without problems. However I really prefer the simplicity of Audacity so I hope someone else has the answer to my strange problem.

I have exactly the same problem with Audacity trying to use an M-audio M-Track Duo and its native driver. There is just something fundamentally incompatible here.

More likely it’s just wrong settings somewhere. However, given that this topic is now about several different audio devices, there’s probably several different problems being discussed here, with different solutions. Better to start a new topic rather than posting onto the end of an old dead topic.